ondra avatar image

ESS mode ignores BMS BMZ ESS-X control

I would like to ask if it is normal that ESS mode ignores BMS control from BMZ ESS X battery. Configuration 3 x MPII, 3 x BMZ ESS-X, MPPT 250/85, Fronius Symo and AC OUT1, Cebo. All devices have the latest version of FW. Unfortunately even if the BMS battery sends a parameter - CCL = 0A:




so the batteries are still charging. The charger is set according to the manual for BMZ = Absobrtion time = 1. Unfortunately = Absobrtion time is never one hour, even 7 hours at a time.


Status code # 3 should appear in ESS mode: BMS disabled charging, I've never seen it with BMZ ESS X in ESS mode. I run another 4 similar systems with BMZ ESS X and I have also never seen status code # 3: BMS disabled charging.

I'm worried about the batteries, about the safety of operation. I think I overcharge them this way and they could be damaged. Please tell me if this behavior is normal (the battery is not overcharging) or if it is an error. Thanks Ondra

Multiplus-IIESSBMSbattery bms
1615370285457.png (33.4 KiB)
1615370332097.png (12.5 KiB)
1615370439263.png (38.1 KiB)
1615370485292.png (67.8 KiB)
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
Daniël Boekel (Victron Energy Staff) avatar image
Daniël Boekel (Victron Energy Staff) answered ·

Hi @Ondra

first: absorbtion time, etc. is not used when using a CANbus controlled battery, the battery controls charging.

in this case 'absorbtion' means that the charge voltage is reached, and Bulk that it is below target voltage.

second: because ESS is continuously charging / discharging the battery, the system will just keep the target voltage of 61,5 volt, otherwise the battery would stop charging, and a little later charge again.

So as long as CVL is respected, there is no problem and your battery is not overcharged.

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @Daniël Boekel (Victron Energy Staff)

Thank you for the explanation. I'll be calmer right away :-) Maybe this explanation could be part of the ESS manual or the VE Configure setup manual for BMZ batteries ( There would be fewer similar questions.


Hi @Daniël Boekel (Victron Energy Staff)

Unfortunately, it has now happened several times that the battery has been overcharged - see the picture below - CAN-bus BMS battery warning High voltage.


Data from MPPT, here you can see the maximum battery voltage of 61.98 V, while the maximum is 61.5


So I don't think battery charge control is working properly. I have found that this only happens when DC-coupled PV - feed in excess is enabled and the battery is 100% charged.

I use MPPT 250/85 connected via VE.Can. The battery is connected via BMS Can. See settings:


Thank you for your reaction, or for recommending something else to try to avoid overcharging. Ondra

1617437732705.png (71.0 KiB)
1617437749354.png (172.8 KiB)
1617437776937.png (89.5 KiB)

Hi @Ondra

I've learned that the BMZ batteries are kind of special: between CVL and high voltage warnings there is very little room.

When 'feed in excess DC solar' is enabled, the MPPT's get a 0,4V higher setpoint, and the inverters pull this down to CVL (this is how it feeds in), when inverter power is not enough to pull down to CVL, this effect you experience happens. normally no problem for a 48v battery.

In the latest Venus-OS release candidate (and the soon to be an official release) 2.65 there is a setting in the DVCC menu to set a lower maximum charge voltage. for your system this would be ideal.

ondra avatar image ondra Daniël Boekel (Victron Energy Staff) ♦♦ ·

Hi @Daniël Boekel (Victron Energy Staff)

Thank you for your quick response and explanation. I'm using FW in Cerbo-gx release candidate 2.65 - 8, now it's version 2.65 - 9, so I just installed it and adjusted the CVL setting to 61.5 V. If that makes problems, I'll reduce the CVL voltage to 61V. Have a nice Saturday. Ondra

ondra avatar image ondra Daniël Boekel (Victron Energy Staff) ♦♦ ·

Hi @Daniël Boekel (Victron Energy Staff)

So, we have several days with testing new function with DVCC, manual setting CVL.

The task stop with exceeding CVL / overcharging is OK. Perhapas, there is one dissadvantage, which we can see in partly cloudy days (changing cloud with full sunshine). I would like to explain:

The battery is full charge (97% - 100%). CVL is manualy set up to 61V. Allowed grid feed in from MPPT. And we have sunshine and CVL is automatically increased from 61V to 61,4V. The battery is charging with increased voltage. And now, there is cloud (stop sunshine) and power from MPTT is low, incresing about 0,4V is deactivate and battery has for example 61,2V. Now, there is setting CVL 61V and with this start discharging to 61V. When we have voltage 61V, discharging stopped. This cycling we have all day and this is issue for battery timelife. Should be better by manually setting CVL to deactivate discharging from value CVL +0,4V to set up value CVL.

Many thank´s for your support. Ondra

Hi @Ondra

This little bit of cycling is really no issue for batteries.

Also LFP batteries have very little capacity in the fully charged region, so very little energy is actually transferred.