question

stevemarston avatar image
stevemarston asked

Cerbo GX wifi issues

Hi all,

so the cerbo GX and Wi-Fi connectivity including connection to a mobile hotspot.

i have been reading for a while about some Wi-Fi issues, so thought i would pop in my experience.

most cerbos i have fitted, do not want to connect to Wi-Fi or a hotspot. however I have found, that if I roll back the firmware to V2.56 I do not experience any connectivity issues.

this seems to be working for me and the last 5 cerbos fitted connect without any issue.

cerbo gx
4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Eddy avatar image Eddy commented ·

I had also same problems with it. Always while connecting to a wifi surfstick. My own systems runs perfect this way, Some other of my customer don't like it. Changing from surfstik to a router and connecting via LAN solved the problem sadly in an expensive way.

0 Likes 0 ·
Sam Salwei avatar image Sam Salwei commented ·

Having the same issues. Upgraded to 2.63 and now I can not see my system on the vrm.

Are there plans to fix this?

Are there any plans to increase the cerbo BT interface?



0 Likes 0 ·
Hartley Gardner avatar image Hartley Gardner commented ·

I just installed my Cerbo - no Touch attached, and it refuses to see my boat wifi router which is about 18 inches away! I can connect to the AP in the Cerbo with my fone or laptop, and connecting via Ethernet works 100% - but the Cerbo just won't see the other network.

Edit to add: Firmware 2.73, which was updated when I brought it online Thursday.

0 Likes 0 ·
seb71 avatar image seb71 Hartley Gardner commented ·

but the Cerbo just won't see the other network.

Is your Wi-Fi (from your Wi-Fi router) 2.4GHz? If it's 5GHz, Cerbo can't see it.

Does your Cerbo detect any other Wi-Fi networks (if you know there are other close by)?

If you don't have other Wi-Fi networks close by, make a 2.4GHz Wi-Fi hotspot with a phone and check if that Wi-Fi network is visible (by your Cerbo).

0 Likes 0 ·
5 Answers
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi Steve and others here: there is an issue with the Cerbo wifi when having a GX Touch installed.

Details & solution here:

https://community.victronenergy.com/questions/82877/cerbo-gx-wi-fi-issue-when-having-the-gx-touch-conn.html

My apologies for the issues to all of you.

I checked our logs and changes since Steve noticed that rolling back to v2.57 makes it better; I can’t see a reason for that.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ commented ·

Ps I’ll accept my own answer so its quickly found by anyone happening to find this page

0 Likes 0 ·
Sean avatar image
Sean answered ·

I am having similar issues. Can not connect to phone hotspot and doesn't find other wifi networks in close vicinity.

Any progress to fixing this issue?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

andrewcp avatar image
andrewcp answered ·

Hi,

My Cerbo didn’t want to connect to my home wifi… it worked fine on my phone hotspot…

after a bit of stuffing around to get it to work I had to:

- seperated 2.4 and 5ghz wifi in my router setup

- change the 802.11 Mode to mixed 11G/B (turn off N)


not sure why but that seems to have worked for me.


cheers,

ap

3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

ses avatar image ses commented ·
Hi Andrew, having same issues with Cerbo GX installed lately. Scanning for wi-fi the cerbo shown the neighbor modem, cerbo's own signal and when my phone hotspot is on it shows but not client's T-link modem. No problem for me to connect to client wi-fi with my mobile.

Any other solution than to change client's modem settings ?

Thanks

Daniël

0 Likes 0 ·
nickdb avatar image nickdb ♦ ses commented ·
Have you checked that the T-link has the 2.4 gHz radio enabled for wifi? If it is 5gHz, it will not be found.
0 Likes 0 ·
ses avatar image ses nickdb ♦ commented ·
Not familiar with modem settings but will give it a try when I go there next time - many thanks
0 Likes 0 ·
rob-smith avatar image
rob-smith answered ·

My cerbo GX is not used with a touch screen, is on v2.64 and randomly stops talking to the wi-fi. Wi-fi supplied via a Google mesh 5m away.

£330 spent installing the thing because: 1 - victron BT is utter tripe in many ways, 2- victron bmv712 is useless at accurately indicating battery level and doesn't give a breakdown Inc history of what's actually been used, 3- I have no way of knowing what the status is when I'm away, 4- I want to kick start a generator when voltage drops too far.

Without wi-fi 1 and 3 are simply not supported and the convenience of 2 and 4 is severely impaired.

Without reliable wi-fi the cerbo GX is simply not fit for purpose.

Victron are rumoured to be the best in the business, if this is the case then fix all of your issues, your kit is very expensive for the issues it has


2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

seb71 avatar image seb71 commented ·
After v.2.60 they made a change with Wi-Fi which fixed some things, but also degraded the Wi-Fi (lost connection) for some cases (including mine).


The current Cerbo GX firmware (v.2.73) or the current beta (v.2.80~36) have some Wi-Fi improvements over your v.2.64.


Still, in may case the best Wi-Fi was with v.2.60.


As a workaround, you can set the Cerbo to reboot if it has no connection for a certain (settable) duration.


If a wired connection (UTP/LAN/RJ45 cable) is not an option, you can also improve the connection by using an Wi-Fi USB dongle.

0 Likes 0 ·
nickdb avatar image nickdb ♦ commented ·
I have never seen a wifi issue with devices with good signal (all 3 bars not just 2). The occasional bug where on a disconnect (say reboot etc) it does not reconnect, but setting the reboot-on-no-comms option sorts this, helped as well with improvements in newer code.

You'd be surprised by how people forget that wifi does not go through walls and is susceptible to interference from other nearby access points.

Eliminate signal and interference and everything seems to work.

0 Likes 0 ·
mipl avatar image
mipl answered ·

OK, here "my Issue".

a couple of days I got my new Cerbo GX with Serial Nr. HQ2215xxxx - so brand new. A Touch 50 is not connected. Nevertheless it was over two days not possible to connect to my local router over WiFi. The router was not seen by the Cerbo GX. OK, my router is able to connect on 2,4 an 5 MHz. So I disabled the 5 MHz. Later I reduced Signalstrenght because other routers (neighbors) were listed, but my router not. That all don't help.


At the end I set my router fix to channel 1, 100% Signalstrenght, 2,4 and 5,0 MHz and everything works now well. So there must be a (automatic selected) channel that doesn't work.


Perhaps this helps some of you.


Regards - Michael

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.