question

gilemon avatar image

Grid feed in excess power not working anymore in ESS (keep batteries charged) mode

Hi,

After I have replaced my Smart Solar 150/85 with a brand new VE.can rev2 model, the ESS Grid Feed-in option does not work anymore in "keep batteries charged" mode.

screen-shot-2021-01-23-at-41104-pm.png

screen-shot-2021-01-23-at-41115-pm.png

The system is attached to the grid most of the time and I'm using the batteries for UPS application.

Basically when batteries are fully charged, the MPPT does not output any power anymore.

screen-shot-2021-01-23-at-40944-pm.png

If I disconnect the grid input momentally and I reconncet it so that the batteries get recharged, I can verify the PV and charger output some power.

screen-shot-2021-01-23-at-35113-pm.png

Also with the old Smart Solar 150/85, this function was working perfectly.

I have no DVCC and this is what's shown on CCGX under SmartSolar MPPT VE.Can 150/85 rev2 > Networked operation tab:

screen-shot-2021-01-23-at-40430-pm.png

So far I tried:

  • Updating CCGX firmware to latest 2.6.
  • Changing battery monitor from BMV-700 to Quattro

but nothing helped. What am I missing?

Let me know if you need more information about the configuration.

ESS
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
gilemon avatar image
gilemon answered ·

It has been a month now and I'm still in same situation.

I have tried "Optimize, and set the minimum SOC to 100%" but it is oscillating constantly. When battery is fully charged it starts using inverter (MPPT/solar + batteries) after 5 seconds it recharges the batteries, then after 5 seconds for a moment (1 second) it does not use MPPT anymore. This dance makes the battery balances go crazy. It does not seem healthy to me.

I also tried enabling DVCC (I had to upgrade Multi firmware to v481), without any change.

The only way I found to force using all the solar input, is by cutting the grid input and forcing battery discharge for 10s. After this the solar is used again to charge the battery back. And after it reaches 100% the excess solar it used in the Multi again.

This is quite annoying because I need to constantly monitor the ESS/CCGX and still this leads to a lot of wasted solar energy.

11 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Not sure what is the cause (except maybe the new MPPT, since you say that your system worked perfectly with the previous MPPT), but try "Optimized without BatteryLife" in ESS and set the minimum SOC lower than 100%. For instance 85%. Then see if it works as it should and then go from there.

Thanks a lot for your advice, but I can't use "Optimized without BatteryLife" in winter. My battery bank (1300Ah AGM Gel) cannot handle the AC load (>5kW) for more than 15 minutes.

Just for better understanding of the issue, following is today's VRM historical data (very sunny and warm).

screen-shot-2021-02-21-at-52359-pm.png

Well, above you said that you "waste a lot of solar energy".

You don't have to use this mode permanently. Just for a day or two, for testing.

85% SOC is not that low, anyway. If your battery can't handle the load for more than 15 minutes, then what's the difference?

Thanks again. I get your point. So I tried it and I'm indeed using all available solar power now as you can see:

screen-shot-2021-02-23-at-61839-pm.png

But at the cost of depleting the batteries, having constant "Low battery" alarms, and the multi is changing mode every few minutes. This doesn't look like it's really usable long term.

With 95% SOC you get low battery alarms?

What are your low voltage limits set to?

Indeed there is something I need to get clarified here. The inverter settings in VE Configure are:

  • DC input low shut-down=37.20V
  • DC input low restart=43.6V
  • DC input low pre-alarm=43.60V

But the alarms show as soon as voltage is below 48V.

screen-shot-2021-02-24-at-110730-am.png

This happen when there is a load >5kW, so I thought it was normal, but when compared to these inverter DC settings, now it seems odd.

Is there something else I need to check? BMV?



When using ESS (as it is your case), those values are overridden by the Dynamic cut-off values you set in the ESS assistant.

Thanks again for clarifying this as quickly.

So the setting on the ESS assistant are:

  • AGM batteries 1300Ah
  • Sustain voltage during first 24 hours 46.00V
  • Cut off voltage for a discharge current of:
    • 0.005C=48V
    • 0.25C=46V
    • 0.7C=45V
    • 2C=44.8V
  • Inverting is allowed again when voltage rises 1.2V above cut-off

It seems there is something wrong as the load equivalent would be:

  • 0.005C ≃ 78W
  • 0.25C ≃ 4kW
  • 0.7C≃ 10kW

I have set the max inverter power to 4kW and this function works well.

So according to these I shouldn't go over 0.25C and alarms should only comes if V < 46V. Right? Which is not the case as I do have alarms when voltage is under 48V. Kind of like it behaving if C was much lower. Do you know how this is calculated by the ESS?


Those are cut-off voltages, not voltages for alarms.

This is not clearly explained in the manuals, but when using ESS the low voltage alarms apparently are given at (cut-off voltage for that current draw) + (the hysteresis which is set for inverting again after a cut-off: 1.2V).

I found a automatic solution which is really far from optimal with a crontab job on the ccgx.

2 13 * * * dbus -y com.victronenergy.vebus.ttyO1 /Mode SetValue 2
3 13 * * * dbus -y com.victronenergy.vebus.ttyO1 /Mode SetValue 3

This is kind of doing the trick so far, as it's avoiding wasting these few solar KW every days.

But still, I'm sure I'll need to add some more thinking into this as it might become a problem in some situations. An obvious one being, when I need peak current exactly at this time (13:02).


Following on this issue.

I have replaced my Gel batteries + BMV with a lithium solution with integrated BMS and the problem is gone. The MPPT is now fully charging all day long (without the nasty cron job trick...).

screen-shot-2021-04-01-at-101306-am.png

I guess something was wrong with the battery monitoring.

I'll reinstall this battery bank + BMV on another ESS system. So if the problem comes back and if I managed to fix it, I'll explain how I did it here.