laurenceh avatar image
laurenceh asked

VRM overview display incorrect because of duplicate devices

I have multiple copies of some devices on the VRM probably because they have changed port. The result is that the VRM system overview is not displaying solar information (and perhaps BMV information, see this example.


You can see that the solar and consumption data from about 4 weeks ago is shown but not the more recent data.

But historic data for for the last 2 days shows solar data here:


but not here:


My system is all connected and reporting correctly in real time:screenshot-2020-11-03-at-174432.png

I connected my system together once (to check it all worked) then wired it up neatly and reconnected but obviously not on the same USB ports.

I have seen a similar reported on other posts but it does not appear to have been answered satisfactorily.

I have deleted devices from the device list as shown here:


But they still appear in the advance TAB device list - where you say what graphs to display:


I also suspect that at least once device may be from when I ran the system in demo mode for a few minutes to check something.

My Venus GX device is a Raspberry Pi but I dont think it is anything to do with being a Raspberry Pi so I am posting this question here as the right place to post it.

The connected equipment is:

  • MPPT 150.35 VE.Direct->USB
  • BMV 702 VE.Direct->USB
  • Multiplus Compact VE.Bus -> MK3 ->USB

Venus OS 2.6

Is there some sort of master reset that can rescan and get the VRM to sync up?

I don't mind losing the historic data as long as it is working for the new new cruising season.

VRMRaspberry Pi
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
Guy Stewart (Victron Community Manager) avatar image
Guy Stewart (Victron Community Manager) answered ·

Hi @LaurenceH,

If you are happy to purge all previous history, this is probably the easiest way to go.


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

laurenceh avatar image laurenceh commented ·


Thanks, I wondered about doing that.

The installation is on my boat 100miles away. I saw the comment:

"after deleting, the device needs to be rebooted to resume sending data to the VRM portal."

My only means of rebooting right now is via the remote console on the VRM and of course if I delete it, I cant access the console. I could connect to the console with my phone via the VRM (then delete the VRM entry from my PC) but assume that as soon as I delete the device the console access will stop ?

Is the best advice to wait till I am next on the boat, or can I complete this remotely?

0 Likes 0 ·
laurenceh avatar image laurenceh commented ·

Well here is an update:

In case anyone comes across this thread when they have the same problem.

After the advice provided by Victron support (thanks Guy). I came back the next day and it was fixed. I had changed nothing so I presume that the guys at Victron had taken a look at the VRM displays and tweaked a few things. I do hope this was a general fix - which will work for everyone who finds their devices have changed ID. While I would appreciate the 'personal' hand from Victron, I'm far more interested in contributing so that everyone benefits from product improvements.

Here are a few shots of what I see on the dashboard graphs now:



Very nice - thank you Victron.

0 Likes 0 ·
Rene Mullie avatar image
Rene Mullie answered ·

I have exactly the same issue (also Venus on RPi), after a reboot of the RPi the devices have an other ID (289 -> 290) or something like this. The USB converters (VEdirect & MK3usb) are in the same USB socket in RPi.

It would be nice if the Venus OS will keep same IDs over a reboot.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.