Seppo Rantala avatar image
Seppo Rantala asked

Issues with VENUS GX internet connection in DHCP mode

First time setting up the VENUX GX box (firmware V2.21) I tried to use automatic IP configuration mode (DHCP) for the Internet connection. The Venus box got an address 192.168.x.y which does not match to our network IP address subnets. Our network has a Linux based DHCP server (dhcpd) and it works fine for instance with Linux and Windows laptops. Could it be that VENUS GX does not support Linux based DHCP?

Fortunately, workaround for this was easy; to assign a fixed IP address. After that, the device could be found in the VRM cloud ( ) and firmware SW could be updated to V2.22.

Just asking this, if I want to use DHCP in the future..

Best regards,

Seppo Rantala

Venus GX - VGX
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
markus avatar image
markus answered ·


"This should have worked" may not be, what you want to hear.

To help you further, you might need to provide more details of your LAN and DHCP server configuration.

It sounds strange to me, that your Venus received some 192.168.X.Y address not matching your IP subnet, as this address has to come from somewhere else. Does your linux router do DHCP or do you have a separate linux DHCP server beside your router?

Maybe you have 2 DHCP servers running on your LAN?

DHCP lease addresses are used up?

some static DHCP server address leases, based on Venus MAC address configured?

Do you use VLANs?

Do you use the same DHCP server for LAN and WiFi? If yes, what happens when you connect to WiFi with you VenusGX?

Have you tried some other (new to this LAN) devices to connect. Do they obtain a DHCP address?

So much questions. :o)



1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Seppo Rantala avatar image Seppo Rantala commented ·

Hi Markus,

Thanks for your answer! I examined further our network and found "a rogue DHCP" server. Someone had plugged D-Link wireless router to our network and due to erroneous plugging (LAN port connected to "upper" network, not WAN), D-Link was acting as second DHCP server in the network.

I will return to this topic if still some issues with Venux Gx's automatic IP configuration mode.



1 Like 1 ·