question

thisbus avatar image

BMV SOC Sync Error?

I have a SmartSolar MPPT 150/85 charge controller powering a bank of 5 x 100Ah LiFePO4 batteries.

My batteries are charging everyday and reaching 100% (14.4v). I am able to manually sync the BMV at this point to show SOC 100%. However, after a few days the system 'learns' and corrects the SOC and always shows 0% even when in the high 13v range.

I've tried dropping the charged level to 14.2 as suggested in the manual and changed the charge time to 10 mins but my BMV won't learn correctly.

Any help or thoughts?

MPPT - Solar Charge ControllerBMV Battery MonitorSOC
1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I'll also add that from the history tab - Time since last full charge - is only ever the time since I manually sync the BMV. It never thinks it's hitting full charge. However the voltage reading is hitting 14.4 (or 14.2) and the MPPT is reaching Float each day.

2 Answers
wkirby avatar image
wkirby answered ·

My first thought, did you set the battery capacity (500Ah) in the BMV?

1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Yes. Battery capacity is set to 500Ah

wkirby avatar image
wkirby answered ·

Is the shunt wired the right way around with the battery side going to the batter and the loads side going to loads and charger. Also there are no loads connected directly to the battery negative side.
Sorry if I sound condescending, but these are common errors that people make.

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.