question

Daren Connor avatar image

SOC in VE Bus is not matching the battery

I have 3 x 48/5000/70 multiplus in a 3 phase configuration which is fed by a 15kw Fronius 3 phase solar inverter.

Lately the SOC in VE Bus does not match the batteries. This causes the SOC to stop st 90% SOC when the batteries are at 57.6v which is the absorption voltage. Sometimes it will sit at 90% for 3 or more hours waiting for the batteries to meet the SOC before going into absorption. I've tried everything I can think of but I'm obviously missing something. Even my installer is at a loss. Can someone please help. Thanks in advance...

battery chargingSOCVE.Busabsorption
8 comments
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

It gets to 90% SOC but the batteries are only 55v so it waits at 90% until the batteries reach the absorption voltage of 57.6 then it finally starts absorption. Any ideas?

@Daren Connor

Are these batteries with their own BMS or managed only through the VE Bus?

Managed only through VE Bus. All firmware is the latest on all 3 multiplus & the ccgx.

Since I dont know many details about your install. We start with basics which is are the battery cables the right size for the system? The most common cause of what you are describing is voltage drop. Or extra resistance points along the cable such as breakers or fuses may be causing an issue. Are you using a lynx shunt or any thing like that?

It's been running fine until I had a complete shutdown one day when the generator shut off under no load so I was told to update the firmware in the multi's & that will fix that problem, which it did.

Since updating the firmware it has been doing what I stated. I've had this system for over 5 years & it has never missed a beat until the firmware update. I even rolled back the firmware to a previous version but that didn't help either. It's like the batteries aren't synchronizing with VE Bus anymore..

It seems must be settings then. Were the previous settings kept from before the firmware update and then reloaded; or was it treated as a new install?

Show more comments
1 Answer
Mark avatar image

Most likely your current battery monitor settings in VE.Configure are inappropriate for your battery bank.

Regardless what settings you expect have been copied over from the original FW, as the new FW is so much newer maybe that didn't totally work.

Specifically check the 'battery capacity' and the 'charge efficiency'.

It is likely that the battery capacity is set too low and possibly charge efficiency is set too high.

There is a setting 'state of charge when bulk finished' and it sounds like you have it set to 90% SOC (which is reasonable) - so the battery monitor is correctly following this logic. The issue is that it's not accuracy tracking the batteries true SOC % well.

Lastly, do you have any DC loads powered by the same battery bank? As the VE.Bus battery monitor would not consider these loads in the SOC % calculations.


12 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I have a 1350ah lead acid battery bank, it's set at the default charge efficiency of .95 & bulk finishes at 90%.

These settings worked perfectly well in firmware 209 but for some reason in 459 it holds at 90% until the batteries get from 55v to 57.6v. That can take up to & even over 3 hours.

The system was actually working perfectly with 209 until a problem occurred during a generator shut down & a victron representative told me to update the firmware which did fix that problem but created a much worse problem. That was over 3 months ago & I'm still battling with it. I've adjusted charge efficiency, charge rates, even adjusted the PV assistant but nothing ever changes the fact that the batteries & VE Bus are not synchronizing. I'm at a complete loss.

Mark avatar image Mark ♦ Daren Connor ·

So you have confirmed that 1350Ah is programmed in the battery monitor - correct?

In your case, next step I recommend is to perform a proper full charge cycle so that the battery really gets to 100% SOC and you have a proper synchronised baseline for the battery monitor to work with going forward. To do this you may need to temporarily change to 'fixed absorption' time and keep charging at absorption voltage until the charge current flowing into the battery tails off to about 1% of your battery capacity (so about 13.5A).

Also, how far down do you normally discharge the battery each day? If not much/only to ~85 or 90% SOC, it might be more accurate (for your usage profile) to try increasing the 'SOC when bulk finished' setting to ~95% SOC.

Yes, that's correct. 1350 is programmed in.

I have also taken it to full charge using the generator many times but the next day it's back to usual. I normally discharge to about 55 - 60%.

Mark avatar image Mark ♦ Daren Connor ·

How did you confirm that the batteries were really 100% full?

What did the charge current drop to at the time that absorption phase ended?

Also does it fully recharge back to 100% SOC (confirmed based on tail current) regularly?

The other thing to do is to run a controlled discharge test (from 100%SOC down to 0% / 42.0v at exactly the C20 discharge current to confirm that the capacity the battery monitor is working with is really correct.

Under generator it charged up to 57.6v then went into absorption & held 57.6v for the absorption duration then went into float where the voltage dropped to 54.5v.

I have discharged the batteries till the generator started but that's around 46v, by memory.

Mark avatar image Mark ♦ Daren Connor ·

You need to look at charge current at the time absorption ends - otherwise you are guessing/assuming.

Mark avatar image Mark ♦ Daren Connor ·

It also sounds like you may be charging with a very low charge current (in relation to your battery capacity) in bulk phase, so it takes a long time to increase the battery voltage to the absorption voltage setpoint.

The charge current in bulk phase really needs to be at least 10% of your battery bank capacity - so at least 135A in bulk for a 1350Ah battery bank. (Upto about 25% or ~340Ah for your battery bank).

If your normally charging with PV but don't have sufficient PV available to do this year round that is another likely reason for your VE.Bus SOC% issue.

Show more comments

At the moment, the SOC is saying 86% & the voltage is 54.0v. By the time it gets to 90% it will barely be 55v so the system will sit at 90% until the batteries reach 57.6v then it will go into absorption.