question

timofei-pasechnikov avatar image

Battery Monitor [512]: Alarm: Internal error alarm - Quattro and Pylontech US2000 Battery

Hello,


This alarm appears very often: once in two or one day. System components: Venus GX firmware 2.33 (downgraded because with new firmware there occurs fimware insufficient alarm), Quattro 48/5000/70 firmware 430, BlueSolar MPPT 150/60 firmware v1.47 and Pylontech US2000x3 battery.


When this alarm appears, battery shows red ALM and starts to make continuous beep noises.

Share link: https://vrm.victronenergy.com/installation/43728/share/ebb50a16


What can be done to solve the problem? Picture of battery with alarm is attached to this post.

What is the reason of this alarm? How could the setup/settings be changed to avoid or reduce the alarm event? System setting I took from pylontech manual (https://www.victronenergy.com/live/battery_compatibility:pylontech_phantom)


Best regards,

Timofey

Venus GX - VGXPylontech
1580800530108.png (844.0 KiB)
1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hello,

Yes, I have the same issue in our installation:CCGX firmware 2.39 or 4.22, Quattro 48/5000/70 firmware 430, BlueSolar MPPT 150/35 firmware v1.47 and Pylontech US2000x4 battery.

I noticed that alarm was raised due to battery fully charged. If you disconnected Ac input, then alarm will be cleared. In our system this error appeared every a week or several weeks when 100% fully charged. The system still fully functional when the error happened.

I have contacted pylontech for this issue, but they have no idea what is wrong with it. They suggested to read the battery internal log data and look at it. But we do not have chance to visit the site yet.

6 Answers
Ned Yu (Pylontech) avatar image
Ned Yu (Pylontech) answered ·

Dear @Timofei Pasechnikov


I'm sorry I didn't pay attention to your question until recently.Please see the diagnosis results and suggestions from Pylontech technical team below.


The cause of this alarm message:Our battery has a kind of BMS logic:When the battery is not charged or discharged for 3 days,always in idle state. The battery will automatically shut down and go to sleep mode.Only when the battery is charged or discharged again, by then the battery will automatically activate.

So when there is a battery to sleep mode and shut down, our Master battery will light up red light and send message to the inverter show there is an internal alarm. (You can check the first three days of the alarm record, the battery will be used once.)


What I want to highlight fist is that. This is a normal BMS logic of our battery, to reduce unnecessary self discharge consumption loss of the system.it will not affect the normal use of the whole system or cause damage to the system. So don’t worry.


This situation usually occurs when the inverter sets the battery to the backup power supply, or UPS mode. The battery is not used as often, and it is usually left unused after being charged to 100%.

The solution:

1.Determine the working mode of on-site situation. If the customer does not want to use the back-up mode, please set the battery has priority over the public-grid to power the load.


2. If the customer only wants to use the battery as a backup power source, The customer can limit the inverter to charge the battery only up to 90% not 100%, so that the battery will not enter the standby state.


Hope these information will help. Please let me know if you have more questions.

2 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hello, thank you for explanation.


Yeah, at first these batteries were used only for backup, were always fully charged. I found next solution to avoid this error if you use it only for backup: setup ESS assistant and choose "Keep batteries charged" mode.


Now it all works fine :)

Glad to hear that and thanks for your advice!

Daniël Boekel (Victron Energy Staff) avatar image
Daniël Boekel (Victron Energy Staff) answered ·

Hi @Timofei Pasechnikov and @Alan Peng

'internal error' alarm is not something Victron can do anything with.

Please read out the battery, or ask your installer to do this for you.

1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

And to go further: also please update firmware of Victron devices so they're on the latest firmware.

John Hobill avatar image
John Hobill answered ·

Hi there.

I also have a 512 error and not sure if its driven by Victron firmware or if its BYD battery or some other issue. Would like to understand what is going on here.

I am off grid and not 'attached' to the grid.

My troublesome battery is 'turned off'

my system is as follows;-

Victron MultiPlus 5KVA Inverter /Charger BYD / Kratos Lithium Battery bank and 2 x Cabinet 4 x modules 4 x 2.5KWH total 20KWH

Victron MPPT SmartSolar charge 60A Victron Colour Control GX System Monitor

pic show 8th battery with run error.


any hlep is appreciated.

Thanks


john

battery-bank-5-8.jpg


battery-bank-5-8.jpg (743.1 KiB)
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

warwick avatar image
warwick answered ·

Please talk to Pylontech. I think this has something to do with the batteries not being able to supply the current required by the Multis. See the table below from the Victron Pylontech documentation recommends 4 batteries to be able to supply current required by 5000VA.

8127-f853e28d-5ac8-4b3e-aeec-33c05566b1bb.png

From: https://www.victronenergy.com/live/battery_compatibility:pylontech_phantom


1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @warwick and thanks for your reply. I can't speak for the other users experiencing issues, but in our case we actually have 6x of the US3000 (75Ah) batteries connected to the Multi. I'm fairly certain that the alarm is permanently on - power cycling everything at the site makes no change and the alarm turns on again. Cheers.

leon-zimbabwe avatar image
leon-zimbabwe answered ·

Good Day I have a EasySollar 5 KVA and 3 pylontech batteries I keep on getting a alarm Pylontech Battery Alarm Internal failure any suggestions please my system is only 2 months old.Kind Regards leon

1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @Leon Zimbabwe

'internal error' alarm is not something Victron can do anything with.

Please read out the battery, or ask your installer to do this for you. to find out what errors the battery gives. if you know the error, please tell us so the rest can learn from it.

stratanet avatar image
stratanet answered ·

We also have the same problem; the system was installed about a month ago (also Pylontech) and so far nobody knows why this is happening. Glad I'm not the only one!

GX firmware v2.42 (latest as of writing), Pylontech firmware 456 (no idea about firmware with these).

Looking for updates on this if anybody finds out anything.

1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @StrataNet

'internal error' alarm is not something Victron can do anything with.

Please read out the battery, or ask your installer to do this for you. to find out what errors the battery gives. if you know the error, please tell us so the rest can learn from it.