question

Ruireis avatar image

PowerAssist is not engaging, and overloading generator

I have a 3 X Multiplus 5k 48V configured as 3 phase system and 7KW of solar panels and 480 amp hour batteries. I have connected a 6.5 KVA 3 phase generator.

On Veconfig general page

configured 7.5 Amp input current limit per phase and enabled current limiterPower assist.

On invertor page

Enabled Power assist and assistant boost factor 2.0


When The generator is charging and output load is low the current limit controls the maximum generator load well to about 4kW

But when output load starts to increase close to the maximum generation load the PowerAssist does not kick in to assist with invertor load from batteries, instead the generator load starts to increase to above 5KW eventually trips generator breaker.

Can some one help me to identify why PowerAssist does not help when aditional power is required.

configpowerassist
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

6 Answers
Ruireis avatar image
Ruireis answered ·

Good evening

I have now upgraded the firmware to 469.

But I still have a problem.

Once I start the generator and ac in synchronised it goes to ac in and bulk charging in all 3 phases.

If I start a load for example a vacuum cleaner 1500 watts the one phase will go to power assist invertor on and the other two phases will remain in a.c. in and bulk charging.

So far so good but when I stop the vacuum cleaner and load drops suddenly.

All 3 phases go to invertor on and disconnects from generator it then takes a short while until it synchronizes again.


Thank you again for your great support.


I have one question.

Is there any configuration that once you start the generator it will be dedicated to battery charging and all 3 phases remain on invertor supply at all times.


I know that in one hand it is less efficient and looses about 20% charging but in other hand I can then load the generator to maximum load possible without derating much and the output loads will be very stable with a clean supply at all times.

Best regards,

2 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I think in the moment you turn off the vacuum cleaner the voltage of the generator goes up above the upper limit set in the Multis.

To your question:
It's not possible with the Multis because the same transformer is used to make AC out of DC and vice versa.
For this you have to use a separate charger but unfortunately there are not many 48V models available.
For 24V there is a 3-phase Skylla.

Hi @Ruireis

on rejecting ACinput when a load drops (?), probably the generator output exceeds the maximum settings (voltage and/or frequency) causing the inverters to disconnect.

Do you use any grid-code? otherwise tweaking the grid settings and / or 'UPS mode' setting might help.


on the other question: the Multi / Quattro's are a bidirectional inverter, so it's either inverter or charger, not both at the same time.

Ruireis avatar image
Ruireis answered ·

To use victron connect I need a password?

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Ruireis avatar image
Ruireis answered ·

Dear john

I don't have access to victron professional.

The last firmware loaded was 2624433.


Is it possible to send me the latest file.


Thank you.


1 comment Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Ruireis avatar image
Ruireis answered ·

Hi Guy

I have now purchased the cable.

Can you please send the latest firmware update so that I can upgrade.


Best regards,


Rui Reis

1 comment Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Sign in here as an installer.

https://professional.victronenergy.com/accounts/login/?next=/

You'll need to match the particular firmware file to your device, but you'll find the latest there.

Ruireis avatar image
Ruireis answered ·

Good morning Guy

I have not done the firmware update because l need to purchase the mk3 to usb cable first.

Once I am ready I will contact you to provide me with the latest firmware version.

Thanks for your support.


Rui Reis

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Guy Stewart (Victron Community Manager) avatar image
Guy Stewart (Victron Community Manager) answered ·

Hi @Ruireis,

What is the sizing of the Generator breaker? For a 7.5A per phase input current limit, I would suggest a minimum 10A breaker per phase, and better 12A to prevent nuisance tripping. Especially when the breaker is de-rating with heat.

The 6.5 kVA 3 phase generator should be able to deliver 9A per phase. That might just be too close to your target 7.5, when accounting for hidden power factor in some of your loads.

Perhaps try reducing it to 6A and see if that improves performance.

You also did not mention if you had enabled the DYNAMIC current limiter - this would also be recommended, if not already done.

After trying that, I would also suggest you make sure that the Multi's are running the latest firmware (467). Remember to back up your settings first. https://vimeo.com/373208468

There have been some improvements around 452 that improve performance of PowerAssist.

2 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Guy

Thank You very much for your prompt reply.

I am not sure what is the size of the generator break, it is mounted on the generator unit and I can not see the rating.

Hi have reduced the current limit to 6 amps and I can now see that power assist kicks in.

It is still a little sluggish, the generator is running at 3200 watts and bulk charging I then started a vacuum cleaner and the power assist kicks in in one phase and generator load drops to 2800 watts. (I was expecting that generator load would be maintained)

so far OK but when I switch off the vacuum cleaner the sodden drop in load it disconnects the generator and goes back to invertor in all 3 phases.

Yes dynamic current limiter is enabled.

I have also tried to disable Week ac input on charger but does not work it becomes unstable, so I had to go back to enable Week AC.

The Multiplus Firmware version is 433.






Good to hear there was some improvement, with the change in settings.

Have you undertaken the firmware update yet?