fash avatar image
fash asked

AC Charging issues


I have an EasySolar 48/5k/70a that is being very temperamental when it come to charging from AC from my genny (7Kva Honda).

It's pot luck seemly as to whether it will charge from it or not. I'm firing the genny manually.

The SOC on the Colour Controller is always showing 100% even when the BVM reads otherwise, the BVM is connected to the Colour Controller. The BMV reads 80% when the voltage across the batteries (4 x 200aH AGMs) seems low (46v across the bank)

The days are cloudy and dull so I'm having to (try) charge on a daily basis. Tonight it won't accept it at all. Previously it accepts the power for about 20 seconds, then rejects it, then accepts it again until it gets to about 90% SOC (on the BMV) then stops charging.

I have watched the AC power input and it rapidly rises to 3Kw and sometimes 3.2, sometimes this seems happy, others not. I see in the menu that the current limit is 40a but at 3.2KW this is way more.

The colour control is not ethernet connected so feels quite restricted in what I can alter but is there something I'm missing here?!

Any help is very welcome, I don't want to loose these batteries yet!


battery chargingEasySolar All-in-One
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

4 Answers
JohnC avatar image
JohnC answered ·

Hi Fash. I've answered this (briefly) on another of your threads, but of course there I assumed you have internet/VRM access. Gets tough without that or a MK3 adaptor and a lappy to run VEConfig.

On your GX, go Device List > Multiplus > Input Current Limit. Try resetting that way down to (say) 8A. If that won't stick then it'll need enabling in the Multi via VEConfig.

And that mightn't be the issue anyway.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

fash avatar image
fash answered ·

Thanks John

I'll have a go today. I'm guessing it's better if it is connected via ethernet, I just need to source a new switch to go with our setup!


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

fash avatar image
fash answered ·

Progress made! Not completely convinced as to why but managed to push the batteries up 98% (into float mode) so very happy!

I adjusted the current limit to 20a but it looked like it was still drawing the same from the genny and it seemed to charge at the same rate as when it was on a 40a limit?!

I have the CCGX now fully reading and displaying the BMV info :)

I also switched on the DC reading which I'm not sure why (curiosity!) and whilst charging this fluctuated quite randomly! It also says there's a 10w DC draw which could be true as I run some LED strips outside the EasySolar....or is this the EasySolar drawing power?

Here's a screen shot of the CCGX, can someone tell me why the Genny is showing 3.2Kw but the battery shows 2.8

And the DC thing?!

Here's a very brief clip showing the DC out varying....

Thanks again :)


img-1812.jpg (122.6 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

JohnC avatar image JohnC ♦ commented ·

Yeh, good to see you're getting somewhere. If the Multi was actually rejecting the genny in the first place, then it's likely to return (I suffer this too). Murphy's Law says it will happen on some foul day when you most need it.. :)

The GX screen will rarely balance. Broadly, it's to do with the sampling times of each of the readings. They don't match, so nor can the balance. They are 'best effort' readings anyway, also the Multi isn't 100% efficient, so ac-out/batt can't hope to equal ac-in. Unless you actually have dc loads, that box is just confusing.

I'm intrigued though by your 51A into 200Ah of batts. Never seen an AGM maker suggest that high, and I wouldn't have thought they could do it anyway. Are they getting hot? Touch them? Take care Pal.

0 Likes 0 ·
fash avatar image fash JohnC ♦ commented ·

Hi John, intersting to hear yours drops out too! Pot luck?! If there''s a fix, let me know!!

I've not noticed the batteries getting warm, although I've not actually fondled them mid charge...but they're bound in insulation to keep the worst of the cold off them so I'd have thought I'd have noticed some extra heat popping out the vent. I guess they get 3Kw from the panel array when the sun is good so they seem (fairly) happy! They've been on solar for over 3 years now, albeit on a much smaller rig till this summer. They're showing signs of being tired (ageing) but was happy to see 100% SOC on them tonight as I've got back from work, sitting at 52v :) and thats at zero degrees outside now too!

Here's hoping the AC charger behaves :D

Thanks again


0 Likes 0 ·
elvistherv avatar image
elvistherv answered ·

So I found that when the current limit on my Quattro was set too high for the genny it would sync, then try and draw too much from the genny which would cause the genny to stop generating 9or at least to reduce the voltage/RPMs so the Quattro disconnected from it.
When I set it to the right level for the size of the genny it would sync and then start charging, note that when it was charging it didn't actually seem to need the full capacity of the genny but seemed like it tried to initially ramp up the current draw to the limit and then reduce it to the actual level required to charge the batteries.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Related Resources

Additional resources still need to be added for this topic

EasySolar 1600 product page

EasySolar-II GX 3000 & 5000 product page