question

Marcus Fosker avatar image
Marcus Fosker asked

AC Current Limit when using ESS as a grid parallel system

I have a Multiplus II GX system which is installed with the ESS application. It's connected to the UK grid via a single phase 100A supply, connected to AC IN of the Multiplus.

All loads and an AC coupled solar inverter are also connected to AC IN of the Multiplus.

The Multiplus is able to balance the grid supply close to zero, charging the batteries off of solar and discharging them as required. I also have time of use tariff which enables the Multiplus to charge the batteries over night.

The issue I have is that I run a lot of loads over night in the cheap period of my tariff including a 32A electric car charger. This regularly take my load over 50A.

The Multiplus needlessly regulates its own charger down in this period and on occasion supplements my grid supply from batteries. This is needless and results in me not having a full battery bank at the end of the cheap time-of-use period.

I can't increase the current limit beyond 50A on the Multiplus or seem to disable it. It is not needed in a parallel grid connection as I have it, as far as I can see.

Can somebody advise me as to whether I have missed a setting or if this is something Victron need to consider in a future firmware update. I want to be able to heat my water, charge my car, batter bank, run my dish and clothes washers during my off peak period!


Multiplus-IIESScurrent limit
11 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I am not sure if I understand correctly.

You are using the scheduled charge feature in the ESS menu to disable discharging from the battery during the off peak time period you want.

Setting the target charge to 0% (so the battery doesn’t charge from the grid), and the set the time it begins, and for how many hours.

During that period the battery should not discharge to power loads.

But you are saying that it is discharging the battery during this period?

0 Likes 0 ·
Marcus Fosker avatar image Marcus Fosker Guy Stewart (Victron Community Manager) ♦♦ commented ·

Thanks for getting back.

I'm using the scheduled charging to attempt to charge the battery during the off-peak period of my time-of-use tariff. I want to exit this period with as a high state of charge as possible.

I am also using my grid connection for other loads at that time. e.g. charging my car, doing clothes washing, heating water.

All loads, including the Multiplus are connected to AC IN, so the Multiplus is parallel to the loads.

When the total load of my grid connection reaches about 50A the Multiplus starts to limit the power of its charger and also supplements the grid connection. I do not want it to do either as I have a 100A grid connection.

0 Likes 0 ·
elel avatar image elel Marcus Fosker commented ·

Hi Marcus,

I am going to install a grid tied Multiplus II 5000 with similar load/battery connection as yours. I am also going to charge the battery during the low cost off-peak period. Have your solved the problem you encountered? If yes, what was the course of the problem and how did you solve it?

0 Likes 0 ·
Marcus Fosker avatar image Marcus Fosker Guy Stewart (Victron Community Manager) ♦♦ commented ·

It is as though both the PowerAssist and PowerControl functions are enabled and are functioning when they should not be.

Please could you advise how I disable them.

0 Likes 0 ·
Rob Duthie avatar image Rob Duthie Marcus Fosker commented ·

Hi

You disable them by using VE configure configuration software.

0 Likes 0 ·
Marcus Fosker avatar image Marcus Fosker Rob Duthie commented ·

Thanks for getting back to me. In the Inverter Tab, I have PowerAssist "unticked". In the General Tab, I have AC Input Current Limit set to 50 Amps. I cannot set it to 100 Amps, nor set it to disabled.


Is this how it should be?

0 Likes 0 ·
Marcus Fosker avatar image Marcus Fosker Guy Stewart (Victron Community Manager) ♦♦ commented ·

I've taken a video of the Multiplus performing a schedule charge with no SOC limit set. When I start the car to charge, you will see the Multiplus throttle down its charging, then start up the inverter, all during the scheduled charge. This isn't what I was expecting from the ESS Assistant.

The Multiplus is installed with the grid and loads all connected to AC IN on a 100AMP feed to the grid with the intent of using cheap electricity stored from grid over night and excess solar produced in the day from a grid tie AC inverter, so there's no need to perform this PowerControl and PowerAssist type function.


Video of VRM console

0 Likes 0 ·
pau1phi11ips avatar image pau1phi11ips Marcus Fosker commented ·

I've got the same connection set up. The Multiplus is actually in my campervan plugged into my house mains 24/7 so there is only connection to AC in. Only AC out loads are the local 240Vac in the camper. I'm using the scheduled charge on Octopus Go and then letting it power my house during the day.

There's definitely something amiss with your setup as it shows the current going through the Multi instead of like mine.

screenshot-2022-11-19-at-121542.png

I take it you're using an ET112 meter to monitor the grid usage?

  • Settings > ESS > Grid metering = External Meter
  • Settings > ESS > Inverter AC output in use = Off
  • Settings > Energy Meters > {your meter} > Role = Grid Meter

0 Likes 0 ·
garethcurtis avatar image garethcurtis commented ·

Can't offer any help but just wanted to say thanks, really useful to read that. I'm in the UK and have the same set up (though not the electric car yet!). Hope you get it sorted.

0 Likes 0 ·
twista avatar image twista commented ·

Hi,


I am about to start a ESS system much like this too, so am interested in your problem.


Is this happening because the MultiPlus is limited to 50A for the AC input? It can't cope with 63A input.

It is able to output 63A from the 50A input and 13A from the battery.

Or is it not as simple as this?

Phil.

0 Likes 0 ·
Rob Duthie avatar image Rob Duthie twista commented ·

You need to ask your self what are the loads doing and for how long yes it can add the battery and ac mains together you need to setup via VEconfigure setting called power assist set to value to suit.

Regards

Rob D

NZ

0 Likes 0 ·
6 Answers
Rob Duthie avatar image
Rob Duthie answered ·

Hi

The current is the maximum of the inverter type model 3kw is 32 amps the 5kw is 50 amp.

What sort of battery do you have in your system?

And how is the power wall integrated?

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Marcus Fosker avatar image Marcus Fosker commented ·

I have the 32A Multiplus II GX. The battery is Lithium Ion with a CanBus BMS.

The Powerwall (Multiplus) is connected to Grid on its AC IN. The current sensor is plugged in and connected to the grid meter tail so it can measure import/export.

I've used the ESS Assistant.

My layout is as per this reference model from Victron with the exception I am not using the No break loads option on AC OUT 1. Given the reliability of the grid in the UK, there's little point.

Victron ESS has a scheduled charging function to allow you to top up the batteries during off peak rates on a time of use tariff. They say "

It allows you to set up to five scheduled periods, during which the system will take power from the grid to charge the battery. This is typically used to charge the battery during off-peak tariff time windows (TOU). For each schedule, configure a start-time, duration, and optionally set the percentage up to which you want the battery to be charged.

If the target state of charge is reached, and it is still within the period of time set, the battery will stop charging but will not discharge (unless there is grid outage). This optimises battery cycling and still allows room in the battery for PV charging."

My system is not only failing to charge as it limits its charger based on the current limit setting but also discharges the battery during the charging time, contrary to what's stated above.

Hopefully Victron will change their software such that when installed as per below, one can set the current limit as per their grid connection, rather than artificially constraining it and discharging the battery when there is no need.


0 Likes 0 ·
1570661495198.png (124.7 KiB)
Rob Duthie avatar image
Rob Duthie answered ·

The Lithium BMS has charge control setting parameters as well?

The battery discharging could be the BMS thinks that the batteries are full so will discharge a bit off the top as mine does also the setting for the lithium battery,

Need to check these settings for the lithium battery type Absorption setting and float setting and SOC when bulk finished when i had these set wrong the battery would charge up an then discharge down to these settings odd behavior, once change the battery now charges fully up now and doesn't discharge like it use to.

Also check the battery ESS mode is set to Optimized (without battery life) Note there are so many setting etc which is convoluted

in operation i have found.

I have a very similar system to yours, i don't use charge scheduling at all, i use to but had some issues so changed to a normal ESS control.

And all works as normal.


Regards
Rob D

NZ

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Marcus Fosker avatar image Marcus Fosker commented ·

My batteries cells are set out in a 16S arrangement and I currently charge them to 64 volts. Experience now tells me I should have gone with 15S, but that is not relevant here and I shall change them later. The settings I use on the Multi are:

Absorbtion voltage: 64 volts

Float voltage: 63.8 volts

The Multi very rarely reduces its charge current with these settings, unless there has been little load and a very long, sunny day. I do not believe this is contributory to the issue I'm experiencing now with the Multiplus II throttling charging when 50 AMP grid load is reached and then discharging during the Scheduled Charging session.

The BMS is a Batrium system connected via CAN BUS. The parameters shared with the Mulitplus from the BMS are:

Charge Current Limit: 90 Amps

Battery Low voltage: 48 volts

Discharge Current Limit: 180 Amps

Max Charge Voltage: 64.8 volts

You can see the BMS often limits the discharge current when the battery reaches a low SOC or a particular cells reaches a low voltage, however charge voltage and charge current are rock steady.


I also use the Optimized (without battery life) so as not to have the low SOC point changing.

I use the Scheduled Charging function from 00.30 to 04.30 each day as my electricity supplier has a low rate to encourage electric vehicle charging and day use off setting through home storage solutions.

Thanks for your suggestions and looking into my issue - I appreciate it. I hope Victron are also able to come back with some advice/a view too.

0 Likes 0 ·
1570701998827.png (27.2 KiB)
sean avatar image
sean answered ·

I have an almost identical setup, 250kWh of leaf cells, Batrium, parallel MPIIs etc etc

I use a ET112 for metering, which is rated for 100A max

The MP CT (which I believe is being used by the OP ?) is rated at 32A - it will likely be saturated at 50A and give rather erroneous results.




1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Marcus Fosker avatar image Marcus Fosker commented ·

You're correct that although it's a 100A/50ma CT, Victron do rate it at 32A max. If I can get the behaviour to work as I'd like, I should replace this with the ET112 meter.

I'm not sure it's the root cause of the issue I'm experiencing though and I think my issues are caused by an error in my config or my misunderstanding of Victron's manual.

My issues are two fold:

1) When the input current (loads in house plus MP-II charger) exceeds the level set in the Venus GX (or via VEConfig in the General Tab), the MPII inverter starts up and assists the grid during a ESS schedule charge session. I've overcome this by using Node Red to switch off the inverter during the schedule charge window, using TCP Modbus.

2) When the input current exceeds the level set (as above) the charger reduces its current to attempt to keep the input AC current below the value set. In VEConfig I can set this to a max of 32A, in the console of the Venus GX, I can set this to 50A. Ideally I'd like to turn the function off or set it to the 100A limit of my breaker.

Victron's manual says that you "can" set a value for this Current Limiter, but in my case so far, it's more of a "must". I can't find a way to not set a value.

Please would you share your config with me?

PS. 250kWh! I am envious - I have 12kWh of cells from a Mitsubishi Outlander PHEV.

0 Likes 0 ·
llyr-roberts avatar image
llyr-roberts answered ·

I have the same issue. Multiplus set to 50A input current limit.


Victron Multiplus 5000 plus 7kwh of Pylontech

The Multiplus input current limit and the grid input current limit need to be separated out.

The grid should be set to take 100A

The Multiplus input can be kept at 50A

As soon as the grid hits 50A the Victron limits the charge current to the battery.


So there's a fundamental issue with the software that stops us from doing, for example:

50A to battery

50A to any other house loads

100A total


We're being limited to 50A total from the grid!

13 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

shaneyake avatar image shaneyake commented ·

CT can only be set to the Max rating of the transfer switch.
You should install an ET112 instead of the CT in this application.

0 Likes 0 ·
mrrikp avatar image mrrikp commented ·
Have you made any progress on this issue? It turns out, I am experiencing the exact issue, but I’m using the ET112 as a grid meter.
0 Likes 0 ·
craigc avatar image craigc mrrikp commented ·

I had an issue like this where I misunderstood the purpose of the "Grid current limit" in VRM and set it to 32A to limit the amount of current the Multiplus-II would produce. However, because my setup has a CT clamp on the main tails, this limit was being applied to the entire installation, so if my grid load exceeded 32A then the batteries would stop charging and would instead attempt to assist the grid to keep it below 32A. Since I have a verified 100A main cutout and fuse, I changed this to 100A and all has been well since.

screenshot-2022-11-27-at-002530.png


To enable this control in VRM, you first need to go to Settings - General and enable the "Inverter/Charger" control. This then enables the above controls in the Dashboard and you just need to click the little settings icon at the top right of the screen.

I hope this helps.

0 Likes 0 ·
davebaldwin avatar image davebaldwin craigc commented ·

I too have the same issue on 2 systems. Both with Multiplus 2 48/5000 and Pylontech batteries. One system has heat pumps and the other a car charger and when the grid input power exceeds 50A the battery charging is reduced or even worst the batteries are being discharged to support the extra load. Timed charging for 4 hours is setup for Octopus Go tariff. Both setups have 100A supplies and all loads are on the ACin side of the Multiplus. CT on the grid tails.

I have been through all the menus on VictronConnect Remote, VRM remote and VE Configure but cannot find the one you are showing. Please can you be a bit more specific in what you have changed?


Thanks,

Dave.


0 Likes 0 ·
craigc avatar image craigc davebaldwin commented ·

Hi, assuming you've got your system set up on VRM and assuming you have set up the ESS Assistant, then you should be able to go to Settings in the VRM sidebar menu, then General. In this page you should see a section entitled "Inverter/Charger Control" which can be toggled on. I think it defaults to off.

Once this is toggled on, you should be able to go back out to your Dashboard view and click the little icon at the top right which looks like two toggle switches surrounded by a rounded rectangle (pic below).

screenshot-2022-11-28-at-133115.png

When you click this icon a panel will slide in from the right like the one in my earlier screenshot.

Hope this helps.

0 Likes 0 ·
mysik avatar image mysik davebaldwin commented ·

just follow the instruction in the picture below:victron.png

0 Likes 0 ·
victron.png (185.8 KiB)
shaneyake avatar image shaneyake craigc commented ·

You can also just check the input current limit on your GX. It is the same value as on VRM.

This won't have effect if you are using a grid meter and you should set this to the inverters input/grid breaker value.
screen-shot-2022-11-28-at-23657-pm.png

0 Likes 0 ·
davebaldwin avatar image davebaldwin shaneyake commented ·
Thank you all for the detailed replies. Unfortunately I don't have the Inverter/Charger section in the settings/general page. Any ideas as to what I need to change to get it?


I have:

Realtime updates

Installation avatar

Delete this installation


Dave.

0 Likes 0 ·
davebaldwin avatar image davebaldwin davebaldwin commented ·

I found I needed to enable Remote VEConfig in the Device List page to get the Inverter/Charge Control switch in the Settings/General.


So now I can see the Grid current limit setting and can change it but when I try to increase it beyond 50A I get the message "Value not accepted! It was automatically set to the next acceptable value."

Cerbo GX firmware v2.92

Multiplus firmware v492

So it looks like there is still some other setting I am missing.

Dave.

0 Likes 0 ·
craigc avatar image craigc davebaldwin commented ·

I'm running the same Cerbo GX version as you but I'm on v500 on the MP although v498 also allowed me to set the 100A grid limit.

Another point that might be relevant is that I'm using the external CT clamp on the MP2 which is clamped around the main incoming line tail. This is mainly why I need a higher grid limit than the 50A which the MP2 can transfer, because I have other loads such as EV/Cooker/Shower that don't go through the MP2.

Another thing to mention is that there is a setting in the "General" section VEConfigure 3 called "External current sensor connected" which I have enabled. I don't have knowledge of your setup but you might need to enable this if you are using an external CT clamp like me. See the manual here: https://www.victronenergy.com/media/pg/VEConfigure_Manual/en/general-settings.html

0 Likes 0 ·
davebaldwin avatar image davebaldwin craigc commented ·
Thank you so much - it was the using external CT in VEConfigure that unlocked increasing the current limit beyond 50A - have the same CT setup as you.


Dave.


0 Likes 0 ·
hackerp avatar image hackerp shaneyake commented ·
Is it possible to change the value from the GX?
0 Likes 0 ·
shaneyake avatar image shaneyake hackerp commented ·
Yes, if you go to the inverter on the GX, it has an input current limit setting, you can change it there. Look at my screenshot above.
0 Likes 0 ·
mrrikp avatar image
mrrikp answered ·
Watching this thread with interest as I’ve just had my system installed and o served the same thing; except, I am using the ET112 energy meter at the grid incoming point, not a CT clamp. When my grid total load is >50A, my Multiplus regulates its charge current down to try to stay below 50A, and in some cases, actually starts to discharge during an ESS charge cycle.
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Richard Norman avatar image
Richard Norman answered ·

Hi your ess behaviour is odd I have a mp2 48/5000/70-50 in an ess with et112 grid meter, setup the same with acin only used, I have a reasonable run from the consumer unit to the garage where the ess is setup and have a 4mm cable so have a 25amp limit set on the mp2 but I'm not seeing a limit on charging or poweraasist type behaviour during time of day charging (ev, ess battery, Eddi, dishwasher, even a second car sometimes).


Feels like a firmware or configuration issue rather than a design issue a hopefully one that you can resolve without needing victron to change anything.


See example below, I wasn't drawing more than 50amps but more than the limit set on acin, I will have a look at grabbing my config details for you but it essentially followed the ess setup guide for pylontech, I have a cerbogx as the centre, v2.9.2 and I'm still on v498 for the mp2.


screenshot-20221222-194800.pngscreenshot-20221222-194625.png


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.