question

ee21 avatar image

D.Bus from command line - no error, but setting was not applied, what am I doing wrong?

I am attempting to change the ESS Mode from it's current setting, Optimized with Battery Life, to Keep batteries charged, using this command, while logged in as root from the command line:


root@beaglebone:/usr/bin# dbus -y com.victronenergy.settings/Settings/CGwacs/BatteryLife/State9


Previously, I had been using "State 9" with a space in-between which was throwing an error. The command above without a space returns no errors, but when I check the console, ESS is still set to Optimized.


Can anyone provide any insight as to what I am doing incorrectly?

Venus OSCyrix Battery Combiner
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
ee21 avatar image
ee21 answered ·

I managed to figure out the correct command after dusting off the Unix cobwebs. The final command that worked was:


dbus -y com.victronenergy.settings /Settings/CGwacs/BatteryLife/State SetValue 9

1 comment Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Good job. And in some cases you’ll need to use %9, to make it an int instead of a string. See google.