snafu avatar image
snafu asked

MPPT stopped charging


I currently run a system with two MPPT (100/30 & 100/20) and a smartshunt together with 2 gell batteries in a campervan.


A couple of days ago, the smaller MPPT charger stopped working. It might be related to a firmware update, but I do not know if the time correlates.


The PV Voltage appears to be ok for charging, I checked the ones reported with a multimeter, and they are

Interestingly enough, the battery voltage of the 100/20 is quite off from the other devices and is correct if checked on the terminals. If I remove the battery cables and theck them directly, the voltage correlates with the other devices.

I already tried a restart (removing and reinserting all wires), factory reset, and "toggle charger" to no avail. Any ideas?



battery chargingMPPT SmartSolarsmart solar charging behaviour
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
klim8skeptic avatar image
klim8skeptic answered ·

@Snafu Your 100-20 is reading very low battery voltages, and is showing low yield.

There is most likely a blown fuse in the mppt (or battery lead) or a bad connection between the mppt and battery.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

snafu avatar image snafu commented ·
Hi @klim8skeptic ,

thanks for your answer. I tried some constellations to debug this a bit further. For this I switched PV connections of the MPPT chargers. This showed the "problematic" 100/20 MPPT working, but the original panels not workign on the 100/30 Charger either.

My conclustion is, that I might have faulty cableing or that the panels have some issues. I'll investigate further. Thanks for the hint with the cables...

0 Likes 0 ·
klim8skeptic avatar image klim8skeptic ♦ snafu commented ·

@Snafu Test your solar panels and array wiring.

Dont fall off your roof, or burn anything down tho..

0 Likes 0 ·

Related Resources