question

jamierob avatar image

MPPT 100/20: does PV need to be connected for blueooth connection?

I have a SmartSolar MPPT 100/20 and just got it installed. It's hooked up to the battery and the blue light is blinking denoting that it's on, but not charging anything. I fire up the VictronConnect app on 2 different iphones and a mac laptop and none of the devices can 'see' the controller in the VictronConnect app. Do I need to have a PV array hooked up in order for the device to show up in the app via bluetooth? If not, what is going on? The troubleshooting in the manual for bluetooth connection issues is pretty short and i've exhausted the options.


Thanks!

MPPT - Solar Charge ControllerBluetooth
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
Peter Polz avatar image
Peter Polz answered ·

Common mistake ist that people refuse the permisson on location access... Thats compulsory required for BT connection

5 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

We have a good trained dealer here. Fortunately!

Out in the boondocks of Montana, USA, our closest dealer is Seattle, WA!

I meant Peter ;o) As he is my dealer.

Unless I read it wrong, the manual states that giving victronconnect access to location services is only an issue on Android 5+. I have iphone and MacOS devices. Also, Victronconnect on iOS doesn't have a prompt requesting location access.

As I have read you are an iPhone user, I didn't think of any issues, caused by your phone ;o)

markus avatar image
markus answered ·

This BT connection should work without PV Panels connected. (There wouldn't be a possibility to connect at night if not ;o)

Try to connect via VE.Direct USB connection, to diagnose.

9 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Markus - Thanks for that information--that's what I figured, but I was running out of options to try. I don't have a VE.Direct USB cable and don't really want to buy one if the BT should be all I need. The unit sounds like it's defective, eh?

If you cabled up everything right, yes. Unfortunately. But have your Dealer involved, where you bought this unit from.

Thanks, Markus. I'm pretty sure i've got it hooked up correctly:

BAT + MPPT terminal > red wire > Bat + Stud

BAT - MPPT terminal > black wire > Bat - Stud

  • -load jumper removed
  • -25 amp fuse intact
  • -no wires on mppt load terminals
  • -wires hooked to mppt pv terminals but not connected to PV panel wires

frustrating.


Maybe your battery is damaged as a last proposal...

The fuse is a good thing to check. If it is ok, I would return it to my dealer to get the unit checked by him.

Sorry for you, I know its frustrating, if you have received a faulty unit. But this can happen.

It's hooked up to a brand new 105Ah AGM battery that powers other devices just fine, so I don't think that's it. of course I got it online, so no dealer assistance for me. part of the game, I suppose. I appreciate your time, Markus. Cheers.

Surely if it is new, you can contact the online shop you got it from and at least get a refund?
Also, I'm very sorry to say this, but there are some very convincing fakes available online. I really hope you did not fall victim to one of these.
Other than that, nothing else I can suggest really. Connect the battery and Bluetooth should just work.

I got it from Eden Products via amazon prime. good reviews, but...it seems more stories about shady amazon resellers and fake reviews are proliferating. I can surely get a new unit via amazon.

@Markus I just sent this thing back..but then noticed in the picture that there is a big grounding screw threaded through the heatsink. Does there need to be a separate ground wire attached from that to a chassis ground for the unit to function?

No. This is for earthing the chargers chassis and is optional.