jonoci avatar image
jonoci asked

Can not access Cerbo via LAN -IP:1881 any more. Receive 504 Gateway timeout

Cerbo appears to be running. It is on firmware 2.94. Remote Console is running, shows Node Red enabled in venus Large, Ethernet state is connected, IP address is present, as is gateway IP and DNS. VRM portal in Remote Console shows no errors in connect, etc.

VRM Dashboard is also running and updating

Node Red was always accessed vie, with no problem . I had node red running my flows no problem - for weeks now. I added some flows that I was testing - Dashboard buttons, etc, all linked only to debug nodes. When I deployed, the red deploy button became a mobile little bar chart, showing deploy active, and never stopped. 1/2 hour later I exited the browser, and tried to restart node red via - returns 504 Gateway timeout error. Trying to enter node red via Venus OS Large on the VRM portal also just hangs up forever. However, it seems my existing node red flow is still in place and running - I control Cerbo relays with certain temperatures, etc, and that is still happening, but I cannot get into Node red.

I can ping the Cerbo in a cmd window and it returns in 4ms

I have re-booted the cerbo, and turned it off and on again - no change.

Any Ideas?

cerbo gxVenus OS
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

matt1309 avatar image matt1309 commented ·

Can you access the cerbo via IP normally, ie not node red
I'm guessing you will be able to given VRM is working. Given the flows running sounds like it's not node red being disabled in settings but maybe worth checking while you're in the cerbo.

Clutching at straws but how about clearing cache/trying private browser?

0 Likes 0 ·
2 Answers
jonoci avatar image
jonoci answered ·

Hi Matt..

Yes, I can acces direct - entering that IP instantly gives me a remote console type page.

I have tried access ( node red) from a completely different router, ir different IP/DNS etc as well - disconnected the cerbo LAN cable from router 1 and connected to router 2 - no change. I also tried access via fresh browser install off Firefox instead of chrome, on another clean PC - no change.

Cerbo settings via console all show settings are good - VRM active/enabled, network good with no errors, IP addresses are correct, Node red (venus os large) enabled, etc....

I also enabled signal K for kicks - access via http://venus.local:3000 works fine - signal K comes up fine, not node red....

It appears that port :1881 is dead somehow...

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

jonoci avatar image
jonoci answered ·


A set of nodes resulted in a tight loop running. Cerbo's Node Red Scheduler timing was consumed by this loop and could not complete the flow, nor service port :1881


Stop node red in Cerbo console, restart it in safe mode, go to (venus.local:1881), delete the offending nodes or fix the loop, deploy, which restarts node red and all runs again.

Stop node red in console and then restart in normal mode.

The scheduler on Cerbo is obviously very smart that it can compartmentalize code so neatly - Everything else was running during the loop - Cerbo was still controlling 3 Victron inverters, a Fronius inverter, the battery pack, Victron MPPT Charger. AND my then inaccessible flow was still running driving Cerbo relays based on temps, battery SOC, etc - without a hiccup or watchdog event.

That smartness also led me up the garden path in thinking that the hardware or port :1881 was faulty..much searching only revealed that a tight flow loop would result in the Cerbo appearing intensely slow or it suffering watchdog resets. Since none of this was evident, it obviously could not be a loop...

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.