vos23 avatar image
vos23 asked

ESS Multiplus not charging above 47% with forced DVCC


I have a working ESS setup, using a Multiplus-II 5000/48 and two imported 48V LifePo4 batteries connected trough CANbus.

After adding two additional batteries and changing the primary battery to the new version, suddenly, the batteries won't get charged passed ~47% at 52.5V. Even when i set the grid setpoint at +1000W or schedule a forced charge, it won't go above. When letting it discharge below 45%, it will gladly recharge back to ~47% max.

I've checked the DVCC parameters from the battery and the CVL is set to 57. The working battery advertised 57,6. In ESS the charge voltage nor charge current are capped.

The only difference i can see is that the new version of batteries get recognised as Pylontech batteries whereas the previous versions did not. This causes DVCC to be 'forced on' instead of just 'on'.

I have a second setup on a different site which has exactly the same issues (i've tried swapping batteries between sites).

Any idea on how to troubleshoot/debug the ESS loop to figure out why ESS stops charging at ~47%/52.5V, or what other settings could possibly be of effect in this?

My guess is that the GX/ESS is somehow treating a 'recognised Pylontech' battery different internally from the same type of battery, but with a different name/vendor.

Kind regards,

p.s. Yes, swapping the batteries back in order fixes the issue for now. But that's not an option on the second site, hence my attempt of solving this issue.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
nickdb avatar image
nickdb answered ·

This topic discussed often, a search would find the answers for you.

Look at this recent one

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

vos23 avatar image
vos23 answered ·

Hi Nick,

I did in fact search around, but none of the topics seemed applicable in the large wood of various victron products and setups.

I'm glad to see that my suspicions are somewhat validated. And i didn't know this was actually a known thing, but luckly it is. I suspect it's because of the 15s/16s difference.

Thanks for pointing me in the right direction. I'll apply the Pylontech DVCC code fix mentioned in one of the other questions you referenced: and report back.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

nickdb avatar image nickdb ♦♦ commented ·
It can be a maze even with searching, takes a bit of effort unfortunately. It is definitely 15/16s related but also, many of these pseudo-pylon bms batteries have very different voltages and dvcc will insist it is more pylonesque. If you’re happy to mod or beta it should be easy enough to sort.
1 Like 1 ·
vos23 avatar image vos23 nickdb ♦♦ commented ·

I can confirm changing the value in the -script fixed my issues. Thanks again for your insight.
A quick quote from the github page for anyone interested. But to be advised to use the provided install script to overcome reboots.

This script will change line 78:  0xB009 to 0xAAAA in file
This will make not apply workaround quirks because it cant detect pylontech and apply 15s - 52.4v limit
1 Like 1 ·
steviec7 avatar image
steviec7 answered ·

I have the same issue X1 old type battery (named LG RES) and X1 newer battery (named PYLON) and confirm script updates allows charging above 52.4V.

However I still have issues if using the newer battery as Master due to forced DVCC. It limits Battery charge current 30A max charging (X15A per battery) and ignores Victron charging limits which work fine when using LG RES as Master and DVCC is disabled.

Ideally there should be an option to disable DVCC rather than being forced to use it. It might be ok for official Pylontech batteries but causes major issues with Chinese battery Lifepo4 which tbh has worked well for me over the past year.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.