r0ger avatar image
r0ger asked

SOLVED: MultiPlus Compact pushing too high Charging Voltage

Dear Victron fans,
i searched for this without success, counting on you now ;-)

My setup worked fine for months, until suddenly the MultiPlus Compact 12/1600/70 pushes 15.2V instead of 14.6V to my 200Ah LiFeYPo4 Battery, which then turns off thanks to the BMS.
I have a VE.Bus Smart Dongle connected to it, to control it and get some data.

I also have an MPPT solar charger and a BMV with shunt.

In the app, both MPPT and BMV show a battery voltage of 15.2V while the VE.Bus dongle shows 14.6V. In non-charge condition, the app shows for example 13.6V on MPPT and BMV and 13.0V on the MultiPlus (via the VE.Bus dongle). I also measured with a voltmeter, directly on battery and all 3 devices, all confirming that the readings from MPPT and BMV are correct. And confirming there is no loss somewhere in the wiring.

So if the MultiPlus 'thinks' it is 0.6V lower than reality - could this be the reason it outputs too much?

Any ideas what the cause can be?

Thanks in advance, best regards

multiplus ve.bus
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

djsmiley avatar image djsmiley commented ·

Did you also measure the 15.2v on the output directly at the busbars? Maybe it is trying to compensate for some loss, although you have stated this is not the case. I assume you did manually create a charge preset? (Since LiFeYPO4 is not in the default, only LiFePO4) either equalization or temperature compensation could give similar results.

You might consider setting the bms cutoff a little higher, 14.6 is on the low side for LiFeYPO (3.3v nominal, 3.8v max vs 3.2/3.65 for regular LiFePO4), although that doesnt solve your specific question

2 Likes 2 ·
r0ger avatar image r0ger djsmiley commented ·

@DJSmiley thanks,

i measured directly on the PCB / screws where the cables are mounted, so no losses. As i said, i measured 0.6V difference even when not charging, i.e. without load, so no current that can cause voltage drop over a resistance - except for the uA drawn by the multimeter ;-)

The previous owner of the camper had setup the MultiPlus to the battery (with USB dongle, PC and Victron software). As i understood, the main difference with or without 'Y'ttrium is the higher temperature range. (The MultiPlus Compact has only 4 standard settings, selectable by DIP switch, non of which includes a Li battery. But people report Li batteries work pretty fine with the Lead GEL setting, with the only disadvantage that they exhaust only 80-90% of the capacity.)
Anyway, i never changed those manual settings.

The BMS is encapsuled in the housing of the battery, and i don't think i should modify it.
The cutoff is at 15.1V as i can see from the graph in the app, so it already is at the high side.

Regarding temperature compensation, i understand that at lower temperatures the voltage would go up, but i down't know how much. Anyway i had taken all measurements around 20°C (=68°F) where no such increase should happen. Even if the voltage would increase, still it should be shown correctly and not a 0.6V lower value.

Best regards R0ger

0 Likes 0 ·
Alexandra avatar image Alexandra ♦ commented ·

Check everything is still tight. And torqued

0 Likes 0 ·
r0ger avatar image r0ger Alexandra ♦ commented ·
@Alexandra i measured within the housing of the MultiPlus, directly on the PCB.

Always same voltage as the battery, even with load when it was on charge (+/- 0.05V).
Beafy cables and fastened screws.

0 Likes 0 ·
2 Answers
klim8skeptic avatar image
klim8skeptic answered ·

Check out your VE Bus smart Dongle. VE BUS SMART DONGLE voltage connected to MULTIPLUS does not match VE BUS input voltage - Victron Community (

Suspect that you have an error with the Smart Dongle and voltage compensation.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

r0ger avatar image
r0ger answered ·

Solved :-)
'B-' of the dongle was not connected to '-' of the battery.

The link posted by @klim8skeptic lead me to reading through the manual of the dongle, where in the troubleshooting chapter this exact case was covered.

My wrong understanding was, that the dongle is just a bluetooth interface to control the MultiPlus and read its data. But 'B+' and 'B-' of the dongle not only provide power to the dongle but are also used by the dongle to sense the battery voltage. As soon as the dongle is connected to the MultiPlus via UTP cable, the MultiPlus no longer uses its own voltage measurement but the voltage provided from the dongle. Also, the dongle has an internal temperature sensor (and external if connected).

If 'B-' is not connected, it looks like the dongle gets the '-' via the UTP (in my case STP) cable, which obviously is enough to operate, but not suitable for correct voltage measurement.

The dongle was originally placed close to the MultiPlus, so i moved it close to the battery and stuck it to the battery housing for reasonable temperature measurement.
The dongle was originally connected with an STP cable and i replaced it with a UTP cable since this is what the manual says.
Now all works fine. Voltage showing correctly and MultiPlus charging correctly :-)

Best regards R0ger

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Related Resources

Additional resources still need to be added for this topic