question

murphy_r avatar image

Adding Venus GX to multi control and Multiplus 12

Howdy everyone,

I have an existing MultiPlus (v2002142) and multi control panel that was installed in our boat and working.

We added a Venus GX to our system this week with latest firmware. Now both the Multiplus and multi control are plugged directly into the Venus GX VE.Bus ports.

The Venus GX sees the Multiplus just fine. The multi control though is non-operational.

The mulit control will have the following lights on. Some random txt will be on the LCD panel.

  • Mains on
  • Bulk
  • Absorption
  • Float
  • Inverter

Q1: Is the VE.Bus cable a straight through RJ45? I could find only one passing reference. I had to make my own cable from the GX to the multi-control

Q2: Will the MultiPlus with the old microprocessor support GX and multi-control together like the data sheet shows?

Q3: Do I need to do a firmware upgrade on the Multi-Control from 142 -> 159 to get this to work? Its $70 for the USB to MK3 to do the upgrade.


MultiPlus Quattro Inverter ChargerVenus GX - VGX
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

4 Answers
murphy_r avatar image
murphy_r answered ·

For closure on this topic. I tested the STP cable that I was using and it passed on the tester. Swapped in a UTP cable and it worked just fine. Not sure what is going on with that but, checked 2 different STP cables Multi Control freaks out. Substitute 2 different UTP cables and it works.

Not sure why the STP cable would cause issue but, heh got it working.

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

murphy_r avatar image
murphy_r answered ·

Thanks Lange. I downloaded and read through the firmware release notes. I do not see anything specific that the firmware feature / bugs would address a known issue with Venus GX and multi control.

I clarified my initial post. Any chance you know the answers to Q1-3?

2 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Q1: Is the VE.Bus cable a straight through RJ45? I could find only one passing reference. I had to make my own cable from the GX to the multi-control

-yes straigh cable or 'patch cable', please note that Victron doesn't support self-made cables as they cause a lot of problems, first thing I'd try is using a normal patch cable.
(I do use self made cables sometimes please don't tell anyone)


Q2: Will the MultiPlus with the old microprocessor support GX and multi-control together like the data sheet shows?

Yes:

https://www.victronenergy.com/live/ccgx:start#connecting_victron_products

Q3: Do I need to do a firmware upgrade on the Multi-Control from 142 -> 159 to get this to work? Its $70 for the USB to MK3 to do the upgrade.

the firmware is on the Multiplus, not the Digital Multi Control. An update is recommended, but I'd try the RJ45 cables first, also, you might be able to lend an MK3 cable from someone?

Remember to safe your settings before updating firmware, it will be back to factory settings after flashing.


Thanks Boeket. I was planning on bringing in a cable tester from work to double check the cable but, I was getting the same result with a second cable. Always good to validate though.

There is not any settings in the Venus to correctly pass through the VE.Bus data is there?

murphy_r avatar image
murphy_r answered ·

The control panel and multiplus were an existing setup that was working correctly. What is new is inserting the Venus GX into the data path of the VE.Bus.


I did perform a power off of the Venus GX and turned the Inverter off at the face plate switch to see if that would reset and clear the issue.

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Matthias Lange - DE avatar image
Matthias Lange - DE answered ·

Try to connect the control panel directly to the Multi instead of the venus.

2 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I rehooked the original cable from the Inverter back to the multi control and it came up working just fine. Either there is a firmware upgraded needed on the Multiplus OR the VE.Bus cable is not a straight through pinout. Those are my two guesses.

The lastest non assistant firmware for the Multi should be 159 (459 with assistant).