question

romarub avatar image
romarub asked

MultiPlus-II 10 kVA cannot connect to the grid

Hello dear colleagues. Yesterday I put into operation a system with a MultiPlus-II 10 kVA inverter with the latest firmware 497. In standalone mode, the inverter works stably, but when connected to the grid at the AC input, it behaves very strange. As soon as the inverter is connected to the grid, its transformer begins to hum, as if the load has increased dramatically, after which the Multi returns to inverter mode (no errors or notifications appear). Then he tries to connect to the grid again, and sometimes he still succeeds. In this case, a strange undulating sound of the transformer may occur, as if there is a frequency desynchronization, the cooling fans turn on. The voltage in the grid is about 235 volts, the frequency is 50 hertz. So the inverter can work for several minutes, but then everything repeats again.


I have over 30 stable running systems with Multi and Quattro and all the basic configuration settings are the same. I usually choose "Other" as the grid standard as Bulgaria is not on the list and we do not export energy to the grid. Faced with this problem, I decided to do some experiments with different standards. When I chose "Germany" - the problem disappeared, even the sound of the transformer became quieter. But the inverter began to react extremely slowly to switching on/off the loads: when a 3-kilowatt water heater is turned on, it first takes all this power from the grid, gradually transferring it to the battery, and this “transfer” can last about 5 minutes. When the water heater is turned off, the Multi starts to return 3 kW to the grid, and it also takes a few minutes to return to zero. In "Romania" mode, the Multi didn't even try to connect to the grid, and just continued to work offline. Then I decided to return the "Other" mode, but disable the UPS function. At first it worked well, but later the problem still happened again. As a result, while I left the system to work off-grid and went home.


In general, this is the first time I have encountered such a problem. Even systems with generators at the input work stably for me. I think that this is either a defect of a particular instance of the inverter, or there is some kind of problem in the firmware that gives such an effect in the 10 kVA modification (all my other Multis are 3, 5 and 8 kVA). I have 3 more 10 kVA Multis in stock and I could change and test them, but before that I want to know your opinion. What could be the reason for such strange behaviour? I also really hope for a response from Victron Energy employees.


2022-09-26-18-44-46.jpg

multi-10.jpg

Multiplus-IIgrid
multi-10.jpg (323.5 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

6 Answers
Lucian Popescu (Victron Energy Staff) avatar image
Lucian Popescu (Victron Energy Staff) answered ·

Hi, the system is working correctly after reducing the input current limit to a lower value (10A). So most probably that was the issue. Also, "Accept wide input frequency range” shouldn't be enabled for grid connections, that's something for generators.
My advice – when there is an issue, most of the time it is not a complex one, as you are saying above.


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

romarub avatar image
romarub answered ·

Here is a short video of how it happens



1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

ponzoa avatar image ponzoa commented ·
Not sure if it is relevante but, did you notice how the output frequency dropped suddenly just before if cut out? I would suggest testing the frecuency with a multimeter because if the frecuency is drooping and causing the cut out, you have a defective batch. I have 10KVA's installed and without isues.


Alternatively, off grid has a max frecuency range of 45-65Hz while Romania is 47.5-51.5Hz. South Africa 47-52, and ITALY has 45-55Hz. This may be a good country code to test with.


Although it's not critical, I would suggest inputting the correct battery numbers in VEConfigure as some software doesn't like differences even when it shouldn't be relevant. Perhaps it's happening here too and behaving strangely because of this.


Do let us know how you go and good luck.

0 Likes 0 ·
Warwick Bruce Chapman avatar image
Warwick Bruce Chapman answered ·

Are you 100% sure you have the neutrals on the input separated from the output side?

4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Warwick Bruce Chapman avatar image Warwick Bruce Chapman commented ·

Also, unrelated to your fault but if you have Lithium batteries, please check your Inverter tab low voltage settings because they are the defaults for lead not Lithium.


Also, these days most lithium batteries have lower charge settings than are reflected on your Charger tab.

0 Likes 0 ·
romarub avatar image romarub Warwick Bruce Chapman commented ·

"Also, unrelated to your fault but if you have Lithium batteries, please check your Inverter tab low voltage settings because they are the defaults for lead not Lithium."

These settings are ignored when the ESS assistant is installed.


"Also, these days most lithium batteries have lower charge settings than are reflected on your Charger tab."

These values are automatically set if you select the following battery type in the assistant's ESS settings:

System uses LiFePO4 with other type BMS (This can be either a BMS connected via CAN bus or a BMS system in which the batteries are protected from high/low cell voltages by external equipment.)

All my other systems with these BYD Lithium Iron Phosphate batteries run stable with the same settings.

0 Likes 0 ·
Warwick Bruce Chapman avatar image Warwick Bruce Chapman romarub commented ·

OK - you're completely correct above but note the purpose of the settings in VE.Configure and on the MPPTs is to ensure in the absence of the GX device that the battery is treated correctly.


Eg. GX device fails, then configured values are the fallbacks.

0 Likes 0 ·
romarub avatar image romarub commented ·

This is the first thing I thought about yesterday, but I checked everything carefully and made sure that the neutrals at the input and output are separated.

0 Likes 0 ·
romarub avatar image
romarub answered ·

Hello colleagues,


It turned out that we have 7 more MultiPlus-II 10 kVA in our warehouse, so I randomly picked one of them and tested it. The second instance under laboratory conditions behaved exactly the same as the first 10 kVA instance installed on site. We have a different inverter, a different Cerbo GX, a different grid, but the same result.


The inverter firmware is the latest - 497, Venus OS is also updated to the latest version 2.90. Any errors in communications are excluded. This generally occurs regardless of whether a load is connected to the output of the inverter or not. As soon as I connect the grid to the AC1 input, the inverter tries to synchronize, but immediately disconnects from the grid and returns to inverter mode. Sometimes at this moment the lighting even flickers, which is powered directly from the grid, and not from the inverter. It all looks like an overload, and the fans turn on in the same way.


At the same time, when I connected this inverter to a laptop via Interface MK3-USB (without Cerbo GX), it worked very stable with the grid. My opinion is that there is an internal software conflict between Venus OS 2.90 and the 497 inverter firmware, in the case of the MultiPlus-II 10 kVA modification, which does not allow the inverter to synchronize normally with the grid.


It would be great if Victron did a similar test in their lab. I filmed a video of how it happens here:


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

romarub avatar image
romarub answered ·

Dear colleagues, I thank everyone for their opinions and suggestions! Special thanks to Lucian Popescu for the quick response and help.


Shortly before contacting Lucian for help, I unchecked the "UPS function" in the inverter configuration we had installed at our customer's site. Then I noticed that the connection to the grid in this case sometimes succeeded, about 30% of the time.


Then Lucian changed two more settings in the configuration, after which the inverter began to connect to the grid stably. These changes are:


  • Input current limit up to 10 A (factory setting 50A)
  • Unchecked "Accept wide input frequency range"


Thus, we have three changes (compared to all our other systems) with which the inverter is currently connected to the grid stably. I've highlighted these changes with red boxes:


001.jpg

002.jpg


Then I decided to test another MultiPlus-II 10 kVA from our warehouse with factory settings (previous video), and it also did not connect to the grid. My mistake was that during the test I was in a hurry and used thin cables, and even an extension cord with a surge protector, which also could worsen the situation. Lucian told me that the test could not be correct with such cables. I fully agree with this.


Now I installed normal cables and ran a new test. Result is negative: MultiPlus-II 10 kVA is not connected to the grid. Then I made exactly the same configuration settings as on the object of our client: I limited the input current to 10 A, and also unchecked "Accept wide input frequency range" and "UPS function". Unfortunately, it didn't help.


Then, in addition to that, I activated "Dynamic current limiter" and "Weak AC input", but that didn't help either. Only disabling LOM (loss of mains detection) helps. Without LOM, the inverter connects to the grid stably even with thin cables.


I think we do have a pretty weak grid in the warehouse, but we've never had a problem with other inverter modifications or running high power appliances. In addition, some of our systems that we have made for our clients in remote areas work with weaker grids without any problems, even with basic configuration settings.


As a result, I found a Quattro 10 kVA in our warehouse and decided to compare the MultiPlus-II with it in exactly the same conditions. It turned out that a Quattro of the same power connects stably to a weak grid even without changing the settings.


In both cases:

  • Inverter firmware updated to latest version 497
  • Venus OS updated to latest version 2.91
  • The same battery is used
  • The same grid is used
  • The same cables are used
  • Installed ESS assistant
  • All configuration settings, except those highlighted with a red frame, are the same


I did dozens of tests and every time the Quattro 10 kVA connected to the grid without any problems. There were no failed connections at all. Even when I raised the input current limit from 50 to 100 A, it reconnected to the grid. I made a video about this test, in which I limited myself to nine successful connections, although there were more:




In general, I am in some confusion. Here are my preliminary findings and questions:


When the Cerbo GX is turned off, the inverter starts to connect to the grid stably. Why is this happening?


My understanding is that the MultiPlus-II 10 kVA is much more sensitive to mesh quality than the Quattro 10 kVA. This can cause problems in remote regions with a weak grid. Actually, a weak grid is one of the reasons why customers buy such systems. Maybe it has something to do with certification? After all, the Quattro is certified for the UK and requires an external anti-islanding safety devices when used in Germany, for example. On the other hand, in both cases the same grid standard and LOM type B were chosen, shouldn't they behave more or less the same?


Since the inverter connects to the grid stably without the LOM function, it is probably the frequency shift that affects this. Perhaps the MultiPlus-II 10 kVA is trying too hard and with great effort to change the frequency, and only a strong grid can resist this. I also tested the Quattro 10 kVA with the LOM function, but this did not prevent it from connecting to the grid.


With this LOM function, I'm left with other questions. For example, in theory, when the LOM is deactivated, after turning off the grid, a dangerous voltage may remain at the input of the inverter: https://www.victronenergy.com/live/ve.bus:grid-codes-and-loss-of-mains-detection In practice, the backfeed relay turns off just as quickly as it does with the LOM function active. Do I understand correctly that in this case there is another algorithm that determines whether the grid is turned off, but it is considered insufficiently reliable?


001.jpg (354.8 KiB)
002.jpg (322.3 KiB)
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

rainer avatar image rainer commented ·

Thank you for sharing the experience in the forum, and trying that many settings as a workaround. Please keep us updated, this looks like a critical issue. I yet have to setup MultiPlus-II 10 kVA in a not-so-stable grid environment. Please share also any comment from Victron, I would expect that they need to comment.

2 Likes 2 ·
ludo avatar image
ludo answered ·

Why do you set the grid to "other" and not to "none" of you don't want to feed back to the grid ?

7 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

romarub avatar image romarub commented ·

I already planned to test this, but still I want to understand why MultiPlus-II and Quattro of the same power and in the same conditions behave completely differently.

0 Likes 0 ·
Hi, I told you already, use the correct cable thickness. In your case, there are huge voltage differences between PE and N.
0 Likes 0 ·
romarub avatar image romarub Lucian Popescu (Victron Energy Staff) ♦♦ commented ·

Hi @Lucian Popescu (Victron Energy Staff), Yes, I changed all the cables right after you told me about it and did a new test, which I showed in this video:


Nothing has changed: Quattro works stable with mesh, but MultiPlus-II does not work (same mesh, same cables, same settings). I have described this in detail above. I also equalized the potentials between PE and N (this is not on the video), but this did not affect the behavior of the inverter at all. I don't know if it's intentional or not, but it's clear to me that the MultiPlus-II 10 kVA is more sensitive to mesh quality than the Quattro 10 kVA. I'm not saying that it's bad, it's just that there is such a feature of the MultiPlus-II 10 kVA that installers must understand and take into account, because the quality of the grid does not always depend on us. I would like to understand the reason for this difference: is it in hardware or in software? Is it done on purpose or not?

Those settings that you made at our client's site helped only partially. From time to time, the inverter begins to “fight” with the grid, making specific sounds of the transformer load (probably by raising the frequency), and disconnects from it. This rarely happens, so documenting such an event is problematic. Only disabling LOM is guaranteed to help, but I still can't figure out how dangerous that is. The instructions say that this is dangerous, because in the event of an emergency shutdown of the grid, a dangerous voltage may remain at the input of the inverter. At the same time, I did dozens of tests with the LOM off and different loads, but every time I turned off the grid, the voltage on AC IN disappeared instantly.

0 Likes 0 ·
On Multiplus 2, there are extra grid measurements because of the anti-islanding. But the reason for not connecting to the grid should be displayed, is that system online?
0 Likes 0 ·
romarub avatar image romarub Lucian Popescu (Victron Energy Staff) ♦♦ commented ·

@Lucian Popescu (Victron Energy Staff), This test system is not online right now, and I'm not around it right now. I will try to connect this system to the Internet in the coming days and let you know. Thank you!

0 Likes 0 ·
Perfect, then we can have a look at it. Thanks!
1 Like 1 ·
romarub avatar image romarub romarub commented ·

Hi @Ludo, In the "none" mode, the inverter connects to the grid stably, as expected, because there is no LOM in this mode. At the same time, the "none" mode is not compatible with the ESS assistant. I have found a way to leave ESS in "none" mode (to do this, you must first install the assistant with the grid code, and only then select "none", but the assistant does not work correctly in this case (for example, it does not drain the battery when the grid is present). So A more suitable alternative seems to me to be setting the grid to "other" and deactivating the LOM. In this case, at least the relay test is stored before connecting to the grid. With the "none" mode, this test is not present.

2022-10-07-22-59-09.jpg

2022-10-07-22-58-27.jpg

2022-10-07-23-01-17.jpg

0 Likes 0 ·