question

djdemond avatar image
djdemond asked

[NOT SOLVED] Raspberry Pi and Zigbee link for ET112

Raspberry Pi 3B running the latest Venus OS 2.89. Connected to Multiplus II 48/5000/70-50.

The system is connected to a 48V LiFePO4 pack with 250A Daly BMS.

Everything working, I can power up the unit and configure it, inverter comes on, ESS assistant installed via VEconfig, I am in the UK, country code entered, system test successful etc..

I have an ET112 and Zigbee units one USB and one RS485. I have the USB inserted into the Raspberry Pi, which is connected to the multiplus II via Mk3 USB cable to VEBus.

However, in the "setting" > "energy meters" screen on the RPI there is no energy meter showing. The zigbees have a blue tx-rx light flashing?

Any ideas?

Venus OSRaspberry Pi
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

6 Answers
Mariusz Zieliński avatar image
Mariusz Zieliński answered ·

Hello,

It looks that Victron is not convinced to this solution either :-). Zigbee is a mesh type 2.4GHz network. It requires one coordinator that I believe can be either of the devices you have. Coordinator has to be set up first. Usually it involves setting up some parameters like frequency, some network identifiers like PANid and some encryption values. Afterwards you can join-in other devices participating in the network. There are devices(usually grid powered) have the ability to retransmit messages (hence mesh network) and they're called routers. Third type of the device participating is the end device (without ability to retransmit, battery powered). You can have only one coordinator and as many routers and end nodes as coordinator is capable of registering. All devices within the mesh can talk to each other.

It looks like there is some rigged behavior in devices you have and they use Zigbee to tunnel serial communication.

I could not find any documents (I don't speak Chinese) describing pairing procedure but in majority of cases you join devices by enabling joining on coordinator (for security reasons it can't be enabled all the time) and later join other devices by pressing some button for long enough or pressing some button enough times.

Devices clearly belong to contraption category so they will definitely have rigged behavior. Maybe two devices out of box are configured one as coordinator and the other as router/endpoint. Power one on , wait, and then power on second one and it may all work. If not go to their website and using google translate read manuals. I tried but failed :-)

Side note - I would stick to cable connection with mission critical devices anyway.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

djdemond avatar image
djdemond answered ·

Hi Rob. That's very kind of you to give your time to help. Might I just ask for a steer in the direction of any further information on " a coordinator and router modes" I have not come across this in the documentation I have read so far.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

djdemond avatar image
djdemond answered ·

Thanks, Rob, but I am trying to connect a multiplus to an ET112 energy meter. The zigbee units are not capable of doing this without reprogramming? What we seem to be struggling with is just pairing the USB zigbee with the rs485 zigbee. Someone here said press reset three times on the rs485 unit? This doesn't seem to work.

Does anyone know the correct pairing procedure?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

djdemond avatar image
djdemond answered ·

Hi Rob, continued thanks for your time. No the zigbee units I have (aliexpress/ebay cant remember which) came with no documentation at all. If you have a link for it that would be amazing (I can do technical).

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

djdemond avatar image
djdemond answered ·

Okay, we got the Zigbees communicating by using the DTK Zigbee software to set the USB one as coordinator and baud rate 9600, now they are connected and data can be seen flashing on the TX-RX light on both units when the et112 is connected to the RS485. We connect the USB Zigbee to the raspberry pi (venus OS 2.89).

However, on the VRM portal venus OS there are no energy meters showing in that menu.

What else do we have to do?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

djdemond avatar image
djdemond answered ·

Sorry, this is not solved. We have reverted to rs485 to USB cables and cat5e extensions. Zigbee did not help. The user guide for it needs to be considerably overhauled or a simpler product recommended.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.