question

micmak avatar image
micmak asked

Fronius throttled by Quattro despite being needed (AC/DC coupled system)

Hello all,

I have an AC/DC coupled system as seen below:

1663332687109.png

Half way through the day, the batteries got to 100% and I had a low load of around 1000W, which the DC coupled system handled while the AC coupled is throttled down to 0. Load eventually got higher than the capability of the DC coupled system, and yet the Fronius remains throttled.


BYD BMU raised the CCL a while ago and yet the Quattro didn't change its behavior:


1663332859795.png

And here's the Quattro throttling the Fronius:

1663332902234.png


I have two questions:

1. Obviously something is wrong here, Fronius should kick back in when CCL is above 0 to recharge the batteries

2. Why isn't the AC coupled prioritized when the batteries are full over the DC, given that would be more efficient for the AC load?


EDIT: toggling the dc switch of the Fronius didn’t help. Turned on my generator for few minutes then the Fronius started pulling power from its array. Turned off the generator and it is still going strong. A barbaric workaround though…

MultiPlus Quattro Inverter ChargerFroniusAC PV Coupling
1663332687109.png (62.6 KiB)
1663332859795.png (32.9 KiB)
1663332902234.png (24.4 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

5 Answers
ponzoa avatar image
ponzoa answered ·

Perhaps it has to do with your batteries being pretty much topped up. Does this behaviour happen when the batteries are say at 80%? If it does, something is up. If not, I can only imagine it's throttled to look after the batteries.


When you switch on a generator, the systems try to charge the batteries as quick as it can so perhaps you're just tricking the system.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Phil Gavin avatar image
Phil Gavin answered ·

Your frequency is 52.6Hz, which will throttle any PV inverter.

Fronius has dedicated comms, but I have no experience with that PV inverter, but I'd check to see if it is working, because you have locked out on high frequency. ( Throttled by frequency-shifting).

There are various conditions that reset this. It is documented on the Victron site .

From memory:

1. A 50 Hz supply on the input on the Victron.

2. Cycling the power switch on the Victron.

3. A 0.7V ( I think) drop in the battery voltage. ( It is higher for other battery chemistries, so check yours is set to Lithium).



3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

micmak avatar image micmak commented ·
fair point and when I turn on my generator number 1 recovers the fronius. Also, in the morning, the Fronius is working fine, so number 3 is the culprit here, as @ponzoa suspects as well. But I didn't find the configuration related to the voltage drop threshold. Any ideas?


Before adding the DC coupled part to my system, Fronius was handling the AC loads and keeping the battery charged after it reaches 100%. Now the Quattro is relying on the DC part of the system for that (which is only 6 panels facing south east, whereas Fronius is handling 15 panels facing south west'ish).


Is there a way to prioritize the Fronius inverter? First, it has way more panels and second, it makes more sense to have the AC coupled system handling the AC loads...

0 Likes 0 ·
Phil Gavin avatar image Phil Gavin micmak commented ·

1663387739026.png

I agree with about the DC vs AC preference in terms of efficiency, but I don't have a solution.

I have used the Lithium setting for LA batteries and it allows AC coupled PV inverters to reset faster.

It is a trick based on the following info from the Victron website:

"Q1 - The system is locked to 53 Hz and does not resume

Its locked to the upper limit because of a battery over voltage.

The frequency will reset itself automatically, in case one of the following conditions is met:

  1. the battery voltage drops below the re-bulk voltage threshold: the voltage that makes the system restart the charge cycle. For lithium batteries this threshold is defined as the float voltage minus 0.8V. Note that when float is configured to 54.8 volts or higher, then the battery voltage needs to drop below 54V. For lead batteries, the re-bulk voltage is defined as 5.2V below the configured float voltage. Unless that is configured to 56.8V or higher: then the battery voltage needs to drop below 51.6V.

  2. the system is connected to mains or generator power. As soon as it sees a voltage on AC-in, it will sync the AC frequency to 50Hz and then connect.

Alternatively, power cycle the system with the rocker switch on the front panel on the inverter/charger.

To prevent this from happening again, check your configured absorption voltage: setting it lower will prevent the overvoltage condition from happening again."

1 Like 1 ·
1663387739026.png (8.5 KiB)
micmak avatar image micmak Phil Gavin commented ·

I already have the Lithium option checked, and my floating voltage is set to 55, which means that the reset should happen when the battery voltage hits 54.2. This is not happening:

1663401798306.png

It even goes below 53V and still it doesn't reset. The reset in the graph is from when I turned on the generator. and here's my config:

1663401867782.png


Which matches section 4.2 from https://www.victronenergy.com/live/battery_compatibility:byd_b-box#gx_device_configuration

I did notice in that article something about absorption voltage though:

1663402051727.png


Shall I try setting it to 56.5 instead of 55.2? what's the logic here?

0 Likes 0 ·
1663401798306.png (100.1 KiB)
1663402051727.png (125.9 KiB)
ponzoa avatar image
ponzoa answered ·

You're off-grid so yes, you should try the 56.5V. Definitely.

You should also activate modbus in both the Fronius and the GX and have them on the same network - wifi or wired or mix but the same network.

3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

micmak avatar image micmak commented ·
modbus is active and they are all on the same wired network. The configuration on the Fronius is correct when it comes to that as well. I am also connecting to all of the units through modbus from my homeassistant.


I am mostly offgrid, our electrical grid is an hour or two a day if it happens, which hasn't for over 2 weeks now. I guess 56.5V won't interfere with the grid if it ever happens to show up. I will modify the configuration and upload that. Will report back. Thank you both for taking the time, I appreciate it



1 Like 1 ·
Alexandra avatar image Alexandra ♦ micmak commented ·
@micmak

Also set your BMU to offgrid use.

1 Like 1 ·
micmak avatar image micmak Alexandra ♦ commented ·
I double checked, this is the case, thank you



0 Likes 0 ·
micmak avatar image
micmak answered ·

I still couldn't reproduce the issue. In the past 2 days, once batteries are full, AC PV continue to handle the load instead of DC PV. While on the days I had the issue, the DC PV were handling the loads and AC PV went down to 0 and didn't reset. I changed the float charge for now to match the offgrid value recommended.


My concern is still about prioritizing AC PV over DC to avoid the problematic scenario. Is this possible in the configuration somewhere?

3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Dave Rae avatar image Dave Rae commented ·
what ver firmware are your MPPT's on?
0 Likes 0 ·
micmak avatar image micmak Dave Rae commented ·
I don't know what was the mppt release when I had the issue, but I update them regularly and currently running 1.61. I also increased my float voltage to 56.5
0 Likes 0 ·
Dave Rae avatar image Dave Rae micmak commented ·
OK, my MPPT's started being biased towards always covering the loads during the day after i updated them to 1.61. Prior to updating them the Fronius was covering the loads. So, I suspect that the 1.61 firmware update on the MPPT's is the cause of the issue. The MPPT's will not accept downgrading to the previous version, i have tried to install a legacy version without any success.
0 Likes 0 ·
Dave Rae avatar image
Dave Rae answered ·

Yep, have the same issue with my system, Seem's to be prioritizing the DC coupling over the Primo AC coupling, which as you stated if far more efficient at running the AC loads during the day.

Basically, what you have described is exactly what's happening to my system, should be a way to prioritize the AC coupled side.

When I turn off my two 150/70 MPPT's DC couple side only them does the Multiplus drop the frequency and bring the Primo back online.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.