question

Lloyd thompsett avatar image

Battery AGM 165a

Hi. We had two of these batteries installed in April 2017. Have run the boat the last two years for around 12 weeks each year.

Returned to the boat this year having left the boat not attached to electric over winter but batteries turned off.

Recharged through standing electric points and both service batteries got hot. Today again plugged in to shore power a lot of heat generated and one if the batteries had buckled at top.


Please advise. Lloyd

battery charging
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
Boekel avatar image
Boekel answered ·

'buckled at top' batteries might have been frozen?

But anyway: bad news, better replace them.

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

neoneddy avatar image
neoneddy answered ·

What is the charging voltage? Anything over 14.8 can cook em. I try and keep mine below 14.4-14.6v


They could be toast. As a last ditch effort look and see about adding water to the vent holes. I know they are AGMs, but I've heard it is possible to re-enter them. If it doesn't work they were toast anyway.

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.