question

davidalmoncollins@gmail.com avatar image

New MPPT 150/35 LED lights don't come on and no Bluetooth

I'm trying to get my MPPT 150/35 going for the first time. My PVs and Battery bank are hooked up, but the LED lights don't come on at all, nor can my phone detect the controller. I've tested that I have current coming from the PV panels, and that the batteries are fully charged. I've tested right at the Controller, as well as at points along the chain, and I have current.

Is it possible that controller is not coming on because the batteries are already fully charged? Any other suggestions?

MPPT - Solar Charge ControllerBluetoothled
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
Henk avatar image
Henk answered ·

Please ensure you connect the battery ONLY first.

The MPPT needs to know the System voltage first!

henk@pasma.com.au

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Svtti123 avatar image
Svtti123 answered ·

Do you mean you have voltage?

Left side of controller bottom side where the panels and battery hookup there is a fuse i would check that first.

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.