question

justin-carver avatar image
justin-carver asked

SmartShunt and Smart Battery Sense Temperature Issue

Odd issue that randomly pops up between a SmartShunt without an auxiliary temperature sensor, a Smart Battery Sense, and a pair of MPPT 100/30 controllers.

The SmartShunt will occasionally take over temperature monitoring duties and it sticks at a temperature of 30 F. This causes issues with over voltage on my battery bank.

All devices are on the same V.E. Smart Network

I am unsure what is causing the demotion of the Smart Battery Sense temperature sharing. The SmartShunt does not have the external temperature probe installed physically, and it is not enabled in the firmware either.

MPPT ControllerssmartshuntSmart Battery SenseVE.Smart Networkovervoltage
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

5 Answers
Alexandra avatar image
Alexandra answered ·

@Justin Carver

One of the limitations of the smart network mentioned in the manual is "only one Smart Battery Sense, or one BMV can be used in a system. "

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

snoobler avatar image
snoobler answered ·

Take the smartshunt out of the VE.Smart network. The SBS measures both voltage and temp.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Logical answer. What do I lose by not having the shunt in the network? "Battery current sense"


I'm thinking my best option is to remove the Battery Sense and use a temp probe for the SmartShunt instead.

Per the VE.Smart Networking manual:

"The battery current data is used to allow the tail current setting (see the Solar Charger Manual for more details) to be used more precisely as, by having the actual battery current, the Solar Charger can decide better if absorption phase should stop and go to equalisation/float phase."

img-3602.png

0 Likes 0 ·
img-3602.png (485.1 KiB)
snoobler avatar image
snoobler answered ·

Nothing in the VE.Smart network uses battery current sense. If you had a GX, you would connect the shunt to the GX via VE.Direct cable and share current sense with all GX connected devices.





1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

The MPPT controllers do - it is used to accurately read tail current for absorption/float stages of the charge cycle. I also have a RPi Venus/Cerbo which can use the temperature monitor from the SmartShunt, but not the battery sense.


0 Likes 0 ·
snoobler avatar image
snoobler answered ·

Doh! I forgot about that. It's been too long since I set mine up.


I have a BMV 702 and SBS. I bought the SBS first and deployed it quickly for the MPPT, but once I installed the BMV, the SBS is effectively redundant. It's still installed and in the same VE.Smart network as the MPPT, but I use the BMV as my primary SVS, SCS and STS via DVCC in the GX device.


Since you're having issues, I would recommend the same for you - get the temp sensor, a VE.Direct to USB cable and connect smartshunt to RPi. Enable DVCC and enable SVS, SCS and STS for the smartshunt.


It doesn't answer the question, but it will solve the problem.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Temp sensor for the SmartShunt is on its way. Should correct the issue.
0 Likes 0 ·
Thiemo van Engelen (Victron Energy staff) avatar image
Thiemo van Engelen (Victron Energy staff) answered ·

Hi @Justin Carver

It should be possible in the SmartShunt settings to set the AUX input to None (Settings->Misc->Aux input). This should prevent it from ever using it as temperature sensor and broadcasting it as such via VE.Smart networking.

Kind regards,

Thiemo van Engelen

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I have confirmed that the aux input is set to “None”


Issue still persists.

0 Likes 0 ·