botessj avatar image
botessj asked

Multiplus II 5kVA 48V random output voltage dips

I fairly recently installed a Multiplus II 5kVa 48 system (including Venus GX), connected to 2 x Hubble AM-2 5.5kHw lithium batteries. System runs as purely backup system for load shedding purposes.

This issue that has arisen is that the inverter randomly cuts the output voltage to the loads for a couple of second.

The latest instance happened after a blackout (load shedding). The system took

over and returned seamlessly, and roughly a hour after, the output voltage dipped for a couple of seconds.

-Inverter and GX has latest firmware installed

-System is not overloaded

-AES is not enabled

-Battery bank is CAN bus connected to the GX, via its own logging device (Cloudlink\Riot)

I have checked settings multiple times, and compared to other installations.

Has anybody had similar problem, or have advice as to remedy?



2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

6 Answers
botessj avatar image
botessj answered ·

As a sidenote. This does not only happen after loadshedding

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

marekp avatar image
marekp answered ·

I do not have the answer for your question but I had similar occurrence but my system showed an error #1 device switched of.


problem.jpg (175.7 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

nickdb avatar image
nickdb answered ·

There was another member here a while back with hubble issues.

They have not been tested with Victron and are not on the compatibility list.

From that post (you can search for it), it sounds like they can't provide proper settings for victron and may have BMS issues.

Suggest you contact them for support.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Munnik avatar image
Munnik answered ·

I have the exact same problem on 2 x Multiplus 2 sites. One site 8kw BSL other site 5 kw Revov R 100. I have tried multiple settings and cable/terminal checks. The one client is very frustrating and does not understand. I am at the point to remove the system and give him a full refund. I sold Victron to him as one of the best inverters on the market, but because off al the dipping when loadshedding kicks in he does not agree with me. I also find this problem extremely irritating because it is taking up alot of my time. I have installed multiple inferior cheaper brand inverters and have no dipping issues at all. I have searched, Google and spoken to other Victron installers about this, but cant get a answer that works. Hopefully someone on the forum can help me.

Thanks Munnik

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

nickdb avatar image nickdb ♦♦ commented ·

The BSL is at least supported, but that stubby has had some issues where the importer has taken them back, modified them and reinstalled them with no further issues.

It is almost always a BMS issue, or a setup issue. This forum has had various complaints from people with these specific batteries.

You need to go back to the distributor and have them provide support to you, and in the case of unsupported batteries like Revov, to them for assistance.

The R100 is a second life battery with a low-ish charge/discharge current rating and is also unlikely to be suitable for larger inverters (you don't say what they are).

The inverters will also usually log an error like low voltage, or overload.

Best follow official support channels and try get to the bottom of it.

1 Like 1 ·
Munnik avatar image Munnik nickdb ♦♦ commented ·

Hi Nick

Thank for replying. The funny things is VRM is perfect, there is absolute no sign of dipping2022-09-27.png


I have played around with the grid code, even pushed the AC low cutoff to 220V but still it tipped. Did latest firmware, but nothing. I see this morning Eskom took 4 second to switch off, so I also think that the main problem. The Revov site is actually doing very well now after latest firmware update.

Thanks for your advice, I will go though the setting again and double check. Will let you know when problem is solved

Thanks Munnik

0 Likes 0 ·
2022-09-27.png (218.4 KiB)
2022-09-27-1.png (215.4 KiB)
nickdb avatar image nickdb ♦♦ Munnik commented ·
Hey @Munnik on VRM, zoom into that couple of minutes when power is cut, some times the wider view smooths the chart out too much.

Eskom brown-outs sadly too common, but as mentioned the stubby has had issues but it would log an inverter fault for low voltage.

0 Likes 0 ·
nickdb avatar image nickdb ♦♦ commented ·

Just to add.

Some times it helps to go back to the drawing board, so if you haven't already, go step by step through the guides:



Failing a breakthrough, open your own topic on the supported battery and document the config and issues thoroughly, with supporting VRM charts, alerts etc.

Also remember, a "dip" can be very normal for a grid brownout as power is not smoothed.. In SA, this is quite normal in some areas.

You have not been very specific about the issue so it's hard to tell.

If the system is not just having a power dip (VRM will show this) and it is something else like low voltage alerts, it will be recorded and there are other posts on the subject.

0 Likes 0 ·
Munnik avatar image Munnik nickdb ♦♦ commented ·

Just some feedback on my situation. I properly went out to site about 10 times. I tried every possible test that i could think off, I even installed an AVS and contactor, nothing worked. I was literally on my way to remove the inverter and battery and sent it back to the supplier. I friend of mine phoned and said he had the same issue with the dipping on a Multiplus 2 and BSL battery site and he installed the latest V500 firmware. The latest was the V497. This came out this week or last week. I upgraded the inverter with the firmware...and i couldn't believe it.. problem solved. Me and the client are over the moon because this was an extremely frustrating and time consuming exercise...

0 Likes 0 ·
martin-delp avatar image martin-delp Munnik commented ·

That is great news Munnik! I will also try this. Can you please report back in a few days time whether the change-over is successful in all instances of load-shedding at that site? Since load-shedding is now a daily occurrence in RSA it should take too long to confirm whether this is a permanent fix.

0 Likes 0 ·
Munnik avatar image Munnik martin-delp commented ·
Hi Martin. I spoke to soon, but the latest firmware has made a massive difference. Previously the inverter switched off and on with every loadshedding, but now it only happened once since my last post..but i will keep you updated
0 Likes 0 ·
Andrew Poluta avatar image
Andrew Poluta answered ·

Hi Guys

I'm having similar issues with the Multiplus II 5 and 8kVA models with the following batteries:

1. Freedom Won E Tower

2. BSL 7 and 8.8kWh

3. Hubble AM2

Many systems have run great for months but just recently started acting up.

If you are based in South Africa please contact me on 082 411 4060, we need to gather as much info as possible.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

nickdb avatar image nickdb ♦♦ commented ·
Unfortunately not uncommon, all have the same PACE BMS in common. Been plenty of complaints. FW e-tower have been particularly problematic. If you search on this site you will find a topic on FW in particular.
0 Likes 0 ·
Munnik avatar image Munnik nickdb ♦♦ commented ·
What is frustrating is that I sold the Victron inverter as the Rolls-Royce of all inverter but 99% of all my problems comes from them. Between Goodwe and Sunsynk I have done about 30 installation and they just run. Victron I have done 3, just UPS no solar where 2 of them is just a nightmare, constant dipping, to they point where I told the client that I will give him a full refund because I just don't know what to do anymore...This is probably just my experience but as far as it depends on me I will stay away from a Victron installation as far as possible..they are just a headache
0 Likes 0 ·
nickdb avatar image nickdb ♦♦ Munnik commented ·
It is a battery/BMS problem, when these issues have arisen adding more battery has solved it. Transformer and transformerless inverters behave differently, but these issues almost always result from a pack that can't cope with what is suddenly demanded from it and when one BMS manufacturer is the common denominator, not much the inverter can do about it.

0 Likes 0 ·
alan-2 avatar image
alan-2 answered ·


I have / had the same issue.

To me it looked like the charger section was the problem, so I went out an got external chargers and keep Multiplus in inverter mode…

Also, the offices were using nonAVR generators that went as high as 62 Hz at times…

So now there is no dipping, as there is not changeover and no comms between inverter and charger…

One thing interesting I saw is that Revov has popped up as a battery charging profile on the chargers…

Which means there is a very specific management of these batteries.

Incidentally, we have had two of the 200Ah units with a bad cell, out the box.

It only shows up when you take it off charge.

Then run the BMS software to show individual cells.

You will see on of the cells on 0.0v…

My take- it’s a new venture with teething issues.

It’s a nice concept, getting full use of cells… but…

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Related Resources

Additional resources still need to be added for this topic

MultiPlus-II Product page 

MultiPlus-II Manual

MultiPlus-II 230V Datasheet 

VE.Bus Error codes