question

kaffeetasse avatar image
kaffeetasse asked

Voltage and Frequency pulsating - Multiplus 3000 + Fronius Primo 3.0-1

I have a very annoying problem with my off-grid setup of a Multiplus II 48-3000 and a Fronius Primo 3.0-1 PV Inverter. As soon as the Fronius connects its Power Unit through, the voltage starts oscillating from 200 to 250V and the frequency (according to my Cerbo) from 49.9 to 50.1, as you can see here: MAP001.jpg


It stays this way as long as the MP is charging the Battery (200Ah LiFePo4, no limit from the Battery Current etc.) or as long as there are no loads > 500W delivered from the battery (e.g. I turn on my heater).

As soon as the frequency rises above 50.2 Hz (when Throttling) the problem disappears, so I assume there are some regulators oscillating which parameters I can't change.


I've already tried updating the Firmware both of the Muptiplus as well as the Primo. The Primo is on the MG50 setup, the MP has the PV Assistant loaded.


I've tried to adjust the voltage between 210 and 240V, which has no effect. If there was a way to fine adjust the freqency I would do just that, as it would solve the problem to set it to 50.3 or so, as I have no clocks on the system, but there seems to be no way to set anything except 50.0 or 60.0 unfortunately - whereas with 60 Hz the issue is also there.


I'm kind of disappointed as everything works fine except this problem, which seems to also affect my batteries, because the battery current also oscillates quite much as a result, which causes problems when balancing.


Thanks so much for your help!

offgridFroniusAC PV Coupling
map001.jpg (134.1 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

4 Answers
kaffeetasse avatar image
kaffeetasse answered ·

Just to add some more information:
Here is a picture of my vrm portal when the Battery is >95% and the frequency starts shifting. As you can see, the fluctuating AC Voltage levels immediately "calms down" as soon as the frequency goes up to 51Hz and starts to jump around again afterwards - it really is strange:

bildschirmfoto-2022-01-02-um-145743.png
Here is the voltage ripple on one of my Battery cells, it fluctuates as much as 250mV(!):
voltage-ripple-bat-cell.jpg

The only solution I could come up with is to try and set up a warranty dispute for the Fronius - as if there is a hardwareproblem, it is most likely caused by it.


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

sunnyday333 avatar image
sunnyday333 answered ·

Hello,

I want to ask if you have solved anything in this problem? A few days ago, I installed Fronius Primo on AC-OUT Multiplus and I'm solving the same problem. If it is running in island mode and the frequency is below 52Hz, the AC voltage fluctuation is from 210V to 250V as you can see:


screenshot-2022-02-07-at-093242.png


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

marekp avatar image
marekp answered ·

@Kaffeetasse

It could be the Primo's firmware problem and contacting Fronius service was the good idea.

Similar problem was disused here.

https://community.victronenergy.com/questions/119345/fronius-primo-501-voltage-pulsating-problem-after.html

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

kaffeetasse avatar image
kaffeetasse answered ·

Thanks for your help! Fronius in fact was able to install a firmware update that resolved the problem!

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.