question

elel avatar image

SoC jumped to 100% while the battery was being discharged


I have the following simple setup with ESS Assistant in which I charge the battery from the grid during low rate period at night and then use the battery for the house loads during day time.

configuration-diagram.jpg


I encountered a problem in which the SoC shown in the VenusOs screen jumped from 69% (Main On+Absorption LED “ON”, Inverter On LED “Blink”):


soc-jump-1.jpg


suddenly to SoC 100% (Main On+float LED “ON”, Inverter On LED blink):


soc-jump-2.jpg


while the battery was being discharged!

The battery pack has its own BMS and the BMS has no connection to the MP-II.

I set the "State of charge when Bulk finished " to 90% in VEConfig and it worked properly.

I set the "Minimum SoC (unless grid fails)" in ESS to 10% and it worked properly.

The “Float Voltage” set in VEConfig was 52V. The above problem occurred at 53.2V .


Any advice on:

Why the Float LED suddenly lighted up?

Why the SoC suddenly jumped to 100%?


SOC
soc-jump-1.jpg (13.8 KiB)
soc-jump-2.jpg (13.6 KiB)
3 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi we would need more setup information to be bale to help you

Please send setting pictures on the Muttiplus ve configure settings one screen shot for each of the screens - also in the GX please send the system setup setting showing the battery monitor selected


Thanks a lot for the response. Below are the settings exported from VEConfig:


TAB: General

System frequency 50Hz

Shore current 100.0 A

Overruled by remote unchecked

Dynamic current limiter unchecked

External current sensor connected (see manual) checked

State of charge when Bulk finished 90.0 %

Battery capacity 277 Ah

Charge efficiency 0.95

TAB: Grid

Country / grid code standard UK: G98/1 March 2019, G99/1 May 2018

LOM detection AC input 1 Type B (grid code compliant)

start P(f) at 50.40 Hz

start delay for p(F) 0.08 s

Droop for p(F) 10.0 %

Use Aux1 (if available) as disable FeedIn signal checked

Reactive power regulation Use a fixed Cos Phi

Filter time for reactive power 3.3 s

Cos phi at point 1 1.00

TAB: Inverter

PowerAssist unchecked

Inverter output voltage 230 V

Inverter DC shut-down voltage 48.00 V

Inverter DC restart voltage 50.00 V

Low DC alarm level 49.00 V

Do not restart after short-circuit (VDE 2510-2 safety) unchecked

enable AES unchecked

TAB: Charger

Enable charger checked

Weak AC input unchecked

Stop after excessive bulk checked

Lithium batteries checked

Configured for VE.Bus BMS unchecked

Charge curve Fixed

Absorption voltage 55.00 V

Float voltage 52.00 V

Charge current 70 A

Repeated absorption time 1.00 Hr

Repeated absorption interval 7.00 Days

Absorption time 1 Hr

TAB: Virtual switch

TAB: Usage

Virtual switch usage Do not use VS

TAB: Assistants

TAB: Assistant Configuration

ESS (Energy Storage System) (size:962)

*) System uses LiFePo4 with other type BMS

(This can be either a BMS connected via CAN bus or a BMS system in which the

batteries are protected from high/low cell voltages by external equipment.)

*) The battery capacity of the system is 277 Ah.

*) Sustain voltage 49.00 V.

*) Cut off voltage for a discharge current of:

0.005 C= 48.00 V

0.25 C= 48.00 V

0.7 C= 48.00 V

2 C= 48.00 V

*) Inverting is allowed again when voltage rises 2.00 V above cut-off(0).

*) Relevant VEConfigure settings:

- Battery capacity 277 Ah.

- PowerAssist unchecked

- Lithium batteries checked

- Dynamic current limiter unchecked

- Storage mode unchecked


Below is the screen for the "Battery Monitor" :

battery-monitor-automatic.jpg


Here is the video showing the sudden jump to 100% SoC.

https://drive.google.com/file/d/16hqb87Ce6e9MNH_LlkQA6yIPiyxORBO8/view?usp=sharing


Look forward to your advice on this problem.


(Note: I also have some other problems encountered:

https://community.victronenergy.com/questions/113770/discrepancy-between-grid-setpoint-and-the-actual-p.html

I am not sure whether they are related.)



The same problem happened again today in which the SoC suddenly jumped to 100%SoC.

After the sudden jump-to-100%-SoC problem last night, the system failed to execute the scheduled charging after mid-night and then did a list of erroneous actions after that…… (but these are not the subject of this thread and I will handle them later, just in case they are related to this one).

I somehow was able to schedule the changing during daytime. The battery then discharged as expected but then jumped to 100% SoC from 80% just like what it did last night. Here is the link to a short video which shows what happened.

https://drive.google.com/file/d/1NUdbynsnhQS0EemTmcZi3BBPSp2uKSzK/view?usp=sharing


Any help or advice would be very much appreciated.

(Note: after the setup of the ESS, it was the 2nd time I discharged the battery from the end-of-bluk-charge status and in both cases this problem occurred.)

1 Answer
Paul B avatar image
Paul B answered ·

If you look at your video you will notice that it switched from Absorption to float on the multiplus loghts then the SOC flipped to 100% -

So I would think that the Multiplus was ending the absorption phase of its charging cycle as its held the battery voltage at 55v for 1 hr as set and is now changing to float mode of 52v, at that point the SOC is changed to 100% as the battery is full.

The small discharge is occurring because the absorption voltage is 55volts and float is 52 so you will see a negative amps figure until the float voltage reaches the set point set being 52 volts.


well thats my thoughts as to why


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.