question

magicmike avatar image
magicmike asked

SOFTWARE GLITCH. cerbo is getting FROZEN and loosking internet connection and BT randomly after IP CHANGE.

EDIT:


11 of December 2021.

Please check out my last post.


///////////////////////////////////


Hey,

I wouldn't post it but now im really angry,

I tried via ethernet and wifi. Its same problem till i manually reset cerbo by 'plug out' and i have no access to remote console till i do it.

If anyone had this issue please let me know how did you fix it because now i have to drive 2hrs to turn off generator and its 21:00 at night...

Venus hot spot is available but cerbo is frozen.


EDIT:


100% that once ip on router is dynamic cerbo is loosing connection and hitting loop.

Happened yesterday agian.


screenshot-2021-10-29-205850.png

screenshot-2021-10-29-205856.png


screenshot-2021-10-29-205859.png


cerbo gx
2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

harold avatar image harold commented ·
Giving my CCGX a fixed IP adres on my router, solved my Wifi problem.

Was losing connection too

0 Likes 0 ·
magicmike avatar image magicmike harold commented ·

Yeah i just arrived. I was thinking about that it could be an issue with dynamic IP but... It also happens via ethernet not only wifi.



Bluetooth does not work till hard reboot and new paring.

Green light and blue light flashing.


I can go back home i believe :)


0 Likes 0 ·
8 Answers
Paul B avatar image
Paul B answered ·

Make sure that the cerbo is also on the latest Fw 2.73

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Paul B avatar image Paul B commented ·

A further note is that you can set the cerbo to Reboot if it does not see a connection, look under setting and VRM

1635581100103.png


0 Likes 0 ·
1635581100103.png (26.4 KiB)
magicmike avatar image magicmike commented ·

screenshot-2021-11-01-004428.pngscreenshot-2021-11-01-004514.png


Cerbo is getting stuck badly once IP been changed. Sadly my LTE router wont let me set up static IP for any device. IP stays dynamic.


0 Likes 0 ·
Daniel avatar image
Daniel answered ·

Change WiFi Chanel on your router turn off auto channel and set it to channel 11. if you can’t do that or still doesn’t help then buy this, the Cerbo will find it straight way .


D-Link DWA-127 High-Gain Wi-Fi N150 USB 2.0 Wireless Adapter with External Antenna https://www.amazon.co.uk/dp/B006ICOGEK/ref=cm_sw_r_cp_api_glt_fabc_5PZPMYF0CTMR410Q55N4?_encoding=UTF8&psc=1


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

magicmike avatar image
magicmike answered ·

OK ive this done, ll see. i dont have problem with wifi signal at all.

Its full blast, problem ocured with wifi and wire connection.

Today in morning same problem. I think its should not happen over all. For me its glitch that might have bad consequences if someone is away for example and gives cerbo full trust.


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

nickdb avatar image
nickdb answered ·

Your router IP cannot affect devices on your network, unless the router is having an issue or breaking the routing table and/or dhcp.

Try a different router or attach the gx to a wireless hotspot.


1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

magicmike avatar image magicmike commented ·

it is under hotspot now since last week under repeater.

0 Likes 0 ·
magicmike avatar image
magicmike answered ·

up.


cerbo frozen again once ip changed.

its 21:20 so i ll be back home after 24.

Good job Victron.screenshot-2021-11-11-212510.png

screenshot-2021-11-11-212456.png


screenshot-2021-11-11-212656.png



Should be under local as i have remote desktop connected in garage.



2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

magicmike avatar image
magicmike answered ·

bump

looks like i have to do 2hrs trip tonight again.


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

magicmike avatar image
magicmike answered ·

There is nothing better than spending time with family on Saturday right?



Nah, thats not true. Its better to drive to work and HARD REBOOT CERBO.



I found something few weeks ago, Once IP been changed CERBO has problem with BT and WIFI / ETHERNET.

Ok so i got 2nd phone and hooked up in garage.

Sometimes its works, must remove cerbo from phone BT devices then add again, add to network again and then i can connect remotly / VRM working again.

Buty not today my friends!

I cant believe its happening, never had any device in my hands thats has connecting issues after dynamic IP been changed.

Especially that device that costed me almost 400 euro...


To add more fun i found plenty posts that people strugling with simillar issues, problem is no one goes deep and no one analyzed problem like me?

Maybe becuse i dont like puting money into bin.



What ive tried,

static ip, dynamic ip, static ip over wifi/ hot spot, dynamic over wifi / hotspot

static over etherner, dynamic over ethernet.






2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

michelg avatar image
michelg answered ·

Hi MagicMike,

Sounds curious ! I have my Cerbo GX connected to WiFi, and it only happened once in almost 18 months... A few things that may explain the situation :

Your router is unstable, there are many WiFi signals in the area, according to your previous posts, in my opinion the problem is related to the router / repeater. For any reason it does not provide the IP address to the mac addresses of the Cerbo network cards.

Either it was an issue with the WiFi, ok, it may happen, or with the RJ-45 NIC, but when it is on both, you have to look further at the router / repeater.

Could you provide all the router DHCP parameters ? Also if you have access to it, take a look at the MAC addresses table, I suspect the router does not release them, and when the Cerbo tries to reconnect, the MAC being already in the table, it does not provide the IP Address.

I also need to know the hardware you are using (both Router and Repeater), models, versions and firmwares installed on them.

Thanks, Michel

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.