question

matthew-goward avatar image

ip22 12/30 only delivering 18amp

screenshot-20211002-160402.pngI have an ip22 12/30 charging a pair of 100ah battle born lifepo4 batteries. It will charge for a couple minutes at 30amp but then drops to 18.2ish amps and stays there till absorption. I have tried the lipo preset and I have tried custom with the absorption voltage at 14.4 (per Battleborn) and turning off battery safe. I have tried it with and without my built-in RV converter adding 10amp of its own. What else am I missing that is causing it to drop down to 18amp from 30?

battery chargingbluesmart ip22
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
duane avatar image
duane answered ·

I had a similar issue and found that the fan in the unit wasn't coming on

I pulled the top off the unit and blew a little bit of cold air on the inside of the unit while it was charging and it went up to 30 Amps straight away. After fiddling with the fan and reassembling it it worked perfectly.

Something you could try I think its just temperature derating

1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Sounds like something I might try.

Did you find anything wrong with the fan or did it just work again after reareassembling it?

Anything else that I should look out after, while having the unit open?

duane avatar image
duane answered ·

Don't forget you could be electrocuted if you go putting your fingers in the unit running with the top off. Proceed with caution

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.