richard-maton avatar image
richard-maton asked

Why my Skylla IP65 intermittently stops charging

I installed a new Skylla IP-65 charger (12V/70Amps/3 outputs) with the Skylla-i Control 2 weeks ago. It is setup with 2 lead-acid battery banks. DC power cables are #6 AWG. (1 output is left open) I'm also using the temperature sensor and the remote voltage sense on bank 1. It's been working very well since last night. After a 6 hour boat ride, we got into the marina, connected shore power and the Skylla stayed at 0.0 amp. Skylla-i control was showing bulk mode, with 0.0 amps and battery voltage of 11 volts. I measured 12.5 volts at the battery post and the skylla charger posts. Turned it on and off twice. Same result. Thinking that it might be the temp sensor or the Vsense circuitry problem, I disconnected those 4 wires and switched it on again. Same result. I shut it down again, reconnected all the temp/Vsense wires, turned it on and now it's working!!! The charger was not hot in any way and is not installed in the engine room. Since then, I cycled the AC power this morning to see if it would fail again and it did not. What am I looking at? Cold solder on the circuit board? software bug? known issue? Thanks for your help.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

rlynch03 avatar image rlynch03 commented ·

I have the same Skylla IP-65 charger (12V/70Amps/3 outputs) connected for the last 28 days or so. No problem until today. Noticed the same trouble this morning. Skylla is up and running but will not charge the batteries. Also under the Cerbo GX Reset the power, verified source voltage at 123volts.

Will try the disconnect and reconnect procedure that worked for you. Not sure of the root problem however.

Hopefully Victron tech's will weigh in, potential software update to correct. Firmware is v1.10 on the Skylla.

0 Likes 0 ·
rlynch03 avatar image rlynch03 rlynch03 commented ·

I disconnected, left it for a few minutes and reconnected the wiring. Turned everything back on but no luck. Still not charging.

Submitted for warranty replacement. Our vendor, PKYS Inc. bench tested and confirmed the unit has failed. Now pending Victron's repair/replacement process.

Hopefully quick turnaround...

0 Likes 0 ·
rlynch03 avatar image rlynch03 rlynch03 commented ·

So #PKYS Inc determined the Skylla Power Supply connections are defective. They sent the message to Victron but after a few business days it was approved for warranty replacement. Unfortunately, we have to wait for the replacement to be shipped to PKYS. A few more days.

A bit disappointing that PKYS, Inc. has stock of these units and they have an approved RMA for a new one but will not swap stock so their customer doesn't have to be without a battery charger.

Wonder how Amazon would have handled this return?

0 Likes 0 ·
0 Answers

Related Resources

Additional resources still need to be added for this topic