question

simon-eric avatar image

SmartSolar 100/20-48 disappears from VRM Portal

Hi, I am new to the forum and I need some advice on a problem that keeps popping up with my SmartSolar 100/20-48 charge controller connected to a Raspberry Pi.

Let me start off by saying that I am running the latest stable firmware on the Raspberry Pi (v2.66). I have also connected my Victron 500A smart shunt and SmartSolar 100/20-48 controller (both are running latest firmware) to the raspberry pi thru a USB adapter on each. The smart shunt works perfectly, and is always connected and transmitting data.

My problem is occurring with the solar charge controller. It will stop sending data to the VRM portal randomly throughout the day and consistently over night. The only way to get data flowing again is to restart the raspberry pi. Then the cycle starts over again.

Could there be some setting I missed in the solar controller that is causing it to stop transmitting data?

Thanks for the help!


MPPT - Solar Charge ControllerRaspberry Pi
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
simon-eric avatar image
simon-eric answered ·

Swapping USB ports seems to have fixed the problem.

1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I have had the same issue with my Victron 150/35 MPPT vanishing from Cerbo GX for 3 months now. I honestly think it is a software issue not the cable. It keeps disappearing and re-appearing on its own. I have given up on trying to get a solution.