question

wossam avatar image

Victron BlueSolar MPPT 100/20 - Load output is always on

The load output on my Victron BlueSolar MPPT 100/20 wont turn off and is always on.

What happened before:

  • Update to the newest firmware v1.54 for the Smartsolar and v2.25 for the Bluetooth interface.
  • Connecting an inverter with 4kW total max power to the load output, but with no load to the inverter. The MPPT was giving error codes which I didn't write down.
  • Reset to factory values

Setup and beheaviour rigth now:

  • App on the phone will let me set load output to always off and always on.
  • No measure on power and current on load output
  • Fuse on the smartsolar is ok / not broken
  • No jumper set
  • Street light function off
  • Everything else is working just fine

I was thinking of an update error, but the inrush current of the inverter might have damaged the load output possibly.

Did anybyody experience a similar effect and have hint on what might cause / how to solve this?

MPPT Controllerssoftware
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
wkirby avatar image
wkirby answered ·

When I read "Connecting inverter with 4KW" I immediately thought that the Load Output mOSFET would not survive this.
In the first milliseconds, this is a few hundred Amps, no chance for that output MOSFET.

Short circuit MOSFET is most likely the problem.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

jbecker avatar image
jbecker answered ·

This is an old thread, but I have experienced the same problem recently. Output MOSFET was fried after trying to switch ON a 350W (!) inverter.

The reason for the fried MOSFET is most likely not the high inrush current (as the output is advertised as short circuit proof!). It ist most likely the inductive voltage spike when switching OFF wehn the unit detects the high inrush current. There does not seem to be any supressor diode on the output! So even switching longer cables may destroy the output MOSFET.

After adding a 82V suppressor diode to the output, the second MPPT 100/20 is now happy switching the inverter ON and OFF repeatedly!

For me this is a real big issue with the load output on this device! Having short circuit protection without overvoltage protection is not enough! Perhaps one of the Victron people can shed some light into how the output is supposed to be used ....

Best regards, Jörg.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.