question

greg-johnson avatar image

Same cable for smartsolar vs smartshunt?

I have two VE.direct cables and both appear to work flawlessly when connecting my cerbo GX to my smartshunt (the device appears in the top level menu of the console). However, neither of them seem to work for the smart solar.

The BLE connection to the smartsolar works fine, and I was also able to set up "VE.smart" networking between the smartsolar and smartshunt (which I assume is using BLE?). However, I cannot get a thing out of the smartsolar.

I also doublechecked that both the 'streetlight' is disabled, and 'TX port function' is set to 'normal communications', as I read that these override the serial RX/TX lines of the MPPT.

I finally checked the VE.direct straight into my laptop and see no streaming characters either.

Is there something else I can do?

Thanks!

greg

MPPT - Solar Charge Controllersmart shunt
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
Paul B avatar image
Paul B answered ·

Hi Greg, yes the cables are the same, make sure the cerbo is on the latest 2.60 firmware and make sure the smartsolar is also on the latest firmware. the cerbo should just see it if not try under settings then select general then reboot the cerbo

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

greg-johnson avatar image
greg-johnson answered ·

Thanks @Paul B . Unfortunately, my cerbo is on 2.66, the smartsolar is on 1.56, and I _sometimes_ get the MPPT being visible. It happened once last week for about 8h, then it disappeared again. The lack of dedicated technical support from Victron is driving me a bit bonkers.

1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Greg-johnson,

sound like there could be a problem with the VEDirect interface port on the MPPT.
Best is to contact the dealer where you got the product. They will be able to help you
https://www.victronenergy.com/support

best regards
Martijn Coster - Victron Energy

Paul B avatar image
Paul B answered ·

Hi Greg, 2.66 is the latest FW now Note the Max length of a VE Direct cable is 10Mtrs, and then it needs to be run away from power cables and other items that emit electrical interference

maybe you could try a USB cable version if you are running long lengths IF so you would need a Ve direct to USB adapter cable then a good quality USB cable and plug this into the cerbo units USB port

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.