question

valden avatar image

Cerbo failing to connect to B&G Zeus3S

My Cerbo GX is on Firmware V2.60, which I understand is the latest as at mid December 2020. I also understand some networking/password issues with this Firmware edition are being investigated.

Connectivity of the Cerbo to a B&G Zeus3S is very flaky. MQTT is enabled. Upon startup of the Zeus3S, the Cerbo’s Remote Console will be visible on the Zeus for a couple of seconds or for a few minutes, but the following error screen always appears. Can anyone deal?

My boatbuilder’s electrician and Victron installer is stumped wrt this problem. The one other Cerbo he installed, with a Zeus 16” glass cockpit multifunction device, did not have this problem. Older Firmware, perhaps?
Thank you

Edit - prompted by JohnC’s answer: My B&G Zeus3S multifunction device is the 12” version.

Edit: the screen resolution for the B&G Zeus3S is 1280x800.

Edit: the ethernet cable connection between the Cerbo GX and the B&G Zeus3S is composed of a standard UTP ethernet cable from the Cerbo, to a B&G NEP-2 Network Expansion Port ethernet switch box, then a B&G cable with a five-pin connecter to the Zeus 3S chartplotter. Should work - and does work, in terms of making the link and communicating via the MQTT protocol. It’s just the weirdo crash and error message that’s the problem. I can find nothing in the Zeus for dealing with screen size or resolution, other than a text size selection, which did not help. I understand that Victron is not in a position to assist with networking problems via this forum. Fair enough. This is looking like something other than a network problem.

09c0161f-cb28-4b9a-9a23-6342311363dc.jpeg

cerbo gxMQTT
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
JohnC avatar image
JohnC answered ·

Hi @Valden

This may be just a screen resolution issue, but I don't know your Zeus.

I can simulate that message using a CCGX (2.60), wifi, and Win10 laptop/Firefox with the url 'venus.local/app'. The details are different of course, with different kit.

By zooming in or out too far.. But you can't just zoom back in and expect your target to reappear, because it won't. You have to then reload the url for that to happen. So finding the right zoom might involve some trial & error. 110% zoom works fine for me, but there's a bit of range to work with.

How your Zeus works I have no idea..





1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

@JohnC Hi John. Thanks for this idea. I will investigate and report back. :-) As far as I know, the installer and I have used only default settings.
Of interest, while investigating possible problems, I switched off connection protocols that were not in use, such as CANbus and BMSbus. Perhaps the installer’s quick fingers had turned these on. Anyway, after that and another reboot, Remote Console worked well for many minutes, with lots of touch-screen button pressing on both GX Touch 50 and Zeus3S screens. I thought I’d fixed it, but then the black screen of Error reappeared. Curious.

mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi both, thanks for the reports. It should work flawless, which it does in the vast majority of installs but apparently something is different here. We’ll look into it and get back to you

3 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thank you for investigating this. I have tried everything and it keeps tripping up, with the same old error message. After some reboots the display of Cerbo data on the Zeus 3S and even Remote Console works for several minutes, but then the rendering error appears again. I can always refresh the Zeus screen and get it to display current Cerbo data for a second or two before the error screen replaces that data. So, it’s trying to work, but keeps failing. :-)

I may have discovered what the problem is.

Today I had the autopilot display showing on the left of the Zeus3S screen when I activated the Victron app, to display the Cerbo information. It seems to be stable. The size of the window used for the Victron app is narrower than for when the autopilot display is collapsed. Importantly, I can replicate the reported fault by collapsing the autopilot display on the left and then initiating the Victron app. Hmmm, curious. Here are some pics of the app working well - it seems. Fingers crossed! Of course it would be nice if the app could work well regardless of the autopilot display status, but this is a step in the right direction. :-)

0158bdd6-6a45-4ae8-a8f4-1b4f1f2802c4.jpeg39186f1b-6f66-47b9-8570-26b6788b9231.jpeg


The Victron app has been stable for several hours, with lots of other use of the Zeus 3S in the meantime. The key is to have the autopilot display expanded on the left of screen. As soon as this is collapsed, the Victron app displays the error message. I think we can take this as a solid clue as to what the problem is, along with a workaround solution. :-)