wanderbird avatar image
wanderbird asked

Changing Device Instance on Dual CCGX.

Two 800ah Victron battery banks with Quattro, VE.Bus.BMS, CCGX control on N2K. We are having an issue setting the device Instance for the CCGX. We contacted Maretron and we are both in agreement that because the CCGX acts as a gate way to the N2K unless we can change the Device instance only one battery bank will show information to the N2K network. We have tried with N2K analyzer and with Actisence Software to change the Device Instance with no avail. When selecting the device instance on network page the number changes but soon as you hit enter it reverts back to 0. We have a large system and maybe this is cause a problem. We have tried several configurations to change the Device Instance but nothing has worked.

NMEA 2000 - N2K
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi Wanderbird, and welcome to community!

First of all, make sure to update the firmware of both CCGX-es to the latest official version, currently v2.61.

It allows changing the Device instance straight from the CCGX menu.

All details here

Beware, N2K and especially instances are a complex topic. Lots of reading might be necessary.

Read all of that chapter, and especially chapter 11.4.


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

wanderbird avatar image wanderbird commented ·

Both our GX are running v2.6. I have read the information you provided in the link previously when I was working with Maretron. I also read it again as well. I followed the instructions and have also done it with several other technicians. When you select edit the device instance you can change the number but once you hit enter/check it reverts back to 0. We have removed both of these from the N2K network and put them on there own isolated NMEA 2000 powered system and tried to edit the Device Instance through Maretron and through Actisence both softwares did the exact same as the GX it allowed you to edit the number but once you entered it it reverted back to 0. When then tried doing this by the device and same thing happened the number will change but soon as you select enter/check it reverts back to Zero.

CCGX: BPP010300100R SN: HQ1843V8G51 v2.18 hw rev 2

CCGX: BPP010300100R SN: HQ1843V9BQP v2.18 hw rev 2

We have found that the software does allow you to change the number on the CCGX but for some reason it does not register in the device. We have tried this on its own NMEA 2000 network we have done this when the unit is only connected to VE.CAN and no NMEA 2000. We have isolated the system on its own so that it is the only CCGX on the NMEA 2000 Network and we have tried it with the fuse in and fuse out of the VE.CAN to NMEA 2000 network cable.

There could be thousands of issues that could be causing this problem but until we understand more about the Victron CCGX and how it is interfacing on the NMEA 2000 network we will be operating in the dark. I would like to know does the CCGX act as a gate way to the NMEA 2000 network and if so, is it running its own VE.CAN network on the back side say going to the Lynx VE.CAN Shunt? Do I need to terminate the Victron side of the network. For most NMEA 2000 networks, devices on the network are not terminated as this will end the back bone, but if Victron's VE.CAN system is powered from this cable through the CCGX there would be now way to terminate the other end of the network. I have looked through all the schematics I can find so see how Victron recommends us to connect the VE.CAN to the CCGX. Currently we have the Lynx VE.CAN Shunt plugged into one of the VE.CAN port on the CCGX. The other port on the CCGX is plugged into the VE.CAN to NMEA 2000 cable. This is plugged in to a Maretron Multiport and we have the fuse removed because our Maretron/NMEA 2000 back bone is powered by a power tap. Do we need to power the VE.CAN to NMEA2000 cable, does this cable supply power to the CCGX Victron VE.CAN and does the VE.CAN need this power to function properly?

0 Likes 0 ·
bathnm avatar image bathnm wanderbird commented ·

Yes the CCGX is acting s a bridge between its world and the NMEA2000 network. Details of this exist in the manual in section 7.4.2 on virtual devices.

I had issues getting data on my Raymarine system and found that device instance did not work and had too change the data instance. As soon as I did this I got all teh various battery details on the Raymarine. Details of changing data instance can be found in this document at section 5.2. Note you do need to be able to log into the console of the CCGX using ssh.

Good luck.

0 Likes 0 ·
wanderbird avatar image wanderbird bathnm commented ·

So can you give me a break down of your system? Do you have dual CCGX on the same the same N2K network?

0 Likes 0 ·
wanderbird avatar image
wanderbird answered ·

So after several days of research and frustration. I was able to resolve the issue that I was having with our Dual System. Victron does not allow you to change the device instance on any of their GX devices if you have their VE.BUS BMS running with their Smart Batteries. As posted earlier by bathnm you have to go in and change the data instance output using Actisense its a very cumbersome system. I hope that as Victron advances with their products will be able to change device instance in the device with a BMS installed. So again the fix to get the data to send on the system is to change and set the data instance through Actisense. I found Actisense to be very buggy. I recommend that you select sort but the PGN number and find the Battery Status PGN. Then list each one and change the data instance as needed. This resolved our issue, but did not actually answer this question. You can not change Device Instance on a GX that has a BMS installed.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

bathnm avatar image bathnm commented ·

That is interesting. When I was looking at this I had a VE.Bus BMS and tried changing the device instance. I also did it via dbus-spy rather than the GUI. However it did not solve my problem as Raymarine differentiate batteries based on data instance and not device instance. I had this confirmed by Raymarine.

0 Likes 0 ·
wanderbird avatar image wanderbird commented ·
I should also let the community know that we have a very big NMEA 200o Network. We actually have 4 networks with several bridges. The Actisence software functions much better on smaller networks. My recommendation is make as small a network as possible to perform programing functions like changing data instance or device instance. I found this to be the case with most NMEA 2000 software packages. I have currently swapped out to the Lynx Smart BMS for our system and I still have to change the instance on this system. It seems to be causing some problems with our battery ability to report properly.
0 Likes 0 ·

Related Resources

Additional resources still need to be added for this topic