question

Hugo avatar image

VE Configure grid code error "this device is not equipped with internal interface protection"

I'm trying to set up ESS in VE Configure 3 and it requires me to choose a grid code. I'm in South Africa and when I choose it from the menu, it gives the following error "this device is not equipped with internal interface protection"

I'm using a Quattro 48V/10000VA/140A model with a firmware updated to 2653433

If you look at the following link https://www.victronenergy.com/live/ve.bus:grid-codes-and-loss-of-mains-detection#veconfiguregrid_codes_loss_of_mains_detection you will see an image in section 3 where South Africa had been selected.

So did I get the wrong device or what am I doing wrong? Or do I need external LOM devices?

When I run VE Configure 3 and choose "Fake target with full options" then I'm able to select South Africa in the simulation without error codes

I don't want to feed back to the grid, however ESS setup forces me to choose a grid code

VEConfigure 3
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

5 Answers
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi, in your situation you need to use the Gridcode Other; and then use that in combination with external anti islanding equipment.

Please contact a local distributor or installer; they will have experience with the local situation and how to best deal with that.


Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Boekel avatar image
Boekel answered ·

The inverter has no way of knowing if the anti islanding device is in place, it is always the installers responsibility to install following local regulations.

So if you have the anti islanding device in place, you can set the correct grid code and install / configure the ESS assistant.

if you have a generator on one of the inputs, you should disable LOM detection on that input.

Please be safe and consult a Victron installer if you don't have the right knowledge. In some countries the installer might have to be certified to work on grid connections.

4 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Boekel, I'd be interested to know how you would suggest going about it. Here's what happens: in VE Configure, before fitting the anti islanding device, you're not able to select the correct country.

Then according to you we have to fit the anti islanding device and even though, like you said, the inverter has no way of knowing you fitted the anti islanding device, you will suddenly be able to select the correct country

So what is it that makes the software change it's mind and allow you to select the right country, if it doesn't know you've fitted the anti islanding device?

The only thing one can do is to select no grid code and let the external anti islanding device take care of the rest. However I haven't received an answer to that yet, so I'm not sure if that is the best, or only way. I just know that I'm never allowed to select my country from the list

I just tried setting my own Quattro to South Africa, and indeed it doesn't allow it. other country codes do work...

@mvader (Victron Energy Staff)
anyone have more info on South Africa? external protection not allowed there?

Hi Boekel

What country code worked for you in S.A. to run ESS ?

I'm not in S.A. (I'm in the Netherlands)

for testing purposes I use Germany, UK, other, etc.

Hugo avatar image
Hugo answered ·

I think I might have more information, but I'm not sure if it's accurate. When you follow the link https://www.victronenergy.com/live/ve.bus:grid-codes-and-loss-of-mains-detection You will see that Victron tells you, not all Multi/Quattro models will work in all countries, with regards to being able to run the ESS system (Nobody told me before I bought my Quattro!)


So they recommend that you look at their website for a certificate for your product and your country code. It's not easy, but looking through the certificates I found Quattro inverters certified for my grid code, however not my 240 V unit, just the 120 V ones.


So I'd have to assume that my inverter won't work in my country, that's why I can't select my grid code. Victron then recommends that you install external anti islanding equipment, see this link https://www.victronenergy.com/upload/documents/Anti-islanding-solutions-EN.pdf it's exensive!


What they don't tell you is how to configure VE Configure, once you've installed your anti islanding device, because to run the ESS system, you are forced to choose a grid code and the only one you can choose (without choosing the wrong country) is to choose, not compliant to any grid code standard and then choose LOM type B (safe). If you want to disable LOM on one input for use with generator, it will ask for password (Quattro has two AC inputs)


So Victron, is that correct? I hope you will respond to say I'm wrong and that my inverter can run in my country, just be sure to let us know how please

2 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Hugo

Did you have success configuring the ESS with / without anti-islanding due to grid code issue ? I am in the same situation with a Multi 5kVa and SMA .

Any advice appreciated !

Thanks.

Hi Mike, this was the answer from Victron, see on top: "Hi, in your situation you need to use the Gridcode Other; and then use that in combination with external anti islanding equipment" I haven't tried that yet, I'm still installing my solar panels and running the inverter in UPS mode. Have you tried grid code "Other"? You will also see the warning to install external anti islanding equipment.

MrFT avatar image
MrFT answered ·

Good day

I have two new easysolar systems. I am not able to choose any grid code for any country on the list. I also get the message "This device is not equipped with internal protection! So you cannot choose option: xxxxx. Please can you inform me why the multiplus in the easysolar cannot install any country's grid?

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Luis avatar image
Luis answered ·

I am sure that the system will work in my country (Spain, actually there is an option to select it) but I am getting the same message. Is it not possible to configure an ESS system without the anti-island system?

1 comment Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

My country South Africa also has an option to select it, but it doesn't work. Did you look for a certificate for your inverter conforming to Spain's standard?