question

gyrovague avatar image

Victron ESS slow response to load changes

I have MultiPlus II 5000VA, 12x 395W 3s4p panels, Victron 150/100 MPPT, Venus GX, 4x 3.5kWh pylontech, ET-112 grid meter, all configured for ESS, in South Africa. Initial symptom I've observed is that whenever a large load (say 1.5kW or more, like kettle, heater, geyser, stove....) is disconnected, there is several seconds (I've seen up to 15) of back-feed into the grid, and this causes the Conlog prepaid electricity meter to cut-off the grid temporarily, which cuts off the non-essentials and i.a. causes the oven to lose it's time and timer and current status (so if it was on, it goes off, and remains off, making it impossible to use it to cook food). I've looked up the specs of the BEC23 Conlog regarding reverse energy tripping, and it allows 40W for 15s or 600W for 1s, or anything in between, so it does allow for a reasonable-sounding bit of back feed before it will cut off the grid, it integrates the power every second and looks at the energy within a 15s sliding window basically AFAICT. However, what I've noticed from the victron remote console (on local LAN, not via VRM) is that it takes a very long time for it to adjust to load changes, in both directions -- if a kettle is switched on, it uses grid power initially and slow ramps up how much comes from PV or batteries, over about 15s or more, and when that load goes away, it feeds the excess that comes from PV or battery into the grid for about the same length of time. I spoke to my installer about this, and since some posts here on the forums were potentially implicating the ET-112, he disabled that in the ESS settings for now (which then also loses the benefit of essential vs non-essential loads on the ESS apparently, so wouldn't be a permanent solution anyway). In any event, this seems to have made no difference at all, I still observe the same slow ramp-up and ramp-down on load changes, the latter leading to the grid back-feed causing the prepaid meter to trip.


The municipality refuses to replace my prepaid meter, as they have an exclusivity arrangement with Conlog apparently, and the L&G apparently needs some sort of power-line comms GSM concentrator to be installed city wide, which is not in place. The installer wants me to privately replace the Conlog with a Landis&Gyr 4-quadrant meter with GSM comms module, at a very high price to me, but this seems like the wrong solution to me. At best, if it actually works, I'm being asked to pay a hefty sum for a workaround to (what I perceive as) the slow Victron response to load changes? At worst, the problem might persist after this expensive experiment.


There seem to be a number of posts on this or related topic, but nothing more recent than two months or so, and no satisfactory answers that I can see. Some posts even have answers from Victron staff saying a solution is being worked on, but no follow up to that which I could see... FWIW, all the firmware was updated as part of the installation a few weeks ago, so it's not more than a few weeks outdated at worst. Based on forum posts here, I've tried increasing the ESS "grid set point" from the initial 50W to as high as 300W, and while it somewhat reduces the prepaid meter tripping incidence, it does not at all resolve it, and the higher I set this, the more ESS advantage I'm losing of course.


So my question is, is this something known to Victron which will have an imminent firmware fix? Is there some configuration parameter/setting that needs to be changed? I really don't want to go down the arduous and costly route of replacing my otherwise-perfectly-good Conlog prepaid electricity meter with a very expensive (over R8000, or 400 euro, excluding installation) 4-quadrant L&G meter if not absolutely necessary.

MPPT - Solar Charge ControllerESSgrid
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
Daniël Boekel (Victron Energy Staff) avatar image
Daniël Boekel (Victron Energy Staff) answered ·

Hi @gyrovague

Please use the existing topic about this:

https://community.victronenergy.com/questions/51697/victron-ess-et112-slow-response.html


for faster response: have the loads behind the inverters, this gives a faster response than with the energy meter.

2 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thanks, I saw that one, but there was a comment by you from early June saying "I've asked around, and this is a known issue that is being worked on", but I've seen no follow-up on that.... so apologies for making a "duplicate", but I'm desperately seeking a solution.

hi @gyrovague

I fully understand, that's why my advice now is:


for faster response: have the loads behind the inverters, this gives a faster response than with the energy meter.

having the energy meter as source works for 99% of customers, but in this mode all kinds of grid rules have to be followed also (that's one of the reasons it's difficult to improve the reaction time), when loads are behind inverter ('critical loads'), the inverter can provide power almost instantly.