question

laurenceh avatar image
laurenceh asked

Can you install signalk on a Venus OS Rpi, and how ?

I would like to get a Json interface running to access the Venus dbus data from an Ajax client but have so far failed.

Background

I have a working Ajax implementation of a GUI this was written a few years back and easy to customise and serve from the inbuilt Venus web server - Hiawatha. I would like to make calls to access the data in Venus OS running on my Rpi 3B+. The UI Being Ajax and Javascript, the interface should be REST/Json. I could write a Json server to interface to dbus but I realised this is just what Signalk offers. So I took a look at how to get it installed.

Going forward an Ajax UI could be easier to customise within the community than the current pages, would be lightweight as much of the processing is in the client end - not the server, and should integrate well with the signalk service/

Getting Signal k running:

I tried following this instruction: from https://github.com/victronenergy/venus/wiki/Signal-K

"Note for the raspberrypis that it is not necessary, nor recommended to reinstall a full image on an sdcard. Doing so will also remove all configuration and stored data.

Latest available files:

The SWU is found own the SDcard and selecting it says installing. But when the install is complete going to [IP address]:3000 does not display a dashboard and I can't find any installed files with include signal k in the filename.

Either:

I have version Venus OS 2.51 running already so perhaps the SWU which is for 2.50 is ignored.

or

I do need to do the full sdimg install first as per this instruction:

"To install Venus OS + Signalk on an sdcard for a rasperrypi; follow these instructions; but then using below file instead of the one mentioned in the instructions:

And If I do this then how do I go for future version updates (2.6 being around the corner).

Or could Signalk be made available as a opkg install?

Does signal k have much dependency on the Venus OS version?

Venus OSRaspberry PiSignalK
6 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

perstr avatar image perstr commented ·

Is the extended image file for Rpi no longer available for download? Or has they been merged into one image today?

Looking to install SignalK on the same Rpi running Venus OS.

0 Likes 0 ·
Stefanie avatar image Stefanie ♦♦ perstr commented ·
0 Likes 0 ·
perstr avatar image perstr Stefanie ♦♦ commented ·

Is Signalk embedded in node-red? It looked like the extended Venus-image was no longer downloadable. The Dropbox-file was missing (404-error). Hoped to run Signalk in same Rpi as Venus to fetch NMEA-data into Venus.

0 Likes 0 ·
Stefanie avatar image Stefanie ♦♦ perstr commented ·

Maybe a connection problem? I still can download from dropbox.

The large image basically has node-red two times. One within SignalK, which comes as plugin and can be deactivated. Then another node-red, which you can activate/deactivate (just like signalk) from the remote console on your GX device.

0 Likes 0 ·
perstr avatar image perstr Stefanie ♦♦ commented ·

Thas weird. I get at Dropbox error saying 404 this file no loner exist. Tried the URL's above (both) to download the larger image for Rpi. Tried both Safari and Chrome on a Mac. Tried from an iPhone via 4G, same error.

0 Likes 0 ·
Stefanie avatar image Stefanie ♦♦ perstr commented ·

Maybe you're looking at an older entry/version with link to dropbox?

Some parts of the thread is collapsed. So when you expand the view, 50+ more messages will appear...

Try this one: https://github.com/victronenergy/venus/issues/378#issuecomment-629419456

1 Like 1 ·
1 Answer
Stefanie avatar image
Stefanie answered ·

Hi @LaurenceH,

that's weird. For me it installs perfect using the offline install method. Even from a more recent version like 2.51 or 2.60~xyz I always can revert back to the Signal K/VenusOS version. Rpi 3B+ here too.

Maybe something in the offline install method went wrong? Here is the link to the howto, just in case you did not read that: https://www.victronenergy.com/live/ccgx:firmware_updating
It could also help to set "Update to" in the console to "Latest release".

Please also check /etc/signalk-server
AFAIK this should contain the service for Signal K. Ensure that the service has started.
Signal K path is: /data/conf/signalk


Are you on Slack? If so, you need an invite for the Victron/Signal K channel. Support there from one of the core devs for Signal K, who also is working on the integration with VenusOS. I would need your email address, if you want to join.

6 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

laurenceh avatar image laurenceh commented ·

Hi Stefanie,

Thanks for the quick reponse. If I’m on the right track - by taking a normal install and applying a signalk SWU I’ll try it again. I’ll take a look at some of the hints you have given.

Interestingly I had a Venus SD card that had been updated so I could boot as versio 2.51 or 2.42 but after attempting the SWU the firmware menu said there were no backup versions available.

I’m on slack so was ready to post my query on slack or Victron Comunuty. I joined slack today (As Laurence Hardwick) so I’ll see if I need more of an invite when I look tomorrow.

I’ll be at it again tomorrow.

Any further advice would still be welcome.


0 Likes 0 ·
Stefanie avatar image Stefanie ♦♦ laurenceh commented ·

Yes, I noticed the same that the menu said there is no backup versions available.
Dunno how this can happen. AFAIK there is max. of two firmware files possible. The one you ran previously before the update and the one you are running. Now when you copy another swu file to SD or USB (I use USB for update firmware) and update again, the first file is lost. Kinda like first in first out.

My guess is that after attempting the SWU, something went wrong, so it couldn't read the firmware file section. Could well be that the SD card has a problem.

0 Likes 0 ·
laurenceh avatar image laurenceh Stefanie ♦♦ commented ·

Stephanie

Still not working

Hi, I spent a few hours today and tried to get the signalk install working. I tried it on an installed, working, and configured copy of both Venus OS 2.42 and 2.51 on two different SD cards which I had in my Raspberry Pi with 7" touch screen. I formatted a brand new USB memory stick and put on to it a single file which is the SWU file located here : https://www.dropbox.com/s/7ynq8rpnwvui0sg/venus-swu-raspberrypi2-20191221133738-v2.50~2-signalk-1.swu?dl=0

I followed the instructions for offline update you mention above.

The SWU image was clearly recognised, Venus displayed the message something like "This storage device contains a software image and will not be used fro local storage"

In "Firmware Install from SD/USB", I pressed on "Press to install .....etc." And the display changed to "installing ...." when this finished the display went back to "Press to install .....". The system did not reboot or do anything else so I used the reboot option in the Settings-> General.

After this I found no changes in /etc there was no trace of Signalk-server, also nothing regarding systemk in /data/conf.

I don't know what to try to get it installed as you said it worked.

1) Are we sure the SWU file you used was exactly the same one I am using (as link above) ?

2) Anything special about the state of the Venus when doing the update e.g. ESS or DVCC enabled, Demo mode enabled or disabled ?

3) is the behaviour described above as expected "Press to install"->"Installing"->"Press to install" ?

4) Is it really necessary to do an offline Software update working is this not just a few files that need to be added?

Regarding Slack

I appear to have been enrolled in at least the "Server" and "Support" channels. Is there a Victron/signalk channel that I can't see and need an invite for ? Ill message you in slack with my email address.

Once I know which channel I should be posting in, I can start posting there.



0 Likes 0 ·
Stefanie avatar image Stefanie ♦♦ laurenceh commented ·

Hi @LaurenceH,

1) Yes. It's exactly the same SWU file.
2) No. That should not matter. At least it doesn't for me. I installed in various modes.
3) No. When installed correctly, it should reboot automatically and when you login back to remote console, it looks like this:

4) In this case, yes. Unless you have the full source tree and able to compile yourself. So until now you need either the SWU file or the image. It may change at some later point and hopefully we'll be able to do it online. But I don't think this will come soon. The Signal K support is more like a gift for the enthusiasts among us.
5) I will meet you in a few on Slack.

0 Likes 0 ·
laurenceh avatar image laurenceh Stefanie ♦♦ commented ·

Stefanie:

Thanks I’ll persevere, from the screen I guess you may not be in superuser mode?

Also you might not have tank and temperature sensors enabled ( so no dbus-adc files installed?) . So I guess I’ll go back to a clean 2.42 install.

(3) I now know it should reboot if it worked so will carry on till that happens.


Laurence

0 Likes 0 ·
laurenceh avatar image laurenceh laurenceh commented ·

I'm sorry I had to give up on signal K nothing I tried seemed to kick it into working - there was just no evidence of any files being installed after any update.


I am in the process of writing my own Ajax (Json) interface so that I can call from Javascript in the client to request particular data from the dbus so then an HTML call to get .

dbus-json.py?com.victronenergy.gps=Position/Latitude,Position/Longitude

From the Venus OS Rpi, Returns a Jason object with the requested data. Multiple values (and services) can be called in a single request and then displayed out in the client HTML. Im doing a bit more work on the client end with examples before I document it.

0 Likes 0 ·