jfosdick avatar image
jfosdick asked

BMV-712 Temp Sensor Reads "--"


FINAL UPDATE: Received new RJ12 cable in the mail today. Fully functional with a correct temp reading. Everything is good with the BMV712 now.


UPDATE 10/4/19: Received second Temp sensor, both (old and new) test identically. Added VE.Bus Smart Dongle to my Multi and noticed they use the same temp sensor on that. Test both on that and they worked like a charm. Reads 14*C on smart dongle. So temp sensors are 100%. Still waiting to recieve new data cable, will update then.



I have the BMV-712 hooked up to a 240ah 24v LiFePO4 battery.

I have the correct sensor I believe - Pictured below - ASS00010000

The red fused wire is plugged into B1 on the Shunt, the black wire into B2 and it is attached to the positive terminal on the battery. I am getting 27.3V over both sensor wires and 27.99 when I go direct off the battery bus (it was charging at the time of measurement).

The head unit is acting normally without issue except the temp will not register. I just get a "--" readout. What am I doing wrong? I specifically went with the Victron BMV so I could use the relay output to control the remote circuits on my inverter/charger and solar controller to shut down charging when it gets close to freezing.

I cannot find any breaks in the line for the temp wire or the data wire going to head unit. I've tested for continuity and everything comes out well.

What am I doing wrong? What can I test?

BMV Battery MonitorTemperature Sensor
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @jfosdick

Please confirm the part number you have, there is no ASS00010000.

ASS000001000 - Temperature sensor QUA/PMP/Venus GX

ASS000100000 - Temperature sensor for BMV-702/712

You've probably got the right one, but have to check the obvious stuff first.

0 Likes 0 ·
jfosdick avatar image jfosdick Guy Stewart (Victron Community Manager) ♦♦ commented ·

Thanks Guy. Attached is my original order list. Also a photo of the sensor itself. I don't have the packaging anymore but everything is pointing to the fact it should be the right one.

0 Likes 0 ·
2 Answers
Justin Cook avatar image
Justin Cook answered ·

@jfosdick, this is a bit of a new one to me... there's very little in the temp sensor that could possibly fail, and by all appearances you do have everything hooked up correctly. I suppose the one thing that I'd particularly suggest doing is replacing the fuse in the inline fuseholder... I haven't seen it on the temp sensor, but I've seen cases on the standard shunt PCB power supply cable where the little fuse "half-blows"... basically it's intact enough to allow some current through but not all, which ends up causing hinky little voltage drops that make the BMV readout go wonky. In your case, given that you have about 6/10 of a volt difference between the battery reading and the reading off your sensor wires, I think that maybe the sensor fuse is either not seated well in the fuseholder, is the wrong fuse, or is partially blown. Recommend putting in a new fuse (1A) and seeing if that fixes the problem... while you have the fuse out, by the way, check the insides of the fuseholder for any miniscule oxidation that may have built up inside, as I've seen that twice before and in both cases was enough to cause voltage drop, which with instruments as sensitive as the BMV and associated accessories, is enough to make them misbehave.

Good luck!

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

jfosdick avatar image
jfosdick answered ·

@Justin Cook So I popped it open and checked fuse contacts. They were bright and shiny. Fuse looked pristine but swapped it for another and got the same result. So then I just went rogue and joined the two fuse contacts together with an alligator clip and everything came back on exactly the same. Again lol. So not thinking it's the wire. Next simplest answer is data cable? Idk.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Related Resources