xrtx avatar image
xrtx asked

VRM app has stopped showing solar inverter input

Running a Venus GX. It's connected to a meter that provides data on the inverter generation. It has worked fine for years, but then the inverter generation only appeared intermittently, eventually never appearing. For a while, if I rebooted the GX, by unplugging its power, and 10 seconds later re-applying the power, the inverter would reappear within the VRM app. After a while, when it repearedly kept 'losing' the inverter, even the re-boot doesn't work. The feed from the meter appears to be working - well, the plug usually flashes as normal.

I'm thinking there is either an issue with the software on the GX, or with the hardware itself. I believe this because I had 'success' for a while, making the inverter reappear by the reboot method. This suggests that the meter is transmitting, that the cable is okay and the GX is receiving, and logging if only for a short while.

Does anyoine have any straightforward suggestions as to how I can determine where the issue lies, and maybe correct it?

Venus GX - VGX
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Alexandra avatar image Alexandra ♦ commented ·

Probably aso best to mention what meter it is?

If it goes missing from the GX device list though, it wont transmit to the VRM

0 Likes 0 ·
xrtx avatar image xrtx Alexandra ♦ commented ·


xrtx answered · 2 secs ago

It's a Carlo Givazzi 3 phase meter from Victron itself. As I mentioned, the Venus GX has worked with it previously (for years) without issue and recently after a number of reboots. Something has now happened and it has stopped registering the meter's presence. It could be a software update, I presume, or a hardware failure in the GX, the cable and plugs, or the meter.

I am pretty certain this is caused by a software update. The Victron USB/RS485 plug is flashing both green and red which suggests it is both transmitting and reading from the meter, but nothing shows up on the VRM app.

0 Likes 0 ·
1718458110466.png (1.3 KiB)
jetlag avatar image jetlag xrtx commented ·
You can check the meter with the Carlo Gavazzi configuration software UCS. If this is showing the values, then you at least know that the meter and the cable + the RS485 to USB adapter is working. Then it can only be the GX device, either HW or SW.
0 Likes 0 ·
0 Answers