question

betz avatar image

Ignore AC input over modbus / dbus?

I am looking for a way to just ignore the AC input.

I have modbus tcp and access to the dbus thru nodered, but I dont see how i would change that setting.

Currenlty i overwrite the settings manually every day with VEConfigure, but that is pretty painfull. :)

How can I achieve this and make some nice flows in nodered?

Modbus TCPNode-RED
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
Daniël Boekel (Victron Energy Staff) avatar image
Daniël Boekel (Victron Energy Staff) answered ·

I'm moving this post to the 'modifications' area, where more expertise is present.

Have you tried address 33? set to 'inverter only'?

com.victronenergy.vebus Switch Position 33 uint16 1 0 to 65336 /Mode yes 1=Charger Only;2=Inverter Only;3=On;4=Off See Venus-OS manual for limitations, for example when VE.Bus BMS or DMC is installed.

1 comment Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

thanks! that did it indeed.

I was thinking inverter only would still allow passthru, and I wanted to really be sure no frid is used.

But switching to 'inverter only' is perfect!

Alistair Warburton avatar image
Alistair Warburton answered ·

Can you not set the AC current limit to 0? Not sure it will accept 0 but I think it is available via Modbus.

Virtual switch with an assistant may be another option, again pretty sure that can be toggeled over Modbus and used to manage the ignore AC function.

I guess the last option is to set very low voltages in the charger so that it effectivly shuts down.

Very new to Victron myself but thus far performance looks good and access for automation/modification seems reasonable, although some of the documentation isnt great.

I discovered the other day that generator runtime is clocked up whenever the start signal is on, irrespective of weather the generator is actually runing and in spite of the generator failed alarm... Very odd... I want to track actual runtime so will be starting the run timer by switching the manual start on and off when an external PLC starts the genny. Tested this using Modbus and it works just fine. Not available using MQTT though at least not that I can find. Doc is wrong too in this respect.

Al

1 comment Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

you cannot set the current limit to 0. I thought it was 5 of I recall correctly.