question

julianbridgewater avatar image

EASYSOLAR 1600/12 toriod humming.

Hi there,- have a stand alone off grid EasySolar 1600/12.

It has PV and batterys,- they charge fine and are full.

There is NO connection to the mains grid.

There is a buzz / hum from the inverter [torodial transformer] which was not there when new.

The inverter works fine and produces power,- very nicely.

This hum is there even when the mains power output connector is unplugged from the bottom of the inverter [so not even wiring or socket connected!]

the hum is NOT the cooling fan,---this is stationary normally but does kick in under load.

The inverter did not make this noise when first fitted.

I would appreciate any advice but I feel that this unit should be returned to victron


Regards JULIAN.

EasySolar All-in-One
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
ejrossouw avatar image
ejrossouw answered ·

@julianbridgewater My MP IIs always humms ever so slightly even when not inverting and it becomes more noticeable under higher inverter load. Mine is a home installation and I'd always suggest to mount it out of "sight".

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Jaco Reinecke avatar image
Jaco Reinecke answered ·

Hi,

Not sure if my humming is your buzzing?

I have a Multigrid inverter. I hear a humming when it is inverting from batteries, which is perfectly normal.

Hopes this gives you an idea.

Regards
Jaco


Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.