t4abyss avatar image
t4abyss asked

bluesolar is turning off at night & charging through load output only

I have my bluesolar MPPT 75/15 controller (and ve direct usb dongle) in my campervan behind my drivers seat. Solar panel on the roof to PV in on controller, battery in put to positive and negative on battery under my seat, and load wired up to my leisure accessories fusebox. All polarity correct and It has been working great till around the recent fw update and I have had bizarre behavior since. :(

Issues are:

1) controller goes off at night, no leds lit, and subsequently load goes off (load is set to always on) my battery is reading 13.02v directly and at the screws on the controller.

2) in the day, when its back on, the voltage on the battery on the controller reads mismatched values like 3.53v and sometimes 0v. At the battery (2 meters used) its over 13v and on the controller screws

3) Also no charging seems to happen, no float voltage or charging routine on the battery (charging enabled on software)

4) Load was set to always on, I since disconnected unit to give it a 'reboot' and powered it back up (correct wiring order of load, battery, then solar). I tried with battery life setting also and I would get a voltage pulse of 6-12v on my load circuit (ceiling lights would flash!)

As a result, and needing power at night, I have removed the battery in + and put it on the same feed as the controller load + (distribution nut, not directly in the controller), as a result I now get power (no longer feeding off load) but also In the morning I noticed everything working as normal (bar the controller is now wired wrong, no + in on battery) so the charging routine is working, pv is measuring high watts when its charging and finally the float voltage is being applied. I've reset the settings to default and no change and also the 20a fuse is intact. Thanks for reading!

MPPT Controllers
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
wkirby avatar image
wkirby answered ·

This fault bears all of the hallmarks of a blown fuse, but you've checked that. I don't know the topology of that charger, but if the FET's are low side then what you have done with the B+ wire would work around the problem, but you now have no fuse protection.
Short of anything else to suggest, have you tried a different fuse? The fuse could be broken and is exhibiting an intermittent fault, tests fine when you remove it, but goes open circuit when installed in the MPPT.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

t4abyss avatar image t4abyss commented ·

My test to the fuse was simply continuity on the two small metal prongs at the top of the blade fuse. You know, that fuse is super tight! Guess I can get nasty with long nose pliers and give it a good tug!

How long is the warranty on these units people?

Thanks for your reply @WKirby

0 Likes 0 ·
t4abyss avatar image
t4abyss answered ·

Pulled fuse and it had blue plastic under the terminals, think it had got hot and almost short circuit and blew, but didn't. Anyway with a new 25a fuse normality is resumed, had to remove the unit from the wall and get some pliers on it to pull the fuse like I thought.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

wkirby avatar image wkirby ♦♦ commented ·

Good, I'm glad it's resolved. Thank you for letting us know!

0 Likes 0 ·
boekel avatar image boekel ♦ commented ·

You might have a bit to much load on the output, drawing through the fuse it heats up the fuse.

0 Likes 0 ·

Related Resources

Additional resources still need to be added for this topic