jibap avatar image
jibap asked

Newer Venus versions from 2.22 (Rpi) not working for me

Hi everybody !

I have VenusOS v2.22 which works perfectly on my RasPy and the newer version updated automaticaly few month ago when v2.23 was available (February) but i downgraded to v2.22 because some issues appeared...

I tried last week to check for the latest version (2.32) and the same issues encountered, i mean :

- AC Loads, sometimes display no value

- My Inverter is displayed "not connected"

In v2.22, i change only language in french (my language ;-)), and activate "has DC System" to log Inverter self-consumption, and it's all, no more configuration.

Why it not works in v2.32 ? Need some settings ?

Thanks you for help !

Venus OS
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
jibap avatar image
jibap answered ·

Finally, i updated in last version and all is OK, i think that the original issue was a firmwares compatibility between devices and Venus OS...

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

nebulight avatar image
nebulight answered ·

Interesting, I have a Pi and I don't have those issues (same settings but in English). My french is a bit rusty but maybe I can switch to French to see if I have the same issues.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

jibap avatar image jibap commented ·

It would be very surprising if these issues are due to language... What are your elements connected ?

I have 3 :

- BMV-700

- MultiPlus 48/3000/35-16

- BlueSolar Charger MPPT 150/60

Thx for your interest !

0 Likes 0 ·
nebulight avatar image nebulight jibap commented ·

I also have three:

BMV-712 with a to USB cable

SmartSolar 100/50 MPPT with a to USB cable

Multiplus 12/3000/50 with a MK3 to USB adapter

So far I haven't had any issues but there is no load on the inverter so I can't tell if there is a problem :(

0 Likes 0 ·
jibap avatar image jibap nebulight commented ·

So it's similar installation ... cool !

My inverter is well detected and displayed on principal monitor, but when i enter on it, it's indicated "Not connected"...

In v2.22, i have this :

0 Likes 0 ·
1562701859467.png (33.0 KiB)
nebulight avatar image nebulight jibap commented ·

My french is a bit rusty, but your screen shot says that it is connected.

You've got an older version of the firmware. Possibly upgrade the firmware of the Multi?

xxxx450 and up


  • All models added. (Most of the models were still on 433)


  • Introduced new model Compact 1600


  • Transfers additional model info to VECOnfig.

(required for external current sensors with MultiPlus-II)


  • Bug fix. Some models exhibit occasionally rejection of the grid


  • Fix false E11 “AC0/AC1 mismatch”, “UMains error”


  • Added support for new MultiPlus_II (with configurable AC-out2 relay)
  • Supports extended VE.Bus systems when GrideCode=None.
    (New required configuration tools will soon be released)
  • Supports readout of (amongst others) extended E11 info
  • Improvement to prevent false detection of GND relay failure under special circumstances.
  • When the gridcode imposes a certain power, this power is now imposed at the Inverter instead of at the input.
  • Improved speed of Power regulation during ESS
  • IPLog supported by all gridcodes. This IPLog contains info about the reason the grid is rejected. The Log stores the 5 last ‘rejections’.


  • MultiPlus-II only: Bug removed. When the unit is in AES it will not switch to grid when grid is connected.


  • Automatic power reduction due to a rising internal temperature now also works during PowerAssist.
  • Minor bug removed. (Under certain circumstances (temperature related) the power up ramp was limited too much for FeedIn/Charge. The ramping up could take about 5 minutes.)
  • Solved issue with Multifunctional relay. (Once closed it would never open again.)



  • Added SOC low shut-down functionality
  • During FeedIn the power is automatically reduced when the internal temperature rises.
  • Furthermore, when connected to grid, the unit switches to bypass before it gets too hot. This will prevent switching off.


Major overhaul. Required for grid code related reactive power regulations.
At this moment it is released for MultiPlus II/Multigrid II models only.

  • Added support for reactive power requirements in VDE related grid codes
  • Addresses an issue in 3 phase systems which resulted in E11
0 Likes 0 ·
multi.png (31.0 KiB)
nebulight avatar image nebulight jibap commented ·


  • Bug repair (Strange error codes in remote VEConfigure)


  • Supports weak LOM setting


  • Introduction of new 1200VA Compacts


  • Remote on/off state is stored in EEPROM. This will prevent deadlocks which could occur in Lithium systems with low cell voltage.
  • Added BOL (Battery Operational Limits)mechanism.
    This makes it possible to act on the battery state as reported by the battery.
  • Extended temperature compensation to -20°C
  • Removed password from ‘other: Not compliant to any grid code standard’
  • Prevents Error code 7 which could occur during startup in Multi compacts when used with a VE.Bus BMS
  • The Multifunctional, Break, K1 and K2 relays will not be driven when the device is switched off.


  • AS/NZS4777 compliance on a Multigrid 24V model
  • Subversion mechanism added


  • Improved LOM detection mechanism for multi phase systems.
    Reduces the chance for a false LOM detection on weak grids.


  • Introduction of AS/NZS 4777 grid code
  • A lot of ‘under the hood’ changes/improvements.


  • PowerAssist adjustment for Compact 12/2000/80-30


  • Introduction of MultiGrid models
  • Added VDE-AR-N 4105:2011-08 grid code for MultiGrid models.
    (no external protection relay required)


  • Introduction of 500VA models


  • Removed bug which in Hub4 could result in very high charge current (and permanent switch off) when Dynamic Cut-Off is not configured correctly.
    (Bug is introduced in version xxxx402)
  • Better performance in HUB-4 for PMains powers and set points > ±16K
0 Likes 0 ·
jibap avatar image jibap nebulight commented ·

Oh yes ! i'm in late !

I don't know how to update it, on MPPT and BMV i do updates with VE.bus to Bluetooth adapter but with Multiplus there is no ve.bus, only MK3...

How do you do that ?

0 Likes 0 ·
nebulight avatar image nebulight jibap commented ·

I'm not a dealer, installer or engineer, so do this at your own risk. I've upgraded my firmware twice and I didn't have any issues. If you are running a Pi and you set it up yourself, you should probably be fine, but do it at your own risk

You can get the firmware at

Make sure you read the directions carefully especially the first part:

0 Likes 0 ·
jibap avatar image jibap nebulight commented ·

Ouah ! yes it is not easy... I will think about ! It works now, i dont want to break my installation !

0 Likes 0 ·
jibap avatar image
jibap answered ·

Hello, there is news !

i'm still in v2.22, but from few weeks ago, the MPPT (PV load) disappear randomly...

If i reboot the venus OS, it is displayed again, and sometimes it reappear alone.

Any idea ?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Related Resources