question

hindssight avatar image

Not seeing Pylontech US2000B (Battery Monitor) in device list

Hello,


I have the following equipment installed:

1 x Quattro 48/8000 230V

2 x MPPT Smart Charge Controllers 250/100 MC4

8 x Pylontech US2000B Batteries

1 x Venus GX


The batteries are connected to the Venus through one Can port using the VE Can Cable Type B and the dummy plug is inserted in the other port. However, the Venus isn't recognising the Pylontech, it isn't shown in either the device list for the installation (usually shown under battery monitor) or in the device list section of the remote console.

Can-bus profile is set to Can-Bus BMS (500 kbit/s) and DVCC is enabled. Venus is on firmware 2.31 and Quattro is on 459.

Battery monitor under System Setup is set to Automatic but it appears to have auto selected the Quattro on VE Bus and the BMS is set as Off and doesn't give me the option to change it.


Please help me to enable the Pylontech BMS to act as the battery monitor.


Thanks


installationPylontech
3 comments
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Are you sure the battery is switched on?

Can you post some pictures of the installation, showing all the connections?

hindssight avatar image hindssight Guy Stewart (Victron Community Manager) ♦♦ ·

Thanks, i'll take some photos of the installation and the connections when I go back out there on Sunday, but this installation has been set up identical to two others with Pylontech batteries and in those the batteries are visible.


Should I attempt to reset the Quattro and Venus and reconfigure again to see if it takes?

Good to hear you have done this before and been successful.

If you are going back out on site, I would be prepared for a full troubleshooting process.

That means the ability to isolate exactly where the fault is.

Take a spare GX device, preferably a CCGX as it's easier.

Spare CAN.Bus to VE.Can cable.

Spare RJ45 UTP cables for between the module's link ports.

First try with the other GX.

Disconnect all the comms cables,

Then test each battery individually and see if it appears.

Test with both GX devices.

The MultiPlus/Quattro should have nothing to do with it. The batteries not showing up on the device list is between the GX device and the battery via the VE.Can/CAN.Bus.


Also remember 8 units is the limit before installation requires the Pylontech battery hub.

3 Answers
gary-c avatar image
gary-c answered ·

Hi I have the same issue with a multiplus 2. Ccgx and US3000 pylontech batteries. I rebooted the ccgx but not the inverter. Is that a requirement to detect the batteries on the ccgx. I have the correct cable and it's connected the correct way around. Any other suggestions. I will need to go back to site

2 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @gary c It should not be necessary to restart the multi.

There are many steps, such as setting the VE.Can port to 500kbps.

They are all listed here :

https://www.victronenergy.com/live/battery_compatibility:pylontech_phantom

nemo5 avatar image nemo5 Guy Stewart (Victron Community Manager) ♦♦ ·

Did you already solve your issue? As I have the same problem with same setup I wanted to know the solution.

jhass1 avatar image
jhass1 answered ·

I have the same problem. Did you get it resolved?

1 comment Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Do you use the "VE.Can to battery Can type B" cable in the right direction?

The VE.Can side at CCGX/Venus and battery Can side at the battery?!

Murray van Graan avatar image
Murray van Graan answered ·

Have you tried swopping the Can cable around and see if that has an effect? The cable has a battery end and a Venus device end as far as I know

1 comment Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thanks, I have tried this as well, to no avail.