question

eliott avatar image

CANvu with Quattro and BMV doubled each device on VRM

Hi!


I suspect that this is a bug. After a few weeks of normal working. The Quattro and the BMV have reappeared under new device ids. After restart of the CANvu one of the entries has disappeared from the CANvu menu.

It is still on the VRM but not updating.


Any ideas?


regards

eliott



CCGX Color ControlVenus OS
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi @Elliot, yes I have some ideas. It relates to USB id’s being re-assigned. That, combined with the device ids being derived from the usb ids.

For which we are working on a solution; it might take a while though (months).

Thanks for raising this. I wasn’t aware yet that this was an issue on the CANvu.

4 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi! in the meantime I managed to "reproduce" again. I think it happens after a power interrupt and restart. If I there is anything to test, just tell me.



hi @eliott, could you make a photo and post it here? Just to make sure we're talking about the same issue.


Other than that; there is not much to do other than wait I'm afraid.

eliott avatar image eliott mvader (Victron Energy) ♦♦ ·

Well, the devices seems to be breeding like rabbits. The best pace to see is on the VRM. So the devices with new IDs appear and the old ones become stale. It really happens more often than I thought, it seems that as opposed to what I thought you don't need to power cycle to happen.

1559923216071.png (59.1 KiB)
1559923290282.png (90.5 KiB)

Hi @eliott, ok thank you for the update.