question

bjorn-n avatar image
bjorn-n asked

MultiPlus-II ESS mode 2: doing it's own thing from time to time

So I use Mode 2 to set the grid set point. Using it for several months. From time to time, the MultiPlus-II completely ignores the grid set point and acts erratically. It switches between Bulk (charging) and Discharging every few seconds, and sometimes shows "PassThru" in the GX interface.

Normally this rarely happens (once every few months). Or at least, I rarely notice it happens. But recently, I noticed this behavior twice on a single day.

In the morning, the custom control had the grid set point set at 2690W. I noticed that the grid set point was not reached at all. Even though the battery was not full or there was any other obvious cause for this behavior.

The MultiPlus-II was drawing 1000-1200W from the grid at that point. Far from the 2690W requested. I switched to Mode 1 by disabling the custom control. The MultiPlus-II did not "recover" even though the grid set point was now fixed at 2690W for quite a few minutes. I finally ended up taking some screenshots before resetting the MultiPlus-II through the GX menu. After all was back up, the MultiPlus-II behaved nicely again and I re-enabled the custom control.

A few hours later, I noticed the MultiPlus-II was behaving erratically again, seemingly doing its own thing, completely ignoring the grid set point. I again disabled the custom control and set the grid set point to 0W manually (in the GX device). To no avail.

In stead of resetting the MultiPlus-II, I decided to try something different this time. I shut down an electric fan heater (consuming approx. 500W) and low and behold, the MultiPlus-II started honoring the grid set point!

I am collecting some key metrics of the MultiPlus-II like input and output voltage, current, frequency, power. When storing these metrics however, they get averaged out over 10 seconds. So the quick charging/discharging behavior is lost in the process.

I am using a MultiPlus-II 48/5000/70-50, firmware version 494. Any idea if there is a known firmware bug on this?

If not, would it help the firmware development team having "debug" data every second?

Multiplus-IIess grid setpoint not reached
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

sandebs avatar image sandebs commented ·

Hi Bjørn.

I'm also having some issues regarding the Victron systems doing its own thing and not following the grid setpoint at some times. I'm interested in hearing if you've found a solution yet.

I'm currently working on a project for my master's thesis where I'm developing a control algorithm for setting the optimal grid setpoint for a system located in Trondheim with both a large battery and PVs installed. The setpoint is calculated by taking into account power prices, temperature and solar radiation for the next day, so I would like the Multiplus to follow this setpoint as strictly as it can. The setpoint is updated every 5 minutes over MQTT.

I'm observing that the Multiplus does not comply with the setpoint. I've disabled Inverter power limit and battery charge limit.

An example I'm seeing right now: Battery is fully charged, PV power production is about 5000 W, AC load is 4000W, and the setpoint I've sent is -4000W. The actual grid level shows only -2000W, but I'd like to use even more of the battery power so that -4000W is sent to the grid.

Sander

0 Likes 0 ·
3 Answers
bjorn-n avatar image
bjorn-n answered ·

Here we are... almost one month later and again the same behaviour. The ESS software in the MultiPlus-II seems to know it better.

Here are some logs. Note that I have set the EssSetpoint to zero. Even after multiple minutes, the MultiPlus does not adopt this value.


"timestamp":"2023-05-01 12:16:26 [2023W18]"
"MPA":{"InputVoltagePhase1":"239.0","InputCurrentPhase1":"7.0","InputFrequency1":"50.10","InputPower1":"1390","OutputVoltagePhase1":"239.0","OutputCurrentPhase1":"4.4","OutputFrequency":"49.95","OutputPower1":"1340","BatteryVoltage":"49.58","BatteryCurrent":"2.8","BatteryPower":"138.824","StateOfCharge":"98.5","EssSetpoint":"0"} "SCA":{"BatteryVoltage":"49.57","BatteryCurrent":"4.2","BatteryPower":"208.194","PVVoltage":"66.64","PVCurrent":"3.3","PVPower":"216.2","YieldToday":"2.0","YieldYesterday":"5.9","YieldUser":"701.4"} "SCB":{"BatteryVoltage":"49.38","BatteryCurrent":"4.2","BatteryPower":"207.396","PVVoltage":"64.65","PVCurrent":"3.4","PVPower":"217.8","YieldToday":"2.0","YieldYesterday":"6.1","YieldUser":"633.1"} "timestamp":"2023-05-01 12:16:57 [2023W18]" "MPA":{"InputVoltagePhase1":"239.0","InputCurrentPhase1":"7.8","InputFrequency1":"50.10","InputPower1":"1410","OutputVoltagePhase1":"239.0","OutputCurrentPhase1":"4.9","OutputFrequency":"50.08","OutputPower1":"1440","BatteryVoltage":"49.58","BatteryCurrent":"-14.7","BatteryPower":"-728.826","StateOfCharge":"98.5","EssSetpoint":"0"} "SCA":{"BatteryVoltage":"49.60","BatteryCurrent":"4.4","BatteryPower":"218.240","PVVoltage":"66.85","PVCurrent":"3.4","PVPower":"224.9","YieldToday":"2.0","YieldYesterday":"5.9","YieldUser":"701.4"} "SCB":{"BatteryVoltage":"49.56","BatteryCurrent":"4.5","BatteryPower":"223.020","PVVoltage":"65.09","PVCurrent":"3.5","PVPower":"226.0","YieldToday":"2.0","YieldYesterday":"6.1","YieldUser":"633.1"} "timestamp":"2023-05-01 12:17:30 [2023W18]" "MPA":{"InputVoltagePhase1":"238.0","InputCurrentPhase1":"8.9","InputFrequency1":"50.10","InputPower1":"1390","OutputVoltagePhase1":"238.0","OutputCurrentPhase1":"4.6","OutputFrequency":"49.95","OutputPower1":"1460","BatteryVoltage":"49.64","BatteryCurrent":"8","BatteryPower":"39.712","StateOfCharge":"98.5","EssSetpoint":"0"} "SCA":{"BatteryVoltage":"49.63","BatteryCurrent":"4.7","BatteryPower":"233.261","PVVoltage":"65.19","PVCurrent":"3.6","PVPower":"237.8","YieldToday":"2.0","YieldYesterday":"5.9","YieldUser":"701.4"} "SCB":{"BatteryVoltage":"49.64","BatteryCurrent":"4.7","BatteryPower":"233.308","PVVoltage":"65.22","PVCurrent":"3.7","PVPower":"238.9","YieldToday":"2.0","YieldYesterday":"6.1","YieldUser":"633.1"} "timestamp":"2023-05-01 12:18:00 [2023W18]" "MPA":{"InputVoltagePhase1":"238.0","InputCurrentPhase1":"7.8","InputFrequency1":"50.10","InputPower1":"1460","OutputVoltagePhase1":"238.0","OutputCurrentPhase1":"4.8","OutputFrequency":"49.82","OutputPower1":"1440","BatteryVoltage":"49.68","BatteryCurrent":"-35.6","BatteryPower":"-1768.608","StateOfCharge":"98.5","EssSetpoint":"0"} "SCA":{"BatteryVoltage":"49.70","BatteryCurrent":"5.0","BatteryPower":"248.500","PVVoltage":"64.90","PVCurrent":"3.9","PVPower":"255.4","YieldToday":"2.0","YieldYesterday":"5.9","YieldUser":"701.4"} "SCB":{"BatteryVoltage":"49.71","BatteryCurrent":"5.0","BatteryPower":"248.550","PVVoltage":"64.27","PVCurrent":"4.0","PVPower":"256.0","YieldToday":"2.0","YieldYesterday":"6.1","YieldUser":"633.1"}

Why does the MultiPlus ignore the ESS Set Point completely??

Setting it to another value, like 100W in this example, doesn't seem to have no effect at all. I already reset the MultiPlus-II and it keeps doing this.

"timestamp":"2023-05-01 12:24:56 [2023W18]"
"MPA":{"InputVoltagePhase1":"235.0","InputCurrentPhase1":"15.5","InputFrequency1":"50.10","InputPower1":"3350","OutputVoltagePhase1":"235.0","OutputCurrentPhase1":"13.3","OutputFrequency":"50.08","OutputPower1":"3550","BatteryVoltage":"49.26","BatteryCurrent":"4","BatteryPower":"19.704","StateOfCharge":"100.0","EssSetpoint":"100"} "SCA":{"BatteryVoltage":"50.17","BatteryCurrent":"10.7","BatteryPower":"536.819","PVVoltage":"65.69","PVCurrent":"8.3","PVPower":"548.6","YieldToday":"2.1","YieldYesterday":"5.9","YieldUser":"701.4"} "SCB":{"BatteryVoltage":"49.82","BatteryCurrent":"10.7","BatteryPower":"533.074","PVVoltage":"64.67","PVCurrent":"8.3","PVPower":"550.4","YieldToday":"2.1","YieldYesterday":"6.1","YieldUser":"633.2"} "timestamp":"2023-05-01 12:26:19 [2023W18]" "MPA":{"InputVoltagePhase1":"240.0","InputCurrentPhase1":"11.8","InputFrequency1":"50.10","InputPower1":"810","OutputVoltagePhase1":"240.0","OutputCurrentPhase1":"3.4","OutputFrequency":"50.08","OutputPower1":"1200","BatteryVoltage":"50.30","BatteryCurrent":"1.0","BatteryPower":"50.300","StateOfCharge":"100.0","EssSetpoint":"100"} "SCA":{"BatteryVoltage":"50.45","BatteryCurrent":"7.1","BatteryPower":"358.195","PVVoltage":"76.41","PVCurrent":"4.7","PVPower":"356.6","YieldToday":"2.1","YieldYesterday":"5.9","YieldUser":"701.4"} "SCB":{"BatteryVoltage":"50.20","BatteryCurrent":"8.4","BatteryPower":"421.680","PVVoltage":"74.93","PVCurrent":"5.9","PVPower":"442.1","YieldToday":"2.1","YieldYesterday":"6.1","YieldUser":"633.2"}

The battery state of charge is 100%, so there is plenty of energy (and power) available for the MultiPlus to draw from the battery in stead of the grid.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

bjorn-n avatar image
bjorn-n answered ·

screenshot-at-2023-05-01-14-43-02.png

The yellow line is the ESS Set Point value. The blue line is the effective power on the input. As you can see, between 14:15 and 14:27 these values do not correspond at all.

Please note that the time in the graph is UTC+2 and the time in the json is UTC. So 14:00 UTC+2 in the graph corresponds with 12:00 UTC in the json.

And then... all of a sudden it "fixes" itself... I have no clue why the MultiPlus-II is showing this behaviour.

"timestamp":"2023-05-01 12:29:20 [2023W18]"
"MPA":{"InputVoltagePhase1":"242.9","InputCurrentPhase1":"2.6","InputFrequency1":"50.10","InputPower1":"100","OutputVoltagePhase1":"242.9","OutputCurrentPhase1":"7.1","OutputFrequency":"50.08","OutputPower1":"1170","BatteryVoltage":"49.10","BatteryCurrent":"-23.0","BatteryPower":"-1129.300","StateOfCharge":"100.0","EssSetpoint":"100"}
"SCA":{"BatteryVoltage":"49.10","BatteryCurrent":"7.3","BatteryPower":"358.430","PVVoltage":"64.43","PVCurrent":"5.8","PVPower":"371.9","YieldToday":"2.1","YieldYesterday":"5.9","YieldUser":"701.5"}
"SCB":{"BatteryVoltage":"49.11","BatteryCurrent":"7.5","BatteryPower":"368.325","PVVoltage":"64.56","PVCurrent":"5.8","PVPower":"378.4","YieldToday":"2.1","YieldYesterday":"6.1","YieldUser":"633.2"}

And once it recovers, it stays ok. Even when the MultiPlus output draws 3000+W of power.

"timestamp":"2023-05-01 12:35:11 [2023W18]"
"MPA":{"InputVoltagePhase1":"241.9","InputCurrentPhase1":"4.1","InputFrequency1":"50.10","InputPower1":"210","OutputVoltagePhase1":"241.9","OutputCurrentPhase1":"19.2","OutputFrequency":"50.08","OutputPower1":"3820","BatteryVoltage":"46.46","BatteryCurrent":"-83.7","BatteryPower":"-3888.702","StateOfCharge":"99.0","EssSetpoint":"128"}
"SCA":{"BatteryVoltage":"46.78","BatteryCurrent":"4.0","BatteryPower":"187.120","PVVoltage":"62.47","PVCurrent":"3.0","PVPower":"189.8","YieldToday":"2.1","YieldYesterday":"5.9","YieldUser":"701.5"}
"SCB":{"BatteryVoltage":"46.78","BatteryCurrent":"4.0","BatteryPower":"187.120","PVVoltage":"63.90","PVCurrent":"3.0","PVPower":"193.1","YieldToday":"2.2","YieldYesterday":"6.1","YieldUser":"633.2"}

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

bjorn-n avatar image
bjorn-n answered ·

Even over a period of multiple hours, the MultiPlus does not always meets the target. Again: the yellow line is the target ESS Set Point, the blue line is the input power.screenshot-at-2023-05-01-17-51-23.png

In theory, the blue and yellow line should overlap all the time.

However, when the battery is full it is ok for the blue line to be below the yellow line.


The blue line should never be above the yellow line. Maybe for a few seconds but not for minutes at a time. Unfortunately, this is what happens from 15:00 till 16:10, and from 16:20 till approximately 17:15.


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Related Resources

Additional resources still need to be added for this topic

MultiPlus-II Product page 

MultiPlus-II Manual

MultiPlus-II 230V Datasheet 

VE.Bus Error codes