wim-immelman avatar image
wim-immelman asked

AC and DC Coupled Grid-Tied System, PV Inverter throttled incorrectly

To all the experts or struggling enthusiasts like myself - I really hope someone can enlighten me as to why my system is suddenly behaving this way:

My setup:

  • 2x5kva MultiPlus II Inverters - 48v grid tied system
  • 4.5kW PV via a SolarEdge HD Wave 5kW PV Inverter - AC Output coupled
  • 6kW PV via a Victron 250/100 MPPT charge controller

Recently (which could relate it to a firmware update), my PV Inverter is getting throttled when my Critical Loads exceed a certain value (about 4kW). My battery is not full (83% in this case) and my PV Charger (MPPT) does not bring enough power to sustain my loads and charge my battery. This leads to my battery actually discharging while the sun is at max:


What is interesting is that when my critical loads decrease, to say 2kW, the PV Inverter kicks in again. This also happens when I add an AC Load (on the AC input side). Discussing this with a friend lead us to consider maybe the Factor 1.0 rule applies, but surely this should not apply as my PV on the AC Coupled side is only 4.5kW. But something makes me think that it has to do with either:

  • Prioritizing the DC coupled over the AC coupled (which does not make sense to me), or
  • It's trying to protect the system from an potential overload if the loads suddenly disappear

What is also interesting is that when the grid is off (this happens due to our lovely nationwide loadshedding) the PV inverter produces as expected and does not get throttled:no-grid-all-is-good.jpg

I'm running ESS assistant and feed-In is switched off (I'm not feeding back into the grid). There seems to be no frequency shifting happening in these cases (based on my VRM analysis, so I'm assuming the Multiplus or GX is communicating with my SolarEdge PV Inverter via modbus.

Can anyone please help me explain this phenomenon?

Previously @Izak (Victron Energy Staff) from Victron has been super helpful in diagnosing a comms issue between SolarEdge and the GX device, so I have all the faith in this community :)

AC PV Coupling
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

6 Answers
Alexandra avatar image
Alexandra answered ·

@Wim Immelman

Frequency (seen in vrm) shifting only happens on the victron when no grid is connected as it synchronises to grid. It is usually controlled by modbus or the comms when grid is connected.

Does it pick up if the dc pv is disconnected?

What firmware did you update? Have you tried going back to the older firmware?

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

wim-immelman avatar image wim-immelman commented ·
Thank you Alexandra - the frequency shifting only when grid is missing makes sense (and I now recall that the installers mentioned this back in the day).

I've tested so many scenarios, so I will go and double check if it picks up if the DC PV drops - it would be a good test. The DC PB is the only switch I cannot switch on or off from my Home Assistant instance, so I haven't walked out to the garage to the solar combiner to flip the physical switch :)

I've tried a few versions back firmware (think it was v2.80), but it has the same behavior. Currently my SolarEdge and Victron components are all on the latest versions.

0 Likes 0 ·
Izak (Victron Energy Staff) avatar image
Izak (Victron Energy Staff) answered ·

Hey @Wim Immelman , the short answer is that we cannot limit Solar Edge inverters because they don't implement the required part of the Sunspec protocol to allow for that. So I can assure you with perfect certainty it isn't limited in software from our end!

I see it in your data, from yesterday around 10:15. The state is reported as "Throttled", and this state conspicuously change exactly when the power reduces to zero. Do you perhaps use another separate method of limiting the SolarEdge inverter? Because that's where you should start looking then.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

wim-immelman avatar image wim-immelman commented ·

Hey @Izak (Victron Energy Staff)! It's really nice to get a comment from you so quickly and thank you for looking at my actual data.

To be honest, I'm not sure if there is another "method" limiting my solaredge inverter. It has it's own Grid Meter installed, and it's "Export Control" settings are a bit confusing to me on their app - but I'm no expert, so that could just be my understanding. @Andrew Ellis below mentioned high voltage and my grid voltage is on the high side between 239V and 241V, but I think it might still be within limits. I will look at the SolarEdge app to see if there are any voltage based limits that might apply. I do not see any correlation to the SolarEdge being throttled and the AC Input voltage changing much.

I used to be able to feed back into the grid and then all was good, but recently the situation changed and I no longer feed back to the grid.

I'm struggling to see historic values for the SolarEdge PV Inverter on VRM - I assume you have a better view of logs. Is there any way for me to get more detailed logs from VRM over and above the Advanced Graphs section?

Here is an example at 13:09 (today) of it happening again - PV Inverter throttled, Battery discharging, MPPT trying it's best still


And at 13:30, an AC load of 3.4kW was introduced, releasing the throttling on the PV Inverter


0 Likes 0 ·
1674215683306.png (208.5 KiB)
1674215769901.png (203.1 KiB)
wim-immelman avatar image wim-immelman wim-immelman commented ·

Just to confirm - you are saying is that the ESS Assistant / GX / Multiplus / Victron components are not throttling the PV Inverter? If so, it should be SolarEdge itself somehow?

I've read post where you assisted @ThomasW. with a similar issue, but with a Fronius inverter. Firmware update 2.65 seems to have addressed his concerns :)

0 Likes 0 ·
Andrew Ellis avatar image
Andrew Ellis answered ·

Is it set up with the APS relay? It might be in the opposite sense for some reason. What's the display showing on the solar edge? Go to the part for testing the APS. You can see on the Solaredge if it is on the countries grid mode or not. I'd be surprised if it throttles though as the grid frequency would have to be usually high to cause it to happen. Maybe its set up with voltage response?

Also the units will throttle if the local voltage rises outside of the grid limits. What's the voltage at the unit? I had a voltage problem occasionally cutting out the solar edge when it was sunny and windy. All the local turbines raised the voltage too much. I ended up having the transformer retapped to lower the voltage to my house

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

wim-immelman avatar image wim-immelman commented ·
Thank you @Andrew Ellis for your SolarEdge tips. I'm not sure if it's setup with APS - will check this afternoon when I get home. I will also look for any voltage related stabilization. Unfortunately, I do not have access to any SolarEdge detailed logs.

Do you know how I could get hold of any logs that would tell me why the inverter is being throttled?
0 Likes 0 ·
Andrew Ellis avatar image Andrew Ellis wim-immelman commented ·
The other thing you could check is where the CT clamp for the solar edge is located and is it the right way round. Do you have an export limit for the site?
0 Likes 0 ·
wim-immelman avatar image wim-immelman commented ·

@Andrew Ellis I finally managed to connect to the SolarEdge and grabbed a screenshot of every setting that I think can be important to this challenge.

From what I can see, I have "Export Control" enabled:


But set to 0 W:


I assume this is to prevent grid feed-in.

Under Storage Control, AC Charge Limit is set to "No Limit"

Under Advanced Energy Production, External Production is set to "Disabled"

Then Reactive Power is set to "CosPhi"


And active power is set to:


Advanced Power Control:



I also have Alternative Power Source set to "Generator" with similar frequency and voltage rules:



My SolarEdge Inverter Versions:

CPU Version


DSP1 Version


DSP2 Version


Meter Version


WSA Version


Serial Number


I'm at a loss at the moment and my only costly answer is to get rid of the SolarEdge Inverter completely as it's actually being counter productive when my critical loads exceed a certain value.

@Izak (Victron Energy Staff), what could be causing, that during this scenario (when the PV Inverter is being thottled), when I increase the grid setpoint, to something like 300W, the PV Inverter kicks in again and starts producing? I then later have to set the grid setpoint back down to 80-100W, else I keep drawing unnecessarily from the grid

0 Likes 0 ·
1674570110103.png (99.6 KiB)
1674570201818.png (62.6 KiB)
1674570411620.png (97.8 KiB)
1674570434547.png (109.3 KiB)
1674570581204.png (92.9 KiB)
1674570599582.png (77.6 KiB)
1674570775538.png (25.3 KiB)
1674570788409.png (54.1 KiB)
Izak (Victron Energy Staff) avatar image Izak (Victron Energy Staff) ♦♦ wim-immelman commented ·

A setup like this, with two conflicting limiting technologies, is not really supported, and the reason why it is not supported is precisely that they conflict and end up in a deadlocked state like this.

You can sometimes work around this by raising the ESS grid setpoint, as you discovered. If the SolarEdge limiter is trying to push grid consumption down, while the Victron system is trying to pull it up, this "touwtrekkerij" (if I can use the Dutch, I'm sure you understand) avoids the dead spot where one of them shuts down.

Perhaps see if the problem clears with an older GX firmware. Sadly not much I can do here as this combination is not really supported.

0 Likes 0 ·
Andrew Ellis avatar image Andrew Ellis Izak (Victron Energy Staff) ♦♦ commented ·

I'm about to have this setup myself and I was under the impression it would work as there are quite a few papers about setting up the SolarEdge with the Victron. I shall be very frustrated if it doesn't as I can't even reuse the panels in an MPPT as they have integrated solar edge power power optimisers. I'll let you know if it works or not but it will be hard to see if there are any problems at the moment as there isn't much sunshine.

I haven't seen any other people with your problem so hopefully there is something else in your setup causing this issue.

0 Likes 0 ·
wim-immelman avatar image wim-immelman Andrew Ellis commented ·
I haven't seen many other posts either, so hoping it's a settings somewhere on the SolarEdge side perhaps. I'll keep looking and will post if I find a solution.

Thank you for the feedback @An

0 Likes 0 ·
Andrew Ellis avatar image Andrew Ellis Izak (Victron Energy Staff) ♦♦ commented ·

Izack, looking at your explanation, does it make a difference if the solar edge is on the AC IN side of the Victron or the AC OUT?

0 Likes 0 ·
wim-immelman avatar image wim-immelman Izak (Victron Energy Staff) ♦♦ commented ·
Thanks @Izak (Victron Energy Staff) . I feel stupid, but I tried uploading older firmware - oldest I can find is 2.88, but my Cerbo does not seem to find the SWU files on my USB or MicroSD cards... not my best week for troubleshooting things.

Also thank you for the explanation about the "toutrekkerei" - I understand the logic here, but I'm still confused why I do not see many other such scenarios (or posts about it). I also do not understand yet why when the AC Loads increase, the SolarEdge kicks in again?

0 Likes 0 ·
andy156 avatar image andy156 wim-immelman commented ·

Have you checked if the relay is still functioning that triggers the APS mode in the solar edge. There will either be a wire to one of the relays in the Multiplus or a separate device. If you simulate a power cut then obviously everything works. On the display of the Solaredge you should see that country code: is 'gen' or 'dg' . If you now reintroduce the grid this should change back to your country. If you scroll through the info screens on the solar edge you can find this. If this isn't changing then that could be causing issues.

The Multiplus controls the frequency to control the SolarEdge in APS mode. The grid sets the frequency normally so the Multiplus doesn't do anything to the Solaredge at this point. Where are all the CT clamps? Have any been moved and reattached recently?

0 Likes 0 ·
klausr avatar image
klausr answered ·

Hi, it would be awesome if Victron could implement a Solaredge limiting by Modbus TCP.

Technically that works pretty easily, just one single write to Modbus Address 0xF001 with a 0-100 value.

I'm using that currently with an own external running script and it works pretty nice, the Solaredge inverter reacts very fast and very accurate to the given limit (except for limit=0, then it takes some time until controlling will be possible again, so a dynamic control should better operate only between 1 and 100).

I have already made a feature request here:
Would be nice to get some feedback on that.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

wim-immelman avatar image wim-immelman commented ·
Now that sounds like a great idea and thank you very much for sharing the details.

I'm running Home Assistant and already control the Cerbo via Modbus, however I cannot get connect to the SolarEdge's modbus via TCP for some reason - I'm not sure why, but the port simply does not respond.

I might ping you again if I finally get access.

0 Likes 0 ·
klausr avatar image klausr wim-immelman commented ·


the problem is that SolarEdge allows only one Modbus TCP connection!
So when Cerbo is already connect, no second connection is possible.

As 'workaround' I have used one of the RS485 connections (also set to Sunspec) on the SolarEdge and a Waveshare RS485 to RJ45 adapter to get a second Modbus TCP connection. This way two Modbus TCP connections to the ShareEdge inverter are possible - one for Victron/Cerbo and one for my Homesystem and custom script to control the power-limit. Works very fine.

But that's also another reason why an build-in SolarEdge/Victron integration would be awesome, it would avoid the hurdle with the second connection.

0 Likes 0 ·
wim-immelman avatar image wim-immelman klausr commented ·
@klausr Thank you again for the explanation - I will surely do something similar using the RS485 port.
0 Likes 0 ·
kyros32 avatar image kyros32 klausr commented ·

@klausr yes, very suboptimal, but modbus throttling WOULD improve Victron/Solaredge integration. You can always free up Modbus TCP/Ip port when you use ET340 - so you have it ready for external BMS. The problem now is that 90% of times we are in a scenario when only Cerbo-Solaredge comm is needed, you still run into lots of issues when throttling is not available:

I better explain it here:

Could someone from Victron look into this and integrate Modbus throttling when in grid-tied operation? Gpio cant be used to limit export to grid when APS is set up according to manual.

Thank you.

0 Likes 0 ·
Mark avatar image Mark commented ·


I was able to extend dbus-fronius myself and make it work for solaredge inverters, maybe you could help with some testing as I only have access to my own system with a single solaredge inverter.

See this post if you are interested.



0 Likes 0 ·
andy156 avatar image
andy156 answered ·

You have zero feed in defined in the Solar Edge menu. If you look at your first graphic you have 217W going to the grid for whatever reason. The SolarEdge will throttle until this isn't happening. You need to check that the Multiplus has all the feed in settings disabled.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

wim-immelman avatar image wim-immelman commented ·

Thanks @Andy156 for confirming that SE will throttle if there are no AC loads. I definitely have both feed-ins disabled in ESS:1675170072084.png

The -217W might have been temporary as the AC + Critical loads fluctuate. It takes a few seconds for ESS to adjust the PV charger accordingly. This is influenced by the grid setpoint as well (as far as I know), so I'm playing with the setpoint (temp boost) now to fool the pv inverter into thinking there is an AC load.

0 Likes 0 ·
1675170072084.png (31.6 KiB)
Andrew Ellis avatar image
Andrew Ellis answered ·

Where is the clamp for the solar edge located? Is there an export limit?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.