klandos avatar image
klandos asked

Faulty Multiplus II internal measurement sensor?


I'm running 3 Multiplus II 5000 parallel in an offgrid installation controlled by a Cerbo GX. All PV is DC coupled.

As the winter is coming I need from time to time assistance from a generator.

My problem is that the input current limit feature is not working anymore.

Please see attached pictures:


You can see drawing 4,4kW from the genset, but 0A. On top a weird -7.3A on the outside.

bildschirmfoto-2022-12-01-um-143518.pngFor testing I at the moment I started EV Charging with 3.6kW + 0.5kW house load. So this AC Loads value can't be right on top. Double checked with a AC Clamp meter.

What I now have done in first step is to reduce the Charger Amp limit in the Multiplus to 10A (in fact 30A as there are 3x Multiplus) through victron connect so that even localization of the failure is possible.

The input current limit doesn't take any effect. Even tried to re set this through victron connect and also disabled "can be overruled by remote" with no effect. Sure I set this on the master and both slaves. 6 A in each device which should end up in 18A (around 4,1kW).

This definitely had worked half a year ago.

For me it seems that at one of the multiplusses the internal measurement is not working anymore.

Any other thoughts?
Could it help to rearrange them with another being the master?

Firmware is 490 on the multis.

The Multiplusses are 11 month old and bought in germany. The problem is that I won't get any support from the (official) seller. I already hat a faulty battery from them where they already didn't do anything, so my lawyer is on this :(

Thanks in advance.

Multiplus-IImultiplus in parallel
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

klandos avatar image klandos commented ·

News on this, my thought seems to be right.

I've viewed with ve configure, master:




For me it seems clear that the internal measurement on slave1 is faulty.

I double checked with a AC clamp meter, equal current is flowing to each multi.

Any other thoughts?

How can I go further now?

My original seller do not care.

How is the measurement internally done? Printed on PCB or maybe changeable? If changeable, is Victron willing to sell the part? The Multiplus is not a year old, but I would prefer pay a bit for the part than throwing 1,5k+ € away. Does anyone have a contact for me? @Guy Stewart (Victron Community Manager) maybe?

0 Likes 0 ·
master.jpg (276.6 KiB)
slave1.jpg (1.2 MiB)
slave2.jpg (312.6 KiB)
1 Answer
nickdb avatar image
nickdb answered ·

Have you considered reflashing them with current firmware first?

If you search on this site you will find the form in where you can submit your serial number and find out who the distributor is.

If it is under warranty, you can return it to them for testing.

There are no user serviceable parts inside the device.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

klandos avatar image klandos commented ·
Not yet thought about a firmware update because this setup ran perfectly half a year ago.

Are there know problems with the internal measurement at 490 firmware?

0 Likes 0 ·
nickdb avatar image nickdb ♦♦ klandos commented ·

Not specifically, no.

Something else you can try, is to insert a mini phono jack into the external current sensor jack socket of that inverter and just insert/remove it a few times.

Beyond that, I would still reflash it and failing an improvement get it back to the original distributor your seller originally got it from.

0 Likes 0 ·
klandos avatar image klandos nickdb ♦♦ commented ·
​I’ll try with phone jack and reflashing.

Already filed a case, thanks!

0 Likes 0 ·
klandos avatar image klandos nickdb ♦♦ commented ·

Update on this:

inserting phone jack does not help.

After that I updated all multis from 490 to 498.

In the first try victron connect that the update has been successfully but they've been more or less "bricked" and couldn't be found by VictronConnect nor ve configure. Curious that the Faulty Multiplus had different LEDs showing.

I had to start the update again (has been possible in victron connect with "force update").

After that I were able to reconfigure them at one phase three parallel units.

The good news, power assist is working (at the moment). The bad news, the internal measurement of the Faulty Multiplus still doesn't work. When the multis are connected to grid:



As the update has been really weird and only worked in the second try, maybe a bad flash chip instead of the measurement itself?

During reconfigure I had changed the order (master /slave1/slave2)

@Guy Stewart (Victron Community Manager) how can we sort that out now?

0 Likes 0 ·
img-6515.jpg (189.5 KiB)
img-6516.jpg (193.3 KiB)
klandos avatar image klandos klandos commented ·
So, anyone an idea how I can get help?

@mvader (Victron Energy) @Guy Stewart (Victron Community Manager) maybe?

I know the seller should help, but please read my first post. Already have a warranty case open there which my lawyer is on after 3/4 year :(

So for the Victron part it would be cheaper for me to buy a new one, burn the old one and post the video on YouTube.

Don’t get me wrong, I love Victron products, but how to get help when the dealer is bullshit?

Just any (official) answer would help if there will be help from Victron or not.

1 Like 1 ·
Guy Stewart (Victron Community Manager) avatar image Guy Stewart (Victron Community Manager) ♦♦ klandos commented ·

It is nearly always best to go through your original dealer, but when that is absolutely not possible the 5 year warranty for your Victron product is backed by Victron and support is available through any of our service agent network.

Please fill out this form with a link to this thread showing your procedures and explaining the situation and there should be a path to resolution.

For our part, sorry for the issues btw

At a low level the CT is a very simple part that is extremely unlikely itself to fail (it's a passive element), however it is possible for it's connection to the circuit board to become disconnected. We do not offer any end-user advice in how to repair this as it can be dangerous in there, or possible to damage other components which could cause other issues (and then not be covered by warranty).

So best to work with the service network via the support form.

0 Likes 0 ·
klandos avatar image klandos Guy Stewart (Victron Community Manager) ♦♦ commented ·

First of all thank for you reply @Guy Stewart (Victron Community Manager)

I already filled the form on 03.12. and waiting for reply since from victron. There is already a link to this thread in. Even got the "rate your experience" email if I'm happy or not (sure you can think what I am...)

And it is absolutely no problem if there is a problem. It's just the way it will be sort out.

0 Likes 0 ·
klandos avatar image klandos Guy Stewart (Victron Community Manager) ♦♦ commented ·
Hello @Guy Stewart (Victron Community Manager)

Till now no answer from victron against the support form I filled on 03.12.

Sure the error still exist.

We are now 16 days after creation. How many weeks should this normally take?

Wish you a merry Christmas!

0 Likes 0 ·
Guy Stewart (Victron Community Manager) avatar image Guy Stewart (Victron Community Manager) ♦♦ klandos commented ·

That process is still dependant on our support network of distributors, so it is not so easy to say how long it should normally take. But for sure 16 days is too long without a response.

I will see what I can do to escalate your case internally, I don't have any special access myself, but can ask.

Unfortunately while early December should have been plenty of time, now we are well into the holidays - so would also expect even further delays. Apologies again :(

0 Likes 0 ·