bertus avatar image
bertus asked

BlueSolar Charger 75|15 and VE.Direct connection issue


I have a BlueSolar Charger 75|15 and I need some help to get it going. I hope you will be able to help me.

In the past I connected the charger device between my battery and solar panel. The LEDs were blinking and on, so I assumed it worked. I did have some doubts though while my battery went empty on a sunny day. Therefore I purchased last week both a VE.Direct Bluetooth Smart dongle and a VE.Direct USB dongle. After connecting these devices (one at the time) to the BlueSolar charger, I am not able to connect. What do I do wrong?

The device: BlueSolar charger MPPT 75 | 15, PN SCC010015050R, V1.08

What I did:

On my Windows 10 notebook, I connected the VE.Direct USB dongle and stated Victron Connect. It reports “No Devices Found”. I verified the installation of the USB drivers, which went well. I tried installing and connection it to my mac book air, same results.

I replaced the USB dongle with the VE.Direct Bluetooth Smart dongle and installed the VictronDirect software on my iPhone 6. The Bluetooth dongle was recognized instantly, and a firmware download started. This went well and according the instructions. After the firmware update, the VictronDirect list shows my BlueSolar charger. I can tab it and the iPhone starts connecting. A progress bar appears and moves from 0 to 100%. After completion, this process apparently starts over, but now the progress bar remains stuck at 0%. It remains in this state. When tapping ‘back’, the program gets back to the devices menu, where is now shows “VE.Direct Bluetooth Smart dongle”. Instead of the BlueSolar charger. By restarting the app, this process can be repeated.

On the VE.Direct Bluetooth Smart dongle the red error LED flashes at a rate of about 0.5Hz while performing the connecting activities.

What is wrong? What do I need to do to get it working?

Thanks, Bert

MPPT ControllersVE.Direct Bluetooth Smart Dongle
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
mvader (Victron Energy) avatar image
mvader (Victron Energy) answered ·

Hi Bert, this is a bit of a long shot, but worth a try: since v1.08 is quite an old version, try using our previous tool; from before VictronConnect; to get the mppt up to date.

1) download VE Power Setup from our website. Ignore that the exaining text speaks about VE.Can only.

2) use the usb/vedirect cable; and start VE Power Setup.

Does it find the mppt? If it does, update it: you’ll have to download the right file for that from

I hope this works out; please let me know what happened.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

bertus avatar image bertus commented ·

Thanks a lot! It worked J

Th usage of the VE Power Setup was a bit confusing as indeed only VE.can is mentioned and the MTTP controllers are not listed in the supported list. After starting the VE Power, it started scanning for the VE.Direct and found the connected MPPT controller instantly.

I downloaded the firmware and selected it in VE Power. The updated started and ended successfully.

Next I started the VictronConenct software and it connected right away to the MPPT controller and showed the status. After swapping the USB cable with the Bluetooth cable, I was able to read the status on my iPhone. Yes!

So, eind goed, al goed.

Thanks for the support.


0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ bertus commented ·

Fijn! goeie avond


0 Likes 0 ·

Related Resources

Additional resources still need to be added for this topic

MPPT Product Page

MPPT Error codes

MPPT 150/60 up to 250/70 Manual